summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-01-26 08:51:19 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-01-26 08:51:19 +0100
commit7c1fb500b8a4482b584ef732f3797f19d63d16b9 (patch)
tree6b48a9a41e4b36a4c5d77cbd89cf68d9b2f7a323 /media-sound/seq24/seq24-0.9.3.ebuild
parentapp-text/letterize: bump to 1.4 (diff)
downloadgentoo-7c1fb500b8a4482b584ef732f3797f19d63d16b9.tar.gz
gentoo-7c1fb500b8a4482b584ef732f3797f19d63d16b9.tar.bz2
gentoo-7c1fb500b8a4482b584ef732f3797f19d63d16b9.zip
media-sound/seq24: bump to 0.9.3
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-sound/seq24/seq24-0.9.3.ebuild')
-rw-r--r--media-sound/seq24/seq24-0.9.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-sound/seq24/seq24-0.9.3.ebuild b/media-sound/seq24/seq24-0.9.3.ebuild
new file mode 100644
index 000000000000..6173edaf76f8
--- /dev/null
+++ b/media-sound/seq24/seq24-0.9.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Seq24 is a loop based MIDI sequencer with focus on live performances"
+HOMEPAGE="https://edge.launchpad.net/seq24/"
+SRC_URI="https://edge.launchpad.net/seq24/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="jack lash"
+
+RDEPEND="media-libs/alsa-lib
+ >=dev-cpp/gtkmm-2.4:2.4
+ >=dev-libs/libsigc++-2.2:2
+ jack? ( >=media-sound/jack-audio-connection-kit-0.90 )
+ lash? ( >=media-sound/lash-0.5 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README RTC SEQ24 )
+
+src_configure() {
+ econf \
+ $(use_enable jack) \
+ $(use_enable lash)
+}
+
+src_install() {
+ default
+ newicon src/pixmaps/seq24_32.xpm seq24.xpm
+ make_desktop_entry seq24
+}