summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/sidplay
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/sidplay')
-rw-r--r--media-sound/sidplay/Manifest1
-rw-r--r--media-sound/sidplay/files/sidplay-2.0.9-gcc43.patch48
-rw-r--r--media-sound/sidplay/files/sidplay-2.0.9-gcc44.patch122
-rw-r--r--media-sound/sidplay/metadata.xml8
-rw-r--r--media-sound/sidplay/sidplay-2.0.9.ebuild29
5 files changed, 208 insertions, 0 deletions
diff --git a/media-sound/sidplay/Manifest b/media-sound/sidplay/Manifest
new file mode 100644
index 000000000000..13d2ff7ff496
--- /dev/null
+++ b/media-sound/sidplay/Manifest
@@ -0,0 +1 @@
+DIST sidplay-2.0.9.tar.gz 362140 SHA256 b850986ce9226cb6eecca50057967be313771b67aed721421e74e6c931e02215
diff --git a/media-sound/sidplay/files/sidplay-2.0.9-gcc43.patch b/media-sound/sidplay/files/sidplay-2.0.9-gcc43.patch
new file mode 100644
index 000000000000..b1a24e59b9a7
--- /dev/null
+++ b/media-sound/sidplay/files/sidplay-2.0.9-gcc43.patch
@@ -0,0 +1,48 @@
+Index: sidplay-2.0.9/configure
+===================================================================
+--- sidplay-2.0.9.orig/configure
++++ sidplay-2.0.9/configure
+@@ -19985,11 +19985,11 @@ _ACEOF
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+-#include <new.h>
++#include <new>
+ int
+ main ()
+ {
+-char* buf = new(nothrow) char[1024];
++char* buf = new(std::nothrow) char[1024];
+ ;
+ return 0;
+ }
+@@ -20052,11 +20052,11 @@ _ACEOF
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+-#include <fstream.h>
++#include <fstream>
+ int
+ main ()
+ {
+-ifstream myTest(ios::in|ios::binary);
++std::ifstream myTest("test.txt", std::ios::in|std::ios::binary);
+ ;
+ return 0;
+ }
+@@ -20118,12 +20118,12 @@ _ACEOF
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+-#include <fstream.h>
+- #include <iomanip.h>
++#include <fstream>
++ #include <iomanip>
+ int
+ main ()
+ {
+-ios::openmode myTest = ios::in;
++std::ios::openmode myTest = std::ios::in;
+ ;
+ return 0;
+ }
diff --git a/media-sound/sidplay/files/sidplay-2.0.9-gcc44.patch b/media-sound/sidplay/files/sidplay-2.0.9-gcc44.patch
new file mode 100644
index 000000000000..b5c4ab236007
--- /dev/null
+++ b/media-sound/sidplay/files/sidplay-2.0.9-gcc44.patch
@@ -0,0 +1,122 @@
+diff -Nur ori/src/IniConfig.cpp new/src/IniConfig.cpp
+--- ori/src/IniConfig.cpp 2004-02-29 15:28:28.000000000 +0100
++++ new/src/IniConfig.cpp 2009-07-20 21:17:56.926134851 +0200
+@@ -120,7 +120,7 @@
+ }
+
+
+-bool IniConfig::readInt (ini_fd_t ini, char *key, int &value)
++bool IniConfig::readInt (ini_fd_t ini, const char *key, int &value)
+ {
+ int i = value;
+ if (ini_locateKey (ini, key) < 0)
+@@ -134,7 +134,7 @@
+ }
+
+
+-bool IniConfig::readString (ini_fd_t ini, char *key, char *&str)
++bool IniConfig::readString (ini_fd_t ini, const char *key, char *&str)
+ {
+ char *ret;
+ size_t length;
+@@ -165,7 +165,7 @@
+ }
+
+
+-bool IniConfig::readBool (ini_fd_t ini, char *key, bool &boolean)
++bool IniConfig::readBool (ini_fd_t ini, const char *key, bool &boolean)
+ {
+ int b = boolean;
+ if (ini_locateKey (ini, key) < 0)
+@@ -179,7 +179,7 @@
+ }
+
+
+-bool IniConfig::readChar (ini_fd_t ini, char *key, char &ch)
++bool IniConfig::readChar (ini_fd_t ini, const char *key, char &ch)
+ {
+ char *str, c = 0;
+ bool ret = readString (ini, key, str);
+@@ -206,7 +206,7 @@
+ }
+
+
+-bool IniConfig::readTime (ini_fd_t ini, char *key, int &value)
++bool IniConfig::readTime (ini_fd_t ini, const char *key, int &value)
+ {
+ char *str, *sep;
+ int time;
+diff -Nur ori/src/IniConfig.h new/src/IniConfig.h
+--- ori/src/IniConfig.h 2001-07-03 19:49:27.000000000 +0200
++++ new/src/IniConfig.h 2009-07-20 21:16:17.406144852 +0200
+@@ -98,11 +98,11 @@
+ protected:
+ void clear ();
+
+- bool readInt (ini_fd_t ini, char *key, int &value);
+- bool readString (ini_fd_t ini, char *key, char *&str);
+- bool readBool (ini_fd_t ini, char *key, bool &boolean);
+- bool readChar (ini_fd_t ini, char *key, char &ch);
+- bool readTime (ini_fd_t ini, char *key, int &time);
++ bool readInt (ini_fd_t ini, const char *key, int &value);
++ bool readString (ini_fd_t ini, const char *key, char *&str);
++ bool readBool (ini_fd_t ini, const char *key, bool &boolean);
++ bool readChar (ini_fd_t ini, const char *key, char &ch);
++ bool readTime (ini_fd_t ini, const char *key, int &time);
+
+ bool readSidplay2 (ini_fd_t ini);
+ bool readConsole (ini_fd_t ini);
+diff -Nur ori/src/args.cpp new/src/args.cpp
+--- ori/src/args.cpp 2004-05-06 01:49:20.000000000 +0200
++++ new/src/args.cpp 2009-07-20 21:19:12.249460696 +0200
+@@ -77,6 +77,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <iostream>
++#include <string>
+ using std::cout;
+ using std::cerr;
+ using std::endl;
+@@ -95,7 +96,7 @@
+ // Convert time from integer
+ bool ConsolePlayer::parseTime (const char *str, uint_least32_t &time)
+ {
+- char *sep;
++ const char *sep;
+ uint_least32_t _time;
+
+ // Check for empty string
+@@ -110,8 +111,7 @@
+ else
+ { // Read in MM:SS format
+ int val;
+- *sep = '\0';
+- val = atoi (str);
++ val = atoi (std::string(str, sep - str).c_str());
+ if (val < 0 || val > 99)
+ return false;
+ _time = (uint_least32_t) val * 60;
+diff -Nur ori/src/audio/AudioBase.h new/src/audio/AudioBase.h
+--- ori/src/audio/AudioBase.h 2001-11-16 20:34:29.000000000 +0100
++++ new/src/audio/AudioBase.h 2009-07-20 21:06:15.619538393 +0200
+@@ -43,7 +43,7 @@
+ {
+ protected:
+ AudioConfig _settings;
+- char *_errorString;
++ const char *_errorString;
+ void *_sampleBuffer;
+
+ public:
+diff -Nur ori/src/menu.cpp new/src/menu.cpp
+--- ori/src/menu.cpp 2004-02-29 15:28:28.000000000 +0100
++++ new/src/menu.cpp 2009-07-20 21:20:16.576120922 +0200
+@@ -353,7 +353,7 @@
+ {
+ if ((m_iniCfg.console ()).ansi)
+ {
+- char *mode = "";
++ const char *mode = "";
+
+ switch (colour)
+ {
diff --git a/media-sound/sidplay/metadata.xml b/media-sound/sidplay/metadata.xml
new file mode 100644
index 000000000000..f13b23f890ed
--- /dev/null
+++ b/media-sound/sidplay/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">sidplay2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/sidplay/sidplay-2.0.9.ebuild b/media-sound/sidplay/sidplay-2.0.9.ebuild
new file mode 100644
index 000000000000..89f211a778cb
--- /dev/null
+++ b/media-sound/sidplay/sidplay-2.0.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="C64 SID player"
+HOMEPAGE="http://sidplay2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sidplay2/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ppc ~sparc x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libsidplay-2.1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc TODO AUTHORS ChangeLog
+}