summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Buchinger <cb-gentoo@guya.de>2018-10-23 18:49:07 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-26 14:25:11 +0200
commit70e12bfc0e59eb6b24288987a323ab18581dca91 (patch)
tree8af71e9e5ce7c1a14265b2930c05e9b7369954e3 /media-sound/snapcast/snapcast-0.15.0-r1.ebuild
parentnet-im/skype: Drop old (diff)
downloadgentoo-70e12bfc0e59eb6b24288987a323ab18581dca91.tar.gz
gentoo-70e12bfc0e59eb6b24288987a323ab18581dca91.tar.bz2
gentoo-70e12bfc0e59eb6b24288987a323ab18581dca91.zip
media-sound/snapcast: Minor fixes
* Forcing -d(aemon) by moving it from confd to initd * Dropped global USE flag descriptions * Removed CMakeList patch because upstream merged it Signed-off-by: Christian Buchinger <cb-gentoo@guya.de> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10207 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-sound/snapcast/snapcast-0.15.0-r1.ebuild')
-rw-r--r--media-sound/snapcast/snapcast-0.15.0-r1.ebuild89
1 files changed, 89 insertions, 0 deletions
diff --git a/media-sound/snapcast/snapcast-0.15.0-r1.ebuild b/media-sound/snapcast/snapcast-0.15.0-r1.ebuild
new file mode 100644
index 000000000000..a664ea01e296
--- /dev/null
+++ b/media-sound/snapcast/snapcast-0.15.0-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Synchronous multi-room audio player"
+HOMEPAGE="https://github.com/badaix/snapcast"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit user cmake-utils git-r3
+
+ EGIT_REPO_URI="https://github.com/badaix/snapcast.git"
+ EGIT_BRANCH="develop"
+else
+ inherit user cmake-utils
+
+ SRC_URI="https://github.com/badaix/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+avahi +client +flac +server static-libs tremor +vorbis"
+
+REQUIRED_USE="|| ( server client )"
+
+RDEPEND="avahi? ( net-dns/avahi[dbus] )
+ client? ( media-libs/alsa-lib )
+ flac? ( media-libs/flac )
+ tremor? ( media-libs/tremor )
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}
+ >=dev-cpp/aixlog-1.2.1
+ >=dev-cpp/asio-1.12.1
+ >=dev-cpp/popl-1.2.0"
+
+PATCHES=( "${FILESDIR}/${PN}-options-for-use-flags.patch" )
+
+pkg_setup() {
+ if use server ; then
+ enewgroup "snapserver"
+ enewuser "snapserver" -1 -1 /var/lib/snapserver snapserver
+ fi
+
+ if use client ; then
+ enewuser "snapclient" -1 -1 /var/lib/snapclient audio
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_AVAHI=$(usex avahi)
+ -DBUILD_CLIENT=$(usex client)
+ -DBUILD_WITH_FLAC=$(usex flac)
+ -DBUILD_SERVER=$(usex server)
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ -DBUILD_TESTS=no
+ -DBUILD_WITH_TREMOR=$(usex tremor)
+ -DBUILD_WITH_VORBIS=$(usex vorbis)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ for bin in server client ; do
+ if use ${bin} ; then
+ doman "${bin}/snap${bin}.1"
+
+ newconfd "${FILESDIR}/snap${bin}.confd" "snap${bin}"
+ newinitd "${FILESDIR}/snap${bin}.initd" "snap${bin}"
+ fi
+ done
+
+ if use client ; then
+ keepdir /var/lib/snapclient
+ fowners snapclient:audio /var/lib/snapclient
+ fperms 0770 /var/lib/snapclient
+ fi
+
+ if use server ; then
+ keepdir /var/lib/snapserver
+ fowners snapserver:snapserver /var/lib/snapserver
+ fperms 0770 /var/lib/snapserver
+ fi
+}