summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-02-19 21:38:54 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-19 21:40:08 +0100
commit9cf2eab1ccc2b4a989212a0e8198f3747e0187bc (patch)
tree17f5ff994229867803c90538f8f01ff62620dd74 /media-sound/sonata/sonata-1.7_beta1_p20200212.ebuild
parentprofiles: Mask media-gfx/mirage for removal (diff)
downloadgentoo-9cf2eab1ccc2b4a989212a0e8198f3747e0187bc.tar.gz
gentoo-9cf2eab1ccc2b4a989212a0e8198f3747e0187bc.tar.bz2
gentoo-9cf2eab1ccc2b4a989212a0e8198f3747e0187bc.zip
media-sound/sonata: 1.7_beta1_p20200212 version bump
Too many patches on top of 2016 release of 1.7_beta1. Bug: https://bugs.gentoo.org/708170 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/sonata/sonata-1.7_beta1_p20200212.ebuild')
-rw-r--r--media-sound/sonata/sonata-1.7_beta1_p20200212.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-sound/sonata/sonata-1.7_beta1_p20200212.ebuild b/media-sound/sonata/sonata-1.7_beta1_p20200212.ebuild
new file mode 100644
index 000000000000..3f5b02394145
--- /dev/null
+++ b/media-sound/sonata/sonata-1.7_beta1_p20200212.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT=0c807e593f7571a654ad055cb126652d7f3a698d
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_SINGLE_IMPL="true"
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+inherit desktop distutils-r1
+
+DESCRIPTION="Elegant GTK+ music client for the Music Player Daemon (MPD)"
+HOMEPAGE="https://www.nongnu.org/sonata/"
+SRC_URI="https://github.com/multani/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dbus taglib"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/python-mpd[${PYTHON_MULTI_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_MULTI_USEDEP}] )
+ taglib? ( dev-python/tagpy[${PYTHON_MULTI_USEDEP}] )
+ ')
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_install() {
+ distutils-r1_src_install
+ doicon -s 128 sonata/pixmaps/sonata.png
+ rm -r "${D}"/usr/share/sonata || die
+}