summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/sound-juicer/sound-juicer-3.14.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/sound-juicer/sound-juicer-3.14.0.ebuild')
-rw-r--r--media-sound/sound-juicer/sound-juicer-3.14.0.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/media-sound/sound-juicer/sound-juicer-3.14.0.ebuild b/media-sound/sound-juicer/sound-juicer-3.14.0.ebuild
new file mode 100644
index 000000000000..51c3cae5985f
--- /dev/null
+++ b/media-sound/sound-juicer/sound-juicer-3.14.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="CD ripper for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/SoundJuicer"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="flac test vorbis"
+
+COMMON_DEPEND="
+ app-text/iso-codes
+ >=dev-libs/glib-2.38:2
+ >=x11-libs/gtk+-3.4:3
+ media-libs/libcanberra[gtk3]
+ >=app-cdr/brasero-2.90
+ sys-apps/dbus
+ gnome-base/gsettings-desktop-schemas
+
+ media-libs/libdiscid
+ >=media-libs/musicbrainz-5.0.1:5
+
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0[vorbis?]
+ flac? ( media-plugins/gst-plugins-flac:1.0 )
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gvfs[cdda,udev]
+ || (
+ media-plugins/gst-plugins-cdparanoia:1.0
+ media-plugins/gst-plugins-cdio:1.0 )
+ media-plugins/gst-plugins-meta:1.0
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ >=app-text/scrollkeeper-0.3.5
+ virtual/pkgconfig
+ test? ( ~app-text/docbook-xml-dtd-4.3 )
+"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # FIXME: gst macros does not take GST_INSPECT override anymore but we need a
+ # way to disable inspection due to gst-clutter always creating a GL context
+ # which is forbidden in sandbox since it needs write access to
+ # /dev/card*/dri
+ sed -e "s|\(gstinspect=\).*|\1$(type -P true)|" \
+ -i configure || die
+}
+
+src_configure() {
+ gnome2_src_configure ITSTOOL="$(type -P true)"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if [ -z ${REPLACING_VERSIONS} ]; then
+ ewarn "The list of audio encoding profiles in ${P} is non-customizable."
+ ewarn "A possible workaround is to rip to flac using ${PN}, and convert to"
+ ewarn "your desired format using a separate tool."
+ fi
+}