summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/spek
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/spek')
-rw-r--r--media-sound/spek/Manifest1
-rw-r--r--media-sound/spek/files/spek-0.8.1-disable-updates.patch11
-rw-r--r--media-sound/spek/files/spek-0.8.3-replace-gnu+11-with-c++11.patch11
-rw-r--r--media-sound/spek/files/spek-0.8.3-stdlib.patch22
-rw-r--r--media-sound/spek/metadata.xml12
-rw-r--r--media-sound/spek/spek-0.8.3.ebuild41
6 files changed, 98 insertions, 0 deletions
diff --git a/media-sound/spek/Manifest b/media-sound/spek/Manifest
new file mode 100644
index 000000000000..523ff34a33c9
--- /dev/null
+++ b/media-sound/spek/Manifest
@@ -0,0 +1 @@
+DIST spek-0.8.3.tar.gz 1349573 SHA256 f5c09d0062aaafe882e2e617f6d5db2ab540e2a657c1bee38260f7f0567bf175 SHA512 a4b54746316d295574bc963e650728b23b3730ee6bcc8d78b043a5678baac70a0e859870120de2b0e6a17059e9e3757075f4691e2abde98c083afc393e93e17c WHIRLPOOL f88082cbba6ca51d016034860c4908c5c94a993a9e820733f845afc97ef7af484d2d7ece9cb6c36008f1c3f9910986edf313e8e31557a97492d06baf8a2bbdfa
diff --git a/media-sound/spek/files/spek-0.8.1-disable-updates.patch b/media-sound/spek/files/spek-0.8.1-disable-updates.patch
new file mode 100644
index 000000000000..e035a4c60819
--- /dev/null
+++ b/media-sound/spek/files/spek-0.8.1-disable-updates.patch
@@ -0,0 +1,11 @@
+--- spek-0.8.1/src/spek-preferences.cc
++++ spek-0.8.1/src/spek-preferences.cc
+@@ -62,7 +62,7 @@
+
+ bool SpekPreferences::get_check_update()
+ {
+- bool result = true;
++ bool result = false;
+ this->config->Read(wxT("/update/check"), &result);
+ return result;
+ }
diff --git a/media-sound/spek/files/spek-0.8.3-replace-gnu+11-with-c++11.patch b/media-sound/spek/files/spek-0.8.3-replace-gnu+11-with-c++11.patch
new file mode 100644
index 000000000000..624e969dba4a
--- /dev/null
+++ b/media-sound/spek/files/spek-0.8.3-replace-gnu+11-with-c++11.patch
@@ -0,0 +1,11 @@
+--- spek-0.8.3/configure.ac
++++ spek-0.8.3/configure.ac
+@@ -6,7 +6,7 @@
+
+ AC_LANG([C++])
+ AC_PROG_CXX
+-CXXFLAGS="$CXXFLAGS -std=gnu++11 -Wall -Wextra"
++CXXFLAGS="$CXXFLAGS -std=c++11 -Wall -Wextra"
+ AC_PROG_CXXCPP
+ AC_PROG_RANLIB
+ AC_PROG_INSTALL
diff --git a/media-sound/spek/files/spek-0.8.3-stdlib.patch b/media-sound/spek/files/spek-0.8.3-stdlib.patch
new file mode 100644
index 000000000000..c0ffa16b4d52
--- /dev/null
+++ b/media-sound/spek/files/spek-0.8.3-stdlib.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/519450
+
+--- spek-0.8.3/src/spek-fft.cc
++++ spek-0.8.3/src/spek-fft.cc
+@@ -17,6 +17,7 @@
+ */
+
+ #include <math.h>
++#include <stdlib.h>
+
+ #define __STDC_CONSTANT_MACROS
+ extern "C" {
+--- spek-0.8.3/src/spek-events.cc
++++ spek-0.8.3/src/spek-events.cc
+@@ -16,6 +16,7 @@
+ * along with Spek. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include <stdlib.h>
+ #include "spek-events.h"
+
+ //IMPLEMENT_DYNAMIC_CLASS(SpekHaveSampleEvent, wxEvent)
diff --git a/media-sound/spek/metadata.xml b/media-sound/spek/metadata.xml
new file mode 100644
index 000000000000..a219220a8096
--- /dev/null
+++ b/media-sound/spek/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">spek</remote-id>
+ <remote-id type="github">alexkay/spek</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/spek/spek-0.8.3.ebuild b/media-sound/spek/spek-0.8.3.ebuild
new file mode 100644
index 000000000000..0a96bf69918b
--- /dev/null
+++ b/media-sound/spek/spek-0.8.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WX_GTK_VER="2.8"
+
+inherit autotools eutils toolchain-funcs wxwidgets
+
+DESCRIPTION="Analyse your audio files by showing their spectrogram"
+HOMEPAGE="http://www.spek-project.org/"
+SRC_URI="https://github.com/alexkay/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="virtual/ffmpeg
+ x11-libs/wxGTK:2.8[X]"
+
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ >=sys-devel/gcc-4.7
+ sys-devel/gettext"
+
+src_prepare() {
+ if [ $(gcc-major-version) -lt "4" ] ; then
+ die "You need to activate at least gcc:4.7"
+ fi
+ if [ $(gcc-major-version) -eq "4" -a $(gcc-minor-version) -lt "7" ] ; then
+ die "You need to activate at least gcc:4.7"
+ fi
+
+ epatch \
+ "${FILESDIR}"/${PN}-0.8.1-disable-updates.patch \
+ "${FILESDIR}"/${P}-replace-gnu+11-with-c++11.patch \
+ "${FILESDIR}"/${P}-stdlib.patch
+ eautoreconf
+}