summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-02-10 23:27:19 +0100
committerDavid Seifert <soap@gentoo.org>2016-02-10 23:31:34 +0100
commit2f2ed7ed16205a11433816b85e8313b20001193f (patch)
treee16daf5c79151e6fb22ab0b39c9ef75c114fc5ce /media-sound/splay/splay-0.9.5.2-r2.ebuild
parentmate-extra/caja-dropbox: Fix epatch call. Thanks to joost_op. (diff)
downloadgentoo-2f2ed7ed16205a11433816b85e8313b20001193f.tar.gz
gentoo-2f2ed7ed16205a11433816b85e8313b20001193f.tar.bz2
gentoo-2f2ed7ed16205a11433816b85e8313b20001193f.zip
media-sound/splay: Patch out completely broken Qt3 handling
Gentoo-Bug: 574202 * Add missing media-libs/id3lib dependency * Remove xsplay.1 man page Package-Manager: portage-2.2.27
Diffstat (limited to 'media-sound/splay/splay-0.9.5.2-r2.ebuild')
-rw-r--r--media-sound/splay/splay-0.9.5.2-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-sound/splay/splay-0.9.5.2-r2.ebuild b/media-sound/splay/splay-0.9.5.2-r2.ebuild
new file mode 100644
index 000000000000..67d31aeeacb9
--- /dev/null
+++ b/media-sound/splay/splay-0.9.5.2-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="An audio player, primarily for the console"
+HOMEPAGE="http://splay.sourceforge.net/"
+SRC_URI="http://splay.sourceforge.net/tgz/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/id3lib"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-external-id3lib.diff"
+ "${FILESDIR}/${P}-gcc43-2.patch"
+ "${FILESDIR}/${P}-fix-buildsystem.patch"
+)
+
+src_prepare() {
+ mv configure.{in,ac} || die
+ default
+ eautoreconf
+}