summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-08-07 15:29:10 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-08-07 15:29:10 -0500
commit69d20858fc72a028338de20f68e4e069becb58e2 (patch)
treebbdfdea7e828bce2edf1d0ca17463aea5fda0547 /media-sound/spotify
parentapp-admin/cpulimit: take an orphan (diff)
downloadgentoo-69d20858fc72a028338de20f68e4e069becb58e2.tar.gz
gentoo-69d20858fc72a028338de20f68e4e069becb58e2.tar.bz2
gentoo-69d20858fc72a028338de20f68e4e069becb58e2.zip
media-sound/spotify: bup for bug 590624
Package-Manager: portage-2.2.28
Diffstat (limited to 'media-sound/spotify')
-rw-r--r--media-sound/spotify/Manifest2
-rw-r--r--media-sound/spotify/spotify-1.0.34.ebuild117
2 files changed, 119 insertions, 0 deletions
diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
index 78a087902881..f4621e570377 100644
--- a/media-sound/spotify/Manifest
+++ b/media-sound/spotify/Manifest
@@ -1,2 +1,4 @@
DIST spotify-client_1.0.33.106.g60b5d1f0-1_i386.deb 86889986 SHA256 fca0bf364679ab28091071a0406a4072ab0f1b596af0cefae27580eea56ac1e8 SHA512 9c825501cc8558714f935ef68d72b63c4736cc68608c1f081f7c98568e6ca446d07e5ae37e3f30f579b8ad7c0d17df7a672bfd19f497c830c7cc0dbbc4f78242 WHIRLPOOL 4c075ef1df698507e96782ad53aeeecb0e12b4cf3475e5e6df2d896caa0c23cd1681837bc1921bdc0d4cade979b46434dd7110a09f9f8e46aa46abb21de327c2
DIST spotify-client_1.0.33.106.g60b5d1f0-22_amd64.deb 80179480 SHA256 0e3017382b179b3cc84bd188fccaae12b32ca48dbf197924f6b79066f91121c3 SHA512 55db1b6f1fba5a6ea73917dabd87eb9e9fb40991d341e555b1c74748b95df49013a8a21032273dee933028b8c85eda703cd01d090aba54285f0d966ed1e30386 WHIRLPOOL 78136e199f39290a946c99cd2961070209b5130c3dfc485da7a5c187e339e3128c8409625027e2dac5d805b62563ecb834efebaaec10d4fdfb4d29fc8e815264
+DIST spotify-client_1.0.34.146.g28f9eda2-19_amd64.deb 80084258 SHA256 af2881c246e683926a5564839d482e61fa02740694562a071bde4835d04a7ade SHA512 0e94eca97e0e5b673bd8c3f6a8d0cf7ab4ee7f7e278afd4d7b280402230307cfd2cc4a7445c1dcfcba2f239522bd9c70e183fa6f148512526cb535b0fb15cebb WHIRLPOOL aacac69063847ae7f586fcf7f95ea36c90e76e1ffac9d52487af8f95142664ef6ad9f5ca46f1cf35413831388ec4981a277a2b22aa9f9ae6f6d12dadb6b8e469
+DIST spotify-client_1.0.34.146.g28f9eda2-2_i386.deb 86800962 SHA256 aa6bb5fb8bb008cf620d46a9c70f417cc8570cdc4f79b740d5ee24292ee6ad43 SHA512 b6e4b922491774a0b4e769513ecff27d92d3deed3b919b3997a237914785682a4061cebf7262acf8ad8433b628a25b2954a422cd4c7bcefa2678ccfc912bbacf WHIRLPOOL 2dd309fa97a4f3d03f757d39fd2006d67ff0a2d60fc9b25c0885c4abd5b1e163d95fc2b0c23370b7e1e25323b39ee17fd8fc88615bb32f4c0bcee74123de5e2d
diff --git a/media-sound/spotify/spotify-1.0.34.ebuild b/media-sound/spotify/spotify-1.0.34.ebuild
new file mode 100644
index 000000000000..2f27da77fb25
--- /dev/null
+++ b/media-sound/spotify/spotify-1.0.34.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils fdo-mime gnome2-utils pax-utils unpacker
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
+SRC_BASE="http://repository.spotify.com/pool/non-free/${PN:0:1}/${PN}-client/"
+SRC_URI="amd64? ( ${SRC_BASE}${PN}-client_${PV}.146.g28f9eda2-19_amd64.deb )
+ x86? ( ${SRC_BASE}${PN}-client_${PV}.146.g28f9eda2-2_i386.deb )"
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome pax_kernel pulseaudio"
+RESTRICT="mirror strip"
+
+DEPEND=""
+# zenety needed for filepicker
+RDEPEND="
+ ${DEPEND}
+ dev-libs/nss
+ gnome-base/gconf
+ gnome-extra/zenity
+ media-libs/alsa-lib
+ media-libs/harfbuzz
+ media-libs/fontconfig
+ media-libs/mesa
+ net-misc/curl
+ net-print/cups[ssl]
+ x11-libs/gtk+:2
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ dev-python/pygobject:3
+ dev-python/dbus-python
+ pulseaudio? ( media-sound/pulseaudio )
+ gnome? ( gnome-extra/gnome-integration-spotify )"
+ #sys-libs/glibc
+
+S=${WORKDIR}/
+
+QA_PREBUILT="opt/spotify/spotify-client/spotify"
+
+src_prepare() {
+ # Fix desktop entry to launch spotify-dbus.py for GNOME integration
+ if use gnome ; then
+ sed -i \
+ -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+ usr/share/spotify/spotify.desktop || die "sed failed"
+ fi
+ default
+}
+
+src_install() {
+ dodoc usr/share/doc/spotify-client/changelog.gz
+
+ SPOTIFY_PKG_HOME=usr/share/spotify
+ insinto /usr/share/pixmaps
+ doins ${SPOTIFY_PKG_HOME}/icons/*.png
+
+ # install in /opt/spotify
+ SPOTIFY_HOME=/opt/spotify/spotify-client
+ insinto ${SPOTIFY_HOME}
+ doins -r ${SPOTIFY_PKG_HOME}/*
+ fperms +x ${SPOTIFY_HOME}/spotify
+
+ dodir /usr/bin
+ cat <<-EOF >"${D}"/usr/bin/spotify || die
+ #! /bin/sh
+ exec ${SPOTIFY_HOME}/spotify "\$@"
+ EOF
+ fperms +x /usr/bin/spotify
+
+ local size
+ for size in 16 22 24 32 48 64 128 256 512; do
+ newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
+ "spotify-client.png"
+ done
+ domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+ if use pax_kernel; then
+ #create the headers, reset them to default, then paxmark -m them
+ pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+ eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+ eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ eqawarn "you suspect that ${PN} is being broken by this modification,"
+ eqawarn "please open a bug."
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+
+ ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+ ewarn "To remove the cache:"
+ ewarn "rm -rf ~/.cache/spotify"
+ ewarn
+ ewarn "If you use KDE and are upgrading from 0.9 to 1.0, you might still see the old icon."
+ ewarn "Run"
+ ewarn "$ rm /var/tmp/kdecache-\$USER/icon-cache.kcache"
+ ewarn "Then log out and log in back to KDE."
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}