summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-12 08:47:06 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-12 08:47:06 -0600
commit77eee83aafe764ced70c72647f3843a8f1ec09f4 (patch)
treebe9b4d2897631ea2522e376f05b11da7f601c653 /media-sound/spotify
parentmedia-libs/raspberrypi-userland: Fix devices permissions (diff)
downloadgentoo-77eee83aafe764ced70c72647f3843a8f1ec09f4.tar.gz
gentoo-77eee83aafe764ced70c72647f3843a8f1ec09f4.tar.bz2
gentoo-77eee83aafe764ced70c72647f3843a8f1ec09f4.zip
media-sound/spotify: bup
Package-Manager: portage-2.3.3
Diffstat (limited to 'media-sound/spotify')
-rw-r--r--media-sound/spotify/Manifest2
-rw-r--r--media-sound/spotify/spotify-1.0.49.ebuild118
2 files changed, 120 insertions, 0 deletions
diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
index ff924c846eca..56a939fd4a9b 100644
--- a/media-sound/spotify/Manifest
+++ b/media-sound/spotify/Manifest
@@ -1,2 +1,4 @@
DIST spotify-client_1.0.48.103.g15edf1ec-14_i386.deb 73398758 SHA256 4c7f5030589b851cec85a55540e6c54cc4d70ec48619d22ad6515ab50f38413a SHA512 62af00e047ac0a3096697473667f153042d948cd9d43a41cc3ee43ca4354baa1adb61cd49c0bc0163d74bc6764178926d3d2e90cc8b5959309a24b894330f62a WHIRLPOOL 1ee55dbb07e5612c71ecb050f80c9d042feb97f9dd0ff02533970dc82b7cbfd4eeda83f27ed47d57a6beb0594fe2076db212e68d39523201d1d09dd19a2f1436
DIST spotify-client_1.0.48.103.g15edf1ec-94_amd64.deb 72106144 SHA256 63a1289f146d8327518306a7fa92299751eb0fb264a21433850e46b1fbebfc66 SHA512 df5a63538cdc60e407390fa815cf4eb274bc357d63bcfad6587468553dbedaf72815dd91fd8880cd565dae979cfe5096192b51e65723e701eed50722ff4f5e99 WHIRLPOOL f12dc09b7bc18ca17517964240f940e994bd581bbb1db707668f17d6ada9de1dedcb1e546f24ee4affbca49d3624bc3858de743aa74f2d521ef1c292564af5d2
+DIST spotify-client_1.0.49.125.g72ee7853-21_i386.deb 74610218 SHA256 723100d7df9220efe96159d30b900b042f12422a81cc7910e21457d7cdd05866 SHA512 1934478630b65cf02144431e658b6b617943f49a1aefa51e801b2d65421e58e11cd8d56952c4567b1e86d506331d50825c6ff8df751bf1f01aac162535a4b4ac WHIRLPOOL 1405e7fcc5aa4dac5bb1f970db6d157d324b07673c36feb07037f16bc817c8e05616809a0347466f4349c309cf02be6dabb418d180c92de55d8e46a2f30d8e0e
+DIST spotify-client_1.0.49.125.g72ee7853-83_amd64.deb 73362000 SHA256 2fc10858f972f8c1e6ddc0c2090390f03c1441ec266f77cf227e80227d3a11eb SHA512 254f8d6053075c705c533fc2104aebb82b9a33e525d61fc53df68affa168f4a6bfbfe5a8f5bb26d003d955170fd94f9f2789c8ae919c78595715968fd8e38b84 WHIRLPOOL ba13d6097c8f5ffa4274f5c97243ca5ebb0c11df8f636635fffdc9e64076c594de83528f40a6555756f4d5dec6154177a0c7c63f6c88c29e89b55dc3d7246f66
diff --git a/media-sound/spotify/spotify-1.0.49.ebuild b/media-sound/spotify/spotify-1.0.49.ebuild
new file mode 100644
index 000000000000..c0a6c3fd8dcf
--- /dev/null
+++ b/media-sound/spotify/spotify-1.0.49.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils fdo-mime gnome2-utils pax-utils unpacker
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
+BUILD_ID="125.g72ee7853"
+SRC_BASE="http://repository.spotify.com/pool/non-free/${PN:0:1}/${PN}-client/"
+SRC_URI="amd64? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID}-83_amd64.deb )
+ x86? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID}-21_i386.deb )"
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome pax_kernel pulseaudio"
+RESTRICT="mirror strip"
+
+DEPEND=""
+# zenety needed for filepicker
+RDEPEND="
+ ${DEPEND}
+ dev-libs/nss
+ gnome-base/gconf
+ gnome-extra/zenity
+ media-libs/alsa-lib
+ media-libs/harfbuzz
+ media-libs/fontconfig
+ media-libs/mesa
+ net-misc/curl[ssl,curl_ssl_openssl]
+ net-print/cups[ssl]
+ x11-libs/gtk+:2
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ dev-python/pygobject:3
+ dev-python/dbus-python
+ pulseaudio? ( media-sound/pulseaudio )
+ gnome? ( gnome-extra/gnome-integration-spotify )"
+ #sys-libs/glibc
+
+S=${WORKDIR}/
+
+QA_PREBUILT="opt/spotify/spotify-client/spotify"
+
+src_prepare() {
+ # Fix desktop entry to launch spotify-dbus.py for GNOME integration
+ if use gnome ; then
+ sed -i \
+ -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+ usr/share/spotify/spotify.desktop || die "sed failed"
+ fi
+ default
+}
+
+src_install() {
+ dodoc usr/share/doc/spotify-client/changelog.gz
+
+ SPOTIFY_PKG_HOME=usr/share/spotify
+ insinto /usr/share/pixmaps
+ doins ${SPOTIFY_PKG_HOME}/icons/*.png
+
+ # install in /opt/spotify
+ SPOTIFY_HOME=/opt/spotify/spotify-client
+ insinto ${SPOTIFY_HOME}
+ doins -r ${SPOTIFY_PKG_HOME}/*
+ fperms +x ${SPOTIFY_HOME}/spotify
+
+ dodir /usr/bin
+ cat <<-EOF >"${D}"/usr/bin/spotify || die
+ #! /bin/sh
+ exec ${SPOTIFY_HOME}/spotify "\$@"
+ EOF
+ fperms +x /usr/bin/spotify
+
+ local size
+ for size in 16 22 24 32 48 64 128 256 512; do
+ newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
+ "spotify-client.png"
+ done
+ domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+ if use pax_kernel; then
+ #create the headers, reset them to default, then paxmark -m them
+ pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+ eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+ eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ eqawarn "you suspect that ${PN} is being broken by this modification,"
+ eqawarn "please open a bug."
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+
+ ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+ ewarn "To remove the cache:"
+ ewarn "rm -rf ~/.cache/spotify"
+ ewarn
+ ewarn "If you use KDE and are upgrading from 0.9 to 1.0, you might still see the old icon."
+ ewarn "Run"
+ ewarn "$ rm /var/tmp/kdecache-\$USER/icon-cache.kcache"
+ ewarn "Then log out and log in back to KDE."
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}