summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-08-15 15:13:25 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-08-15 15:13:25 -0500
commitfb864aa258b2a542cb8a99f9b8058bcf72a8cc6a (patch)
tree6468bd4903e5ecde0be53f97389f39ad5b992e15 /media-sound/spotify
parentmedia-sound/spotify: fixing bug 591020 (diff)
downloadgentoo-fb864aa258b2a542cb8a99f9b8058bcf72a8cc6a.tar.gz
gentoo-fb864aa258b2a542cb8a99f9b8058bcf72a8cc6a.tar.bz2
gentoo-fb864aa258b2a542cb8a99f9b8058bcf72a8cc6a.zip
media-sound/spotify: stable
Package-Manager: portage-2.2.28
Diffstat (limited to 'media-sound/spotify')
-rw-r--r--media-sound/spotify/spotify-1.0.36-r1.ebuild2
-rw-r--r--media-sound/spotify/spotify-1.0.36.ebuild117
2 files changed, 1 insertions, 118 deletions
diff --git a/media-sound/spotify/spotify-1.0.36-r1.ebuild b/media-sound/spotify/spotify-1.0.36-r1.ebuild
index f72eb5b1fc59..c6b34e741a97 100644
--- a/media-sound/spotify/spotify-1.0.36-r1.ebuild
+++ b/media-sound/spotify/spotify-1.0.36-r1.ebuild
@@ -12,7 +12,7 @@ SRC_URI="amd64? ( ${SRC_BASE}${PN}-client_${PV}.120.g536a862f-20_amd64.deb )
x86? ( ${SRC_BASE}${PN}-client_${PV}.120.g536a862f-2_i386.deb )"
LICENSE="Spotify"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="gnome pax_kernel pulseaudio"
RESTRICT="mirror strip"
diff --git a/media-sound/spotify/spotify-1.0.36.ebuild b/media-sound/spotify/spotify-1.0.36.ebuild
deleted file mode 100644
index e3107458a2bf..000000000000
--- a/media-sound/spotify/spotify-1.0.36.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-inherit eutils fdo-mime gnome2-utils pax-utils unpacker
-
-DESCRIPTION="Spotify is a social music platform"
-HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
-SRC_BASE="http://repository.spotify.com/pool/non-free/${PN:0:1}/${PN}-client/"
-SRC_URI="amd64? ( ${SRC_BASE}${PN}-client_${PV}.120.g536a862f-20_amd64.deb )
- x86? ( ${SRC_BASE}${PN}-client_${PV}.120.g536a862f-2_i386.deb )"
-LICENSE="Spotify"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="gnome pax_kernel pulseaudio"
-RESTRICT="mirror strip"
-
-DEPEND=""
-# zenety needed for filepicker
-RDEPEND="
- ${DEPEND}
- dev-libs/nss
- gnome-base/gconf
- gnome-extra/zenity
- media-libs/alsa-lib
- media-libs/harfbuzz
- media-libs/fontconfig
- media-libs/mesa
- net-misc/curl
- net-print/cups[ssl]
- x11-libs/gtk+:2
- x11-libs/libXScrnSaver
- x11-libs/libXtst
- dev-python/pygobject:3
- dev-python/dbus-python
- pulseaudio? ( media-sound/pulseaudio )
- gnome? ( gnome-extra/gnome-integration-spotify )"
- #sys-libs/glibc
-
-S=${WORKDIR}/
-
-QA_PREBUILT="opt/spotify/spotify-client/spotify"
-
-src_prepare() {
- # Fix desktop entry to launch spotify-dbus.py for GNOME integration
- if use gnome ; then
- sed -i \
- -e 's/spotify \%U/spotify-dbus.py \%U/g' \
- usr/share/spotify/spotify.desktop || die "sed failed"
- fi
- default
-}
-
-src_install() {
- dodoc usr/share/doc/spotify-client/changelog.gz
-
- SPOTIFY_PKG_HOME=usr/share/spotify
- insinto /usr/share/pixmaps
- doins ${SPOTIFY_PKG_HOME}/icons/*.png
-
- # install in /opt/spotify
- SPOTIFY_HOME=/opt/spotify/spotify-client
- insinto ${SPOTIFY_HOME}
- doins -r ${SPOTIFY_PKG_HOME}/*
- fperms +x ${SPOTIFY_HOME}/spotify
-
- dodir /usr/bin
- cat <<-EOF >"${D}"/usr/bin/spotify || die
- #! /bin/sh
- exec ${SPOTIFY_HOME}/spotify "\$@"
- EOF
- fperms +x /usr/bin/spotify
-
- local size
- for size in 16 22 24 32 48 64 128 256 512; do
- newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
- "spotify-client.png"
- done
- domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
- if use pax_kernel; then
- #create the headers, reset them to default, then paxmark -m them
- pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
- pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
- pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
- eqawarn "You have set USE=pax_kernel meaning that you intend to run"
- eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
- eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
- eqawarn "you suspect that ${PN} is being broken by this modification,"
- eqawarn "please open a bug."
- fi
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- fdo-mime_mime_database_update
- fdo-mime_desktop_database_update
-
- ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
- ewarn "To remove the cache:"
- ewarn "rm -rf ~/.cache/spotify"
- ewarn
- ewarn "If you use KDE and are upgrading from 0.9 to 1.0, you might still see the old icon."
- ewarn "Run"
- ewarn "$ rm /var/tmp/kdecache-\$USER/icon-cache.kcache"
- ewarn "Then log out and log in back to KDE."
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- fdo-mime_mime_database_update
- fdo-mime_desktop_database_update
-}