summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/tagtool
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/tagtool')
-rw-r--r--media-sound/tagtool/Manifest1
-rw-r--r--media-sound/tagtool/metadata.xml8
-rw-r--r--media-sound/tagtool/tagtool-0.12.3.ebuild46
3 files changed, 55 insertions, 0 deletions
diff --git a/media-sound/tagtool/Manifest b/media-sound/tagtool/Manifest
new file mode 100644
index 000000000000..84881dbe74f0
--- /dev/null
+++ b/media-sound/tagtool/Manifest
@@ -0,0 +1 @@
+DIST tagtool-0.12.3.tar.bz2 303743 SHA256 273f41031dd2ad80c09d1865fdc71d9052831a5ce9cd8c53705cc518a9d3d411
diff --git a/media-sound/tagtool/metadata.xml b/media-sound/tagtool/metadata.xml
new file mode 100644
index 000000000000..03cfae90382d
--- /dev/null
+++ b/media-sound/tagtool/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">tagtool</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/tagtool/tagtool-0.12.3.ebuild b/media-sound/tagtool/tagtool-0.12.3.ebuild
new file mode 100644
index 000000000000..36b45511e871
--- /dev/null
+++ b/media-sound/tagtool/tagtool-0.12.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="Audio Tag Tool Ogg/Mp3 Tagger"
+HOMEPAGE="http://pwp.netcabo.pt/paol/tagtool"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="vorbis mp3"
+
+RDEPEND="x11-libs/gtk+:2
+ >=gnome-base/libglade-2.6
+ mp3? ( >=media-libs/id3lib-3.8.3-r6 )
+ vorbis? ( >=media-libs/libvorbis-1 )
+ !mp3? ( !vorbis? ( >=media-libs/libvorbis-1 ) )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf
+
+ use mp3 || myconf="${myconf} --disable-mp3"
+ use vorbis || myconf="${myconf} --disable-vorbis"
+
+ if ! use mp3 && ! use vorbis; then
+ einfo "One of USE flags is required, enabling vorbis for you."
+ myconf="--disable-mp3"
+ fi
+
+ econf ${myconf}
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ GNOME_SYSCONFDIR="${D}/etc" \
+ sysdir="${D}/usr/share/applets/Multimedia" \
+ install || die
+
+ dodoc ChangeLog NEWS README TODO THANKS
+}