summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <ck+gentoobugzilla@bl4ckb0x.de>2016-12-04 00:27:27 +0100
committerThomas Deutschmann <whissi@gentoo.org>2016-12-04 00:40:26 +0100
commitadf0a5bb06d2eb393ec45dab0e62708abee3f5a2 (patch)
tree10c73ca5024c53a4ab77ffdb6d465a73dcd2f81a /media-sound/teamspeak-server-bin/teamspeak-server-bin-3.0.13.6.ebuild
parentprofiles: mask dev-python/pygtkspellcheck (diff)
downloadgentoo-adf0a5bb06d2eb393ec45dab0e62708abee3f5a2.tar.gz
gentoo-adf0a5bb06d2eb393ec45dab0e62708abee3f5a2.tar.bz2
gentoo-adf0a5bb06d2eb393ec45dab0e62708abee3f5a2.zip
media-sound/teamspeak-server-bin: Bump to v3.0.13.6
Ebuild changes: =============== - Migrated to EAPI=6; eutils eclass dropped - systemd unit renamed to "teamspeak3-server.service" to use the same name across all init systems - systemd unit now uses the correct command path (bug #591054) Gentoo-Bug: https://bugs.gentoo.org/591054 Gentoo-Bug: https://bugs.gentoo.org/589064 Package-Manager: portage-2.3.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'media-sound/teamspeak-server-bin/teamspeak-server-bin-3.0.13.6.ebuild')
-rw-r--r--media-sound/teamspeak-server-bin/teamspeak-server-bin-3.0.13.6.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/media-sound/teamspeak-server-bin/teamspeak-server-bin-3.0.13.6.ebuild b/media-sound/teamspeak-server-bin/teamspeak-server-bin-3.0.13.6.ebuild
new file mode 100644
index 000000000000..b3f6bafbe9f1
--- /dev/null
+++ b/media-sound/teamspeak-server-bin/teamspeak-server-bin-3.0.13.6.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit multilib systemd user
+
+DESCRIPTION="Crystal Clear Cross-Platform Voice Communication Server"
+HOMEPAGE="https://www.teamspeak.com/"
+SRC_URI="
+ amd64? ( http://ftp.4players.de/pub/hosted/ts3/releases/${PV}/teamspeak3-server_linux_amd64-${PV}.tar.bz2 )
+ x86? ( http://ftp.4players.de/pub/hosted/ts3/releases/${PV}/teamspeak3-server_linux_x86-${PV}.tar.bz2 )"
+
+SLOT="0"
+LICENSE="teamspeak3 GPL-2"
+IUSE="doc tsdns"
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT="installsources fetch mirror strip"
+
+S="${WORKDIR}/teamspeak3-server_linux_${ARCH}"
+
+QA_PREBUILT="opt/*"
+
+pkg_nofetch() {
+ elog "Please download ${A}"
+ elog "from ${HOMEPAGE}downloads and place this"
+ elog "file in ${DISTDIR}"
+}
+
+pkg_setup() {
+ enewuser teamspeak3
+}
+
+src_install() {
+ # Install wrapper
+ dosbin "${FILESDIR}"/ts3server
+
+ # Install TeamSpeak 3 server into /opt/teamspeak3-server.
+ local opt_dir="/opt/teamspeak3-server"
+ into ${opt_dir}
+ insinto ${opt_dir}
+ exeinto ${opt_dir}
+ newsbin ts3server ts3server-bin
+ doexe *.sh
+ doins *.so
+ doins -r sql
+
+ # Install documentation and tsdns.
+ dodoc -r CHANGELOG doc/*.txt
+ use doc && dodoc -r serverquerydocs doc/serverquery && \
+ docompress -x /usr/share/doc/${PF}/serverquerydocs && \
+ docompress -x /usr/share/doc/${PF}/serverquery && \
+ dosym ../../../usr/share/doc/${PF}/serverquery ${opt_dir}/doc/serverquery && \
+ dosym ../../usr/share/doc/${PF}/serverquerydocs ${opt_dir}/serverquerydocs
+
+ if use tsdns; then
+ newsbin tsdns/tsdnsserver tsdnsserver
+ newdoc tsdns/README README.tsdns
+ newdoc tsdns/USAGE USAGE.tsdns
+ dodoc tsdns/tsdns_settings.ini.sample
+ fi
+
+ # Install the runtime FS layout.
+ insinto /etc/teamspeak3-server
+ doins "${FILESDIR}"/server.conf "${FILESDIR}"/ts3db_mariadb.ini
+ keepdir /{etc,var/{lib,log}}/teamspeak3-server
+
+ # Install the init script and systemd unit.
+ newinitd "${FILESDIR}"/${PN}-init-r1 teamspeak3-server
+ systemd_newunit "${FILESDIR}"/systemd/teamspeak3-r1.service teamspeak3-server.service
+ systemd_newtmpfilesd "${FILESDIR}"/systemd/teamspeak3.conf teamspeak3-server.conf
+
+ # Fix up permissions.
+ fowners teamspeak3 /{etc,var/{lib,log}}/teamspeak3-server
+ fowners teamspeak3 ${opt_dir}
+
+ fperms 700 /{etc,var/{lib,log}}/teamspeak3-server
+ fperms 755 ${opt_dir}
+}
+
+pkg_postinst() {
+ einfo "Starting with version 3.0.13, there are two important changes:"
+ einfo "- IPv6 is now supported."
+ einfo "- Binding to any address (0.0.0.0 / 0::0),"
+ einfo " instead of just the default ip of the network interface."
+}