summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-12-17 21:24:42 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-12-17 21:24:58 +0100
commitc27e2e0ec5681ca6db2b11c91bf06d69294e972e (patch)
treeecf67878293441e9397db7668083ae97c9d218d6 /media-sound/timemachine/timemachine-0.3.4.ebuild
parentdev-tcltk/tkdnd: version bump to 2.9.2 (diff)
downloadgentoo-c27e2e0ec5681ca6db2b11c91bf06d69294e972e.tar.gz
gentoo-c27e2e0ec5681ca6db2b11c91bf06d69294e972e.tar.bz2
gentoo-c27e2e0ec5681ca6db2b11c91bf06d69294e972e.zip
media-sound/timemachine: 0.3.4 bump
1) switched to virtual/jack 2) organized deps 3) added desktop file Closes: https://bugs.gentoo.org/426672 Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/timemachine/timemachine-0.3.4.ebuild')
-rw-r--r--media-sound/timemachine/timemachine-0.3.4.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-sound/timemachine/timemachine-0.3.4.ebuild b/media-sound/timemachine/timemachine-0.3.4.ebuild
new file mode 100644
index 000000000000..459c251e230a
--- /dev/null
+++ b/media-sound/timemachine/timemachine-0.3.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop xdg
+
+DESCRIPTION="JACK client record button remembering the last 10 seconds when pressed"
+HOMEPAGE="http://plugin.org.uk/timemachine/"
+SRC_URI="https://github.com/swh/timemachine/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="lash"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+CDEPEND="
+ virtual/jack
+ x11-libs/gtk+:2
+ media-libs/liblo
+ >=media-libs/libsndfile-1.0.5
+ lash? ( >=media-sound/lash-0.5 )
+"
+RDEPEND="${CDEPEND}"
+DEPEND="${CDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-underlinking.patch" )
+
+src_prepare() {
+ mv configure.{in,ac} || die
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable lash)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ newicon pixmaps/timemachine-icon.png "${PN}.png"
+
+ make_desktop_entry timemachine "TimeMachine Recording" timemachine
+}