summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-04-11 13:54:14 +0200
committerJohannes Huber <johu@gentoo.org>2016-04-11 18:50:16 +0200
commitf6d756fe90250378eab32f0622f25b79fdffc825 (patch)
treeceff75d53485a0333a3501c5953742780b8f1b58 /media-sound/tomahawk
parentmedia-sound/tomahawk: EAPI 6 (diff)
downloadgentoo-f6d756fe90250378eab32f0622f25b79fdffc825.tar.gz
gentoo-f6d756fe90250378eab32f0622f25b79fdffc825.tar.bz2
gentoo-f6d756fe90250378eab32f0622f25b79fdffc825.zip
media-sound/tomahawk: Fix live build
Package-Manager: portage-2.2.28
Diffstat (limited to 'media-sound/tomahawk')
-rw-r--r--media-sound/tomahawk/files/tomahawk-liblastfm-cmake.patch126
-rw-r--r--media-sound/tomahawk/files/tomahawk-quazip-cmake.patch67
-rw-r--r--media-sound/tomahawk/tomahawk-9999.ebuild5
3 files changed, 198 insertions, 0 deletions
diff --git a/media-sound/tomahawk/files/tomahawk-liblastfm-cmake.patch b/media-sound/tomahawk/files/tomahawk-liblastfm-cmake.patch
new file mode 100644
index 000000000000..763397c613b7
--- /dev/null
+++ b/media-sound/tomahawk/files/tomahawk-liblastfm-cmake.patch
@@ -0,0 +1,126 @@
+diff --git a/CMakeModules/FindLibLastFm.cmake b/CMakeModules/FindLibLastFm.cmake
+index a348835..545e39f 100644
+--- a/CMakeModules/FindLibLastFm.cmake
++++ b/CMakeModules/FindLibLastFm.cmake
+@@ -14,7 +14,7 @@ endif()
+ # Include dir
+ find_path(LIBLASTFM_INCLUDE_DIR
+ # Track.h doesn't exist in liblastfm-0.3.1, was called Track back then
+- NAMES lastfm${LASTFM_LIB_SUFFIX}/Track.h
++ NAMES lastfm/Track.h
+ PATHS ${KDE4_INCLUDE_DIR}
+ )
+
+diff --git a/src/libtomahawk/accounts/lastfm/LastFmConfig.cpp b/src/libtomahawk/accounts/lastfm/LastFmConfig.cpp
+index 85b747b..098e460 100644
+--- a/src/libtomahawk/accounts/lastfm/LastFmConfig.cpp
++++ b/src/libtomahawk/accounts/lastfm/LastFmConfig.cpp
+@@ -29,17 +29,10 @@
+ #include "utils/Closure.h"
+ #include "utils/NetworkAccessManager.h"
+
+-#if QT_VERSION >= QT_VERSION_CHECK(5,0,0)
+-#include <lastfm5/ws.h>
+-#include <lastfm5/User.h>
+-#include <lastfm5/XmlQuery.h>
+-#include <lastfm5/Track.h>
+-#else
+ #include <lastfm/ws.h>
+ #include <lastfm/User.h>
+ #include <lastfm/XmlQuery.h>
+ #include <lastfm/Track.h>
+-#endif
+
+ using namespace Tomahawk::Accounts;
+
+diff --git a/src/libtomahawk/accounts/lastfm/LastFmInfoPlugin.cpp b/src/libtomahawk/accounts/lastfm/LastFmInfoPlugin.cpp
+index 277a62e..cea29a1 100644
+--- a/src/libtomahawk/accounts/lastfm/LastFmInfoPlugin.cpp
++++ b/src/libtomahawk/accounts/lastfm/LastFmInfoPlugin.cpp
+@@ -34,13 +34,8 @@
+ #include "TomahawkSettings.h"
+ #include "utils/NetworkAccessManager.h"
+
+-#if QT_VERSION >= QT_VERSION_CHECK(5,0,0)
+-#include <lastfm5/ws.h>
+-#include <lastfm5/XmlQuery.h>
+-#else
+ #include <lastfm/ws.h>
+ #include <lastfm/XmlQuery.h>
+-#endif
+
+ using namespace Tomahawk::Accounts;
+ using namespace Tomahawk::InfoSystem;
+diff --git a/src/libtomahawk/accounts/lastfm/LastFmInfoPlugin.h b/src/libtomahawk/accounts/lastfm/LastFmInfoPlugin.h
+index 0eb3b07..6e202b2 100644
+--- a/src/libtomahawk/accounts/lastfm/LastFmInfoPlugin.h
++++ b/src/libtomahawk/accounts/lastfm/LastFmInfoPlugin.h
+@@ -24,15 +24,9 @@
+ #include "infosystem/InfoSystemWorker.h"
+ #include "DllMacro.h"
+
+-#if QT_VERSION >= QT_VERSION_CHECK(5,0,0)
+-#include <lastfm5/Track.h>
+-#include <lastfm5/Audioscrobbler.h>
+-#include <lastfm5/ScrobblePoint.h>
+-#else
+ #include <lastfm/Track.h>
+ #include <lastfm/Audioscrobbler.h>
+ #include <lastfm/ScrobblePoint.h>
+-#endif
+
+ #include <QObject>
+
+diff --git a/src/libtomahawk/utils/TomahawkUtils.cpp b/src/libtomahawk/utils/TomahawkUtils.cpp
+index 0baa27c..cf808d9 100644
+--- a/src/libtomahawk/utils/TomahawkUtils.cpp
++++ b/src/libtomahawk/utils/TomahawkUtils.cpp
+@@ -32,11 +32,7 @@
+ #include "Track.h"
+
+ #ifdef LIBLASTFM_FOUND
+- #if QT_VERSION >= QT_VERSION_CHECK(5,0,0)
+- #include <lastfm5/ws.h>
+- #else
+ #include <lastfm/ws.h>
+- #endif
+ #endif
+
+ #if QT_VERSION >= QT_VERSION_CHECK(5,0,0)
+diff --git a/src/tomahawk/Scrobbler.h b/src/tomahawk/Scrobbler.h
+index 01c2695..fab0ca6 100644
+--- a/src/tomahawk/Scrobbler.h
++++ b/src/tomahawk/Scrobbler.h
+@@ -20,15 +20,10 @@
+ #ifndef TOMAHAWK_SCROBBLER_H
+ #define TOMAHAWK_SCROBBLER_H
+
++#include "lastfm/ScrobblePoint.h"
+ #include "Result.h"
+ #include "infosystem/InfoSystem.h"
+
+-
+-#if QT_VERSION >= QT_VERSION_CHECK(5,0,0)
+-#include <lastfm5/ScrobblePoint.h>
+-#else
+-#include <lastfm/ScrobblePoint.h>
+-#endif
+ #include <QObject>
+
+ /**
+diff --git a/src/tomahawk/TomahawkApp.h b/src/tomahawk/TomahawkApp.h
+index 953140b..c161d07 100644
+--- a/src/tomahawk/TomahawkApp.h
++++ b/src/tomahawk/TomahawkApp.h
+@@ -64,11 +64,7 @@ namespace Tomahawk
+ }
+
+ #ifdef LIBLASTFM_FOUND
+- #if QT_VERSION >= QT_VERSION_CHECK(5,0,0)
+- #include <lastfm5/NetworkAccessManager.h>
+- #else
+ #include <lastfm/NetworkAccessManager.h>
+- #endif
+ #include "Scrobbler.h"
+ #endif
+
diff --git a/media-sound/tomahawk/files/tomahawk-quazip-cmake.patch b/media-sound/tomahawk/files/tomahawk-quazip-cmake.patch
new file mode 100644
index 000000000000..7972056becb7
--- /dev/null
+++ b/media-sound/tomahawk/files/tomahawk-quazip-cmake.patch
@@ -0,0 +1,67 @@
+diff --git a/CMakeModules/FindQuaZip.cmake b/CMakeModules/FindQuaZip.cmake
+deleted file mode 100644
+index 7e628fc..0000000
+--- a/CMakeModules/FindQuaZip.cmake
++++ /dev/null
+@@ -1,43 +0,0 @@
+-# QUAZIP_FOUND - QuaZip library was found
+-# QUAZIP_INCLUDE_DIR - Path to QuaZip include dir
+-# QUAZIP_INCLUDE_DIRS - Path to QuaZip and zlib include dir (combined from QUAZIP_INCLUDE_DIR + ZLIB_INCLUDE_DIR)
+-# QUAZIP_LIBRARIES - List of QuaZip libraries
+-# QUAZIP_ZLIB_INCLUDE_DIR - The include dir of zlib headers
+-
+-
+-IF (QUAZIP_INCLUDE_DIRS AND QUAZIP_LIBRARIES)
+- # in cache already
+- SET(QUAZIP_FOUND TRUE)
+-ELSE (QUAZIP_INCLUDE_DIRS AND QUAZIP_LIBRARIES)
+- IF (Qt5Core_FOUND)
+- set(QUAZIP_LIB_VERSION_SUFFIX 5)
+- ENDIF()
+- IF (WIN32)
+- FIND_PATH(QUAZIP_LIBRARY_DIR
+- WIN32_DEBUG_POSTFIX d
+- NAMES libquazip${QUAZIP_LIB_VERSION_SUFFIX}.dll
+- HINTS "C:/Programme/" "C:/Program Files"
+- PATH_SUFFIXES QuaZip/lib
+- )
+- FIND_LIBRARY(QUAZIP_LIBRARIES NAMES libquazip${QUAZIP_LIB_VERSION_SUFFIX}.dll HINTS ${QUAZIP_LIBRARY_DIR})
+- FIND_PATH(QUAZIP_INCLUDE_DIR NAMES quazip.h HINTS ${QUAZIP_LIBRARY_DIR}/../ PATH_SUFFIXES include/quazip${QUAZIP_LIB_VERSION_SUFFIX})
+- FIND_PATH(QUAZIP_ZLIB_INCLUDE_DIR NAMES zlib.h)
+- ELSE(WIN32)
+- FIND_PACKAGE(PkgConfig)
+-# pkg_check_modules(PC_QCA2 QUIET qca2)
+- pkg_check_modules(PC_QUAZIP quazip)
+- FIND_LIBRARY(QUAZIP_LIBRARIES
+- WIN32_DEBUG_POSTFIX d
+- NAMES quazip${QUAZIP_LIB_VERSION_SUFFIX}
+- HINTS /usr/lib /usr/lib64
+- )
+- FIND_PATH(QUAZIP_INCLUDE_DIR quazip.h
+- HINTS /usr/include /usr/local/include
+- PATH_SUFFIXES quazip${QUAZIP_LIB_VERSION_SUFFIX}
+- )
+- FIND_PATH(QUAZIP_ZLIB_INCLUDE_DIR zlib.h HINTS /usr/include /usr/local/include)
+- ENDIF (WIN32)
+- INCLUDE(FindPackageHandleStandardArgs)
+- SET(QUAZIP_INCLUDE_DIRS ${QUAZIP_INCLUDE_DIR} ${QUAZIP_ZLIB_INCLUDE_DIR})
+- find_package_handle_standard_args(QUAZIP DEFAULT_MSG QUAZIP_LIBRARIES QUAZIP_INCLUDE_DIR QUAZIP_ZLIB_INCLUDE_DIR QUAZIP_INCLUDE_DIRS)
+-ENDIF (QUAZIP_INCLUDE_DIRS AND QUAZIP_LIBRARIES)
+diff --git a/src/libtomahawk/utils/TomahawkUtils.cpp b/src/libtomahawk/utils/TomahawkUtils.cpp
+index 0baa27c..74b403b 100644
+--- a/src/libtomahawk/utils/TomahawkUtils.cpp
++++ b/src/libtomahawk/utils/TomahawkUtils.cpp
+@@ -39,13 +39,8 @@
+ #endif
+ #endif
+
+-#if QT_VERSION >= QT_VERSION_CHECK(5,0,0)
+-#include <quazip5/quazip.h>
+-#include <quazip5/quazipfile.h>
+-#else
+ #include <quazip/quazip.h>
+ #include <quazip/quazipfile.h>
+-#endif
+ // We need this for the version info (if available)
+ #include <taglib/taglib.h>
+
diff --git a/media-sound/tomahawk/tomahawk-9999.ebuild b/media-sound/tomahawk/tomahawk-9999.ebuild
index f93c527233e6..7aff77bc5f03 100644
--- a/media-sound/tomahawk/tomahawk-9999.ebuild
+++ b/media-sound/tomahawk/tomahawk-9999.ebuild
@@ -74,6 +74,11 @@ RDEPEND="${DEPEND}
DOCS=( AUTHORS ChangeLog README.md )
+PATCHES=(
+ "${FILESDIR}/${PN}-quazip-cmake.patch"
+ "${FILESDIR}/${PN}-liblastfm-cmake.patch"
+)
+
src_configure() {
local mycmakeargs=(
-DWITH_CRASHREPORTER=OFF