summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/vdramgw
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/vdramgw')
-rw-r--r--media-sound/vdramgw/Manifest1
-rw-r--r--media-sound/vdramgw/files/vdramgw-0.0.2-gcc43.patch34
-rw-r--r--media-sound/vdramgw/files/vdramgw-0.0.2_gcc-4.7.diff92
-rw-r--r--media-sound/vdramgw/metadata.xml10
-rw-r--r--media-sound/vdramgw/vdramgw-0.0.2.ebuild44
5 files changed, 181 insertions, 0 deletions
diff --git a/media-sound/vdramgw/Manifest b/media-sound/vdramgw/Manifest
new file mode 100644
index 000000000000..7db1520f2d04
--- /dev/null
+++ b/media-sound/vdramgw/Manifest
@@ -0,0 +1 @@
+DIST vdr-amarok-0.0.2.tar.bz2 51816 RMD160 393827e9566d26b93da4fc6a5dc4860ab4674d6c SHA1 c5a22ff55bb0366965aa5a360191d1cfdc17fde2 SHA256 b96b6845eba17d500eeccc85f97cc0480e057801657133302ed7271167372a91
diff --git a/media-sound/vdramgw/files/vdramgw-0.0.2-gcc43.patch b/media-sound/vdramgw/files/vdramgw-0.0.2-gcc43.patch
new file mode 100644
index 000000000000..8c3ac7452aae
--- /dev/null
+++ b/media-sound/vdramgw/files/vdramgw-0.0.2-gcc43.patch
@@ -0,0 +1,34 @@
+diff -ur amarok-0.0.2.orig/Sockets.cpp amarok-0.0.2/Sockets.cpp
+--- amarok-0.0.2.orig/Sockets.cpp 2006-05-15 14:03:23.000000000 +0300
++++ amarok-0.0.2/Sockets.cpp 2009-07-30 14:02:49.000000000 +0300
+@@ -15,6 +15,7 @@
+
+ #include "Sockets.h"
+
++#include <cstring>
+ #include <sstream>
+
+ #ifndef WIN32
+diff -ur amarok-0.0.2.orig/vdramgw/Sockets.cpp amarok-0.0.2/vdramgw/Sockets.cpp
+--- amarok-0.0.2.orig/vdramgw/Sockets.cpp 2006-05-15 12:52:44.000000000 +0300
++++ amarok-0.0.2/vdramgw/Sockets.cpp 2009-07-30 14:02:57.000000000 +0300
+@@ -15,6 +15,7 @@
+
+ #include "Sockets.h"
+
++#include <cstring>
+ #include <sstream>
+
+ #ifndef WIN32
+diff -ur amarok-0.0.2.orig/vdramgw/vdramgw.cpp amarok-0.0.2/vdramgw/vdramgw.cpp
+--- amarok-0.0.2.orig/vdramgw/vdramgw.cpp 2006-12-14 01:25:52.000000000 +0200
++++ amarok-0.0.2/vdramgw/vdramgw.cpp 2009-07-30 14:02:40.000000000 +0300
+@@ -23,7 +23,7 @@
+ #include <config.h>
+ #endif
+
+-
++#include <cstring>
+ #include <unistd.h>
+ #include <getopt.h>
+ #include <iostream>
diff --git a/media-sound/vdramgw/files/vdramgw-0.0.2_gcc-4.7.diff b/media-sound/vdramgw/files/vdramgw-0.0.2_gcc-4.7.diff
new file mode 100644
index 000000000000..c5182cfd33d6
--- /dev/null
+++ b/media-sound/vdramgw/files/vdramgw-0.0.2_gcc-4.7.diff
@@ -0,0 +1,92 @@
+gcc-4.7 compile fix
+https://bugs.gentoo.org/show_bug.cgi?id=424101
+
+signed-of-by: Joerg Bornkessel <hd_brummy@gentoo.org> (2012/30/06)
+diff -Naur amarok-0.0.2.orig/Sockets.h amarok-0.0.2/Sockets.h
+--- amarok-0.0.2.orig/Sockets.h 2012-06-30 17:40:27.000000000 +0200
++++ amarok-0.0.2/Sockets.h 2012-06-30 17:43:21.000000000 +0200
+@@ -182,8 +182,8 @@
+ {
+ if (this->gptr() == NULL)
+ {
+- setg(s, s + n, s + n);
+- setp(s, s + n);
++ this->setg(s, s + n, s + n);
++ this->setp(s, s + n);
+ inbuf_ = s;
+ outbuf_ = s;
+ bufsize_ = n;
+@@ -215,9 +215,9 @@
+ {
+ _flush();
+ }
+- setp(outbuf_, outbuf_ + bufsize_);
++ this->setp(outbuf_, outbuf_ + bufsize_);
+ if (c != traits::eof())
+- sputc(traits::to_char_type(c));
++ this->sputc(traits::to_char_type(c));
+ return 0;
+ }
+
+@@ -225,7 +225,7 @@
+ {
+ // just flush the put area
+ _flush();
+- setp(outbuf_, outbuf_ + bufsize_);
++ this->setp(outbuf_, outbuf_ + bufsize_);
+ return 0;
+ }
+
+@@ -256,7 +256,7 @@
+ return traits::eof();
+
+ size_t totalbytes = readn + remained_;
+- setg(inbuf_, inbuf_,
++ this->setg(inbuf_, inbuf_,
+ inbuf_ + totalbytes / sizeof(char_type));
+
+ remained_ = totalbytes % sizeof(char_type);
+diff -Naur amarok-0.0.2.orig/vdramgw/Sockets.h amarok-0.0.2/vdramgw/Sockets.h
+--- amarok-0.0.2.orig/vdramgw/Sockets.h 2012-06-30 17:40:27.000000000 +0200
++++ amarok-0.0.2/vdramgw/Sockets.h 2012-06-30 17:41:52.000000000 +0200
+@@ -182,8 +182,8 @@
+ {
+ if (this->gptr() == NULL)
+ {
+- setg(s, s + n, s + n);
+- setp(s, s + n);
++ this->setg(s, s + n, s + n);
++ this->setp(s, s + n);
+ inbuf_ = s;
+ outbuf_ = s;
+ bufsize_ = n;
+@@ -215,9 +215,9 @@
+ {
+ _flush();
+ }
+- setp(outbuf_, outbuf_ + bufsize_);
++ this->setp(outbuf_, outbuf_ + bufsize_);
+ if (c != traits::eof())
+- sputc(traits::to_char_type(c));
++ this->sputc(traits::to_char_type(c));
+ return 0;
+ }
+
+@@ -225,7 +225,7 @@
+ {
+ // just flush the put area
+ _flush();
+- setp(outbuf_, outbuf_ + bufsize_);
++ this->setp(outbuf_, outbuf_ + bufsize_);
+ return 0;
+ }
+
+@@ -256,7 +256,7 @@
+ return traits::eof();
+
+ size_t totalbytes = readn + remained_;
+- setg(inbuf_, inbuf_,
++ this->setg(inbuf_, inbuf_,
+ inbuf_ + totalbytes / sizeof(char_type));
+
+ remained_ = totalbytes % sizeof(char_type);
diff --git a/media-sound/vdramgw/metadata.xml b/media-sound/vdramgw/metadata.xml
new file mode 100644
index 000000000000..b9c00d0c96fd
--- /dev/null
+++ b/media-sound/vdramgw/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-tv</herd>
+ <maintainer>
+ <email>vdr@gentoo.org</email>
+ <name>Gentoo VDR Project</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/media-sound/vdramgw/vdramgw-0.0.2.ebuild b/media-sound/vdramgw/vdramgw-0.0.2.ebuild
new file mode 100644
index 000000000000..be232e01493d
--- /dev/null
+++ b/media-sound/vdramgw/vdramgw-0.0.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+MY_P=vdr-amarok-${PV}
+
+DESCRIPTION="vdr to amarok gateway - allows vdr-amarok to access amarok"
+HOMEPAGE="http://irimi.ir.ohost.de/"
+SRC_URI="http://irimi.ir.ohost.de/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+RDEPEND="media-sound/amarok"
+
+S="${WORKDIR}/${MY_P#vdr-}/${PN}"
+
+src_prepare() {
+ # Respect CC,CXXFLAGS, LDFLAGS
+ sed -i -e "/^CXX /s:?=.*:= $(tc-getCXX):" \
+ -e "/^CXXFLAGS/s:?=.*:= ${CFLAGS}:" \
+ -e "s:\$(CXXFLAGS):& \$(LDFLAGS) :" "${S}"/Makefile
+
+ cd "${WORKDIR}/${MY_P#vdr-}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}/${P}_gcc-4.7.diff"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+ newdoc ../README README.vdr-amarok
+
+ insinto /etc
+ doins ${PN}.conf
+}