summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/vitunes/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/vitunes/files')
-rw-r--r--media-sound/vitunes/files/vitunes-2.3-asneeded.patch20
-rw-r--r--media-sound/vitunes/files/vitunes-2.3-time-header.patch10
2 files changed, 30 insertions, 0 deletions
diff --git a/media-sound/vitunes/files/vitunes-2.3-asneeded.patch b/media-sound/vitunes/files/vitunes-2.3-asneeded.patch
new file mode 100644
index 000000000000..ec152f395377
--- /dev/null
+++ b/media-sound/vitunes/files/vitunes-2.3-asneeded.patch
@@ -0,0 +1,20 @@
+--- vitunes-2.3/Makefile.linux.orig
++++ vitunes-2.3/Makefile.linux
+@@ -12,7 +12,7 @@
+ # build info
+ CC?=/usr/bin/cc
+ CFLAGS+=-c -std=gnu99 -D_GNU_SOURCE -Wall -Wextra -Wno-unused-value $(CDEPS) $(CDEBUG)
+-LDFLAGS+=-lm -lncurses -lutil $(LDEPS)
++LIBS=-lm -lncurses -lutil $(LDEPS)
+
+ OBJS=commands.o compat.o e_commands.o \
+ keybindings.o medialib.o meta_info.o \
+@@ -27,7 +27,7 @@
+ .PHONY: debug clean install uninstall publish-repos man-debug
+
+ vitunes: $(OBJS)
+- $(CC) -o $@ $(LDFLAGS) $(OBJS)
++ $(CC) -o $@ $(LDFLAGS) $(OBJS) $(LIBS)
+
+ .c.o:
+ $(CC) $(CFLAGS) $<
diff --git a/media-sound/vitunes/files/vitunes-2.3-time-header.patch b/media-sound/vitunes/files/vitunes-2.3-time-header.patch
new file mode 100644
index 000000000000..169ff0516584
--- /dev/null
+++ b/media-sound/vitunes/files/vitunes-2.3-time-header.patch
@@ -0,0 +1,10 @@
+--- vitunes-2.3/players/mplayer.h.orig
++++ vitunes-2.3/players/mplayer.h
+@@ -28,6 +28,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <time.h>
+ #include <unistd.h>
+
+ #include "player_utils.h"