summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-12 17:02:47 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-12 17:02:47 +0100
commita2f4d6d2f90a3c47439b5b3d005046502e95bd7f (patch)
treea81f65b8a40017965d01d7e6ee06bdd71ecd0403 /media-sound/vlevel/vlevel-0.5-r1.ebuild
parentmedia-sound/fluid-soundfont: Port to EAPI 7 (diff)
downloadgentoo-a2f4d6d2f90a3c47439b5b3d005046502e95bd7f.tar.gz
gentoo-a2f4d6d2f90a3c47439b5b3d005046502e95bd7f.tar.bz2
gentoo-a2f4d6d2f90a3c47439b5b3d005046502e95bd7f.zip
media-sound/vlevel: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/vlevel/vlevel-0.5-r1.ebuild')
-rw-r--r--media-sound/vlevel/vlevel-0.5-r1.ebuild25
1 files changed, 10 insertions, 15 deletions
diff --git a/media-sound/vlevel/vlevel-0.5-r1.ebuild b/media-sound/vlevel/vlevel-0.5-r1.ebuild
index d25eb4ec8439..3878e4aedc2c 100644
--- a/media-sound/vlevel/vlevel-0.5-r1.ebuild
+++ b/media-sound/vlevel/vlevel-0.5-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils multilib toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Dynamic compressor to amplify quiet parts of music"
HOMEPAGE="http://vlevel.sourceforge.net/"
@@ -12,27 +12,22 @@ SRC_URI="mirror://sourceforge/vlevel/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc ~sparc x86"
-IUSE=""
RDEPEND="media-libs/ladspa-sdk"
DEPEND="${RDEPEND}"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-makefile.patch
-}
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
-src_compile() {
- emake CXX=$(tc-getCXX) CXXFLAGS="$CXXFLAGS -fPIC -DPIC"
+src_configure() {
+ tc-export CXX
}
src_install() {
- emake PREFIX="${D}/usr/bin/" LADSPA_PREFIX="${D}/usr/$(get_libdir)/ladspa/" install
+ emake PREFIX="${ED}"/usr/bin/ LADSPA_PREFIX="${ED}"/usr/$(get_libdir)/ladspa/ install
- dodoc README TODO docs/*
+ dodoc -r README TODO docs/.
- exeinto /usr/share/doc/${PF}/examples
- doexe utils/{levelplay,raw2wav,vlevel-dir}
docinto examples
- dodoc utils/README
- docompress -x /usr/share/doc/${PF}/examples/{levelplay,raw2wav,vlevel-dir}
+ dodoc utils/{levelplay,raw2wav,vlevel-dir,README}
+ docompress -x /usr/share/doc/${PF}/examples
}