summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-20 04:26:09 +0100
committerSam James <sam@gentoo.org>2022-06-20 06:03:50 +0100
commita8781219bf8117d216e3a8cf157abb8a615c0664 (patch)
tree0b6bca4ca9760f42a3eaac0f825ee722d215b5c9 /media-sound/vorbisgain
parentsys-process/numad: sync live (diff)
downloadgentoo-a8781219bf8117d216e3a8cf157abb8a615c0664.tar.gz
gentoo-a8781219bf8117d216e3a8cf157abb8a615c0664.tar.bz2
gentoo-a8781219bf8117d216e3a8cf157abb8a615c0664.zip
media-sound/vorbisgain: fix -Wformat-security
Closes: https://bugs.gentoo.org/634994 Thanks-to: René Rhéaume <rene.rheaume@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/vorbisgain')
-rw-r--r--media-sound/vorbisgain/files/vorbisgain-0.37-wformat-security.patch13
-rw-r--r--media-sound/vorbisgain/vorbisgain-0.37-r4.ebuild33
2 files changed, 46 insertions, 0 deletions
diff --git a/media-sound/vorbisgain/files/vorbisgain-0.37-wformat-security.patch b/media-sound/vorbisgain/files/vorbisgain-0.37-wformat-security.patch
new file mode 100644
index 000000000000..eecf45675fac
--- /dev/null
+++ b/media-sound/vorbisgain/files/vorbisgain-0.37-wformat-security.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/634994
+--- a/misc.c
++++ b/misc.c
+@@ -57,8 +57,7 @@
+ vfprintf(stderr, message, args);
+ va_end(args);
+
+- fprintf(stderr, strerror(err_num));
+- fprintf(stderr, "\n");
++ fprintf(stderr, "%s\n", strerror(err_num));
+ }
+
+
diff --git a/media-sound/vorbisgain/vorbisgain-0.37-r4.ebuild b/media-sound/vorbisgain/vorbisgain-0.37-r4.ebuild
new file mode 100644
index 000000000000..30c144f471c9
--- /dev/null
+++ b/media-sound/vorbisgain/vorbisgain-0.37-r4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Calculator of perceived sound level for Ogg Vorbis files"
+HOMEPAGE="https://sjeng.org/vorbisgain.html"
+SRC_URI="https://sjeng.org/ftp/vorbis/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ media-libs/libogg
+ media-libs/libvorbis"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ # bug 200931
+ "${FILESDIR}"/${P}-fix-errno-and-warnings.patch
+ # bug 634994
+ "${FILESDIR}"/${P}-wformat-security.patch
+)
+
+src_configure() {
+ econf --enable-recursive
+}
+
+src_install() {
+ default
+ dodoc vorbisgain.txt
+}