summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 00:48:43 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 00:48:43 +0100
commit2ed5cd24e9cadd8d4da54eff0161532f69c8e410 (patch)
tree1585862f7d7d031b9322f4bd2cd9169e607de23d /media-sound/wavbreaker/wavbreaker-0.11.ebuild
parentmedia-sound/wavplay: Port to EAPI 7 (diff)
downloadgentoo-2ed5cd24e9cadd8d4da54eff0161532f69c8e410.tar.gz
gentoo-2ed5cd24e9cadd8d4da54eff0161532f69c8e410.tar.bz2
gentoo-2ed5cd24e9cadd8d4da54eff0161532f69c8e410.zip
media-sound/wavbreaker: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/wavbreaker/wavbreaker-0.11.ebuild')
-rw-r--r--media-sound/wavbreaker/wavbreaker-0.11.ebuild31
1 files changed, 19 insertions, 12 deletions
diff --git a/media-sound/wavbreaker/wavbreaker-0.11.ebuild b/media-sound/wavbreaker/wavbreaker-0.11.ebuild
index 482c8096fc2d..6ab4036ae813 100644
--- a/media-sound/wavbreaker/wavbreaker-0.11.ebuild
+++ b/media-sound/wavbreaker/wavbreaker-0.11.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit autotools eutils
+EAPI=7
+
+inherit autotools
DESCRIPTION="wavbreaker/wavmerge GTK+ utility to break or merge WAV files"
HOMEPAGE="http://wavbreaker.sourceforge.net"
@@ -13,18 +14,24 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="alsa nls oss pulseaudio"
-RDEPEND="dev-libs/libxml2
- >=x11-libs/gtk+-2:2
- alsa? ( media-libs/alsa-lib )
- pulseaudio? ( media-sound/pulseaudio )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- virtual/pkgconfig"
+RDEPEND="
+ dev-libs/libxml2:=
+ x11-libs/gtk+:2
+ alsa? ( media-libs/alsa-lib:= )
+ pulseaudio? ( media-sound/pulseaudio:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
-DOCS="AUTHORS ChangeLog CONTRIBUTORS NEWS README* TODO"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.10-pkgconfig.patch
+ "${FILESDIR}"/${PN}-0.11-QA-desktop-file.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.10-pkgconfig.patch
+ default
+ mv configure.{in,ac} || die
eautoreconf
}