summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-06-23 05:34:05 +0200
committerMichał Górny <mgorny@gentoo.org>2019-06-23 05:39:13 +0200
commit564f92cc924de5670a59d9415a6fd8bc3904767b (patch)
treebc7f33fb3f3ea4fd5843b392ddd07209897b45db /media-sound/xfmpc/xfmpc-0.3.0.ebuild
parentdev-java/openjdk: drop 11.0.3_p7-r3 (diff)
downloadgentoo-564f92cc924de5670a59d9415a6fd8bc3904767b.tar.gz
gentoo-564f92cc924de5670a59d9415a6fd8bc3904767b.tar.bz2
gentoo-564f92cc924de5670a59d9415a6fd8bc3904767b.zip
media-sound/xfmpc: Bump to 0.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-sound/xfmpc/xfmpc-0.3.0.ebuild')
-rw-r--r--media-sound/xfmpc/xfmpc-0.3.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/xfmpc/xfmpc-0.3.0.ebuild b/media-sound/xfmpc/xfmpc-0.3.0.ebuild
new file mode 100644
index 000000000000..18a7bd3b9554
--- /dev/null
+++ b/media-sound/xfmpc/xfmpc-0.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+DESCRIPTION="Music Player Daemon (MPD) client for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfmpc"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/$(ver_cut 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.18:2=
+ >=media-libs/libmpd-0.15:=
+ >=x11-libs/gtk+-3.22:3=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog IDEAS NEWS README THANKS )
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}