summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-10-21 17:13:08 +0200
committerPacho Ramos <pacho@gentoo.org>2018-10-21 17:17:27 +0200
commit0bda35b5eef6f82734f0bb7ba3adc020af248a90 (patch)
tree96a74e81f591767bbe873067ae0ec61490bf31e1 /media-sound
parentsci-biology/allpathslg: Fix build with glibc-2.27 (diff)
downloadgentoo-0bda35b5eef6f82734f0bb7ba3adc020af248a90.tar.gz
gentoo-0bda35b5eef6f82734f0bb7ba3adc020af248a90.tar.bz2
gentoo-0bda35b5eef6f82734f0bb7ba3adc020af248a90.zip
media-sound/tk707: Fix build with glibc-2.27
Thanks-to: Peter Levine Thanks-to: Toralf Förster Closes: https://bugs.gentoo.org/648308 Signed-off-by: Pacho Ramos <pacho@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/tk707/files/tk707-0.8-glibc-2.27.patch18
-rw-r--r--media-sound/tk707/tk707-0.8-r2.ebuild42
2 files changed, 60 insertions, 0 deletions
diff --git a/media-sound/tk707/files/tk707-0.8-glibc-2.27.patch b/media-sound/tk707/files/tk707-0.8-glibc-2.27.patch
new file mode 100644
index 000000000000..5a2c09bb704e
--- /dev/null
+++ b/media-sound/tk707/files/tk707-0.8-glibc-2.27.patch
@@ -0,0 +1,18 @@
+Bug: https://bugs.gentoo.org/648308
+
+--- a/tk707AppInit.c
++++ b/tk707AppInit.c
+@@ -31,13 +31,6 @@
+ extern int Init_tk707(Tcl_Interp *interp);
+ extern int Init_tk707_Scripts(Tcl_Interp *interp);
+
+-/*
+- * The following variable is a special hack that is needed in order for
+- * Sun shared libraries to be used for Tcl.
+- */
+-
+-int *tclDummyMathPtr = (int *) matherr;
+-
+ #ifdef TK_TEST
+ extern int Tktest_Init _ANSI_ARGS_((Tcl_Interp *interp));
+ #endif /* TK_TEST */
diff --git a/media-sound/tk707/tk707-0.8-r2.ebuild b/media-sound/tk707/tk707-0.8-r2.ebuild
new file mode 100644
index 000000000000..03b31573728b
--- /dev/null
+++ b/media-sound/tk707/tk707-0.8-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools desktop
+
+DESCRIPTION=" An 7x7 type midi drum sequencer for Linux"
+HOMEPAGE="http://www-ljk.imag.fr/membres/Pierre.Saramito/tk707/"
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ mirror://gentoo/${P}-updated_tcl2c.patch.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+
+RDEPEND="
+ >=media-libs/alsa-lib-0.9.0
+ >=dev-lang/tcl-8.4:0=
+ >=dev-lang/tk-8.4:0=
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${WORKDIR}/${P}-updated_tcl2c.patch"
+ "${FILESDIR}/${P}-asneeded.patch"
+ "${FILESDIR}/${P}-nostrip.patch"
+ "${FILESDIR}/${P}-glibc-2.27.patch"
+)
+
+src_prepare() {
+ default
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ HTML_DOCS="tk707.html" default
+ rm -rf "${ED}"/usr/share/html/
+ make_desktop_entry "${PN}"
+}