summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-06 19:43:03 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-08 19:03:37 +0200
commit1140ea38daa75bc0667083fa43c886f5928f1780 (patch)
tree57d370400250f3c8803d025d87e6923d2fdc10e5 /media-sound
parentgames-emulation/pcsx2: drop check for old gcc version (diff)
downloadgentoo-1140ea38daa75bc0667083fa43c886f5928f1780.tar.gz
gentoo-1140ea38daa75bc0667083fa43c886f5928f1780.tar.bz2
gentoo-1140ea38daa75bc0667083fa43c886f5928f1780.zip
media-sound/zynaddsubfx: 3.0.5 version bump
Closes: https://bugs.gentoo.org/682336 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/zynaddsubfx/Manifest1
-rw-r--r--media-sound/zynaddsubfx/files/zynaddsubfx-3.0.5-docs.patch12
-rw-r--r--media-sound/zynaddsubfx/zynaddsubfx-3.0.5.ebuild87
3 files changed, 100 insertions, 0 deletions
diff --git a/media-sound/zynaddsubfx/Manifest b/media-sound/zynaddsubfx/Manifest
index 1c41c32b6611..174652726f35 100644
--- a/media-sound/zynaddsubfx/Manifest
+++ b/media-sound/zynaddsubfx/Manifest
@@ -1 +1,2 @@
DIST zynaddsubfx-3.0.3.tar.bz2 7989258 BLAKE2B 7b71dc358ed3d0248eafb1c4638b05cc7ea8dbb05fd36c40643bb8f9160ee462c229d1604a52e795b6787d9131cea92512ad783c137c9cbe17cf8d56461a581f SHA512 e60e22656388d444114959859c12014ec79d7ba555b0d217ad98ad06e273916eea0eee521bb9dbfdef5be34205280d355b44a8f15760eeff06b16410d560b5d7
+DIST zynaddsubfx-3.0.5.tar.bz2 8141703 BLAKE2B 61f28a62d5ef8c17b5e38febb8ad1ecd40c80f87b26d90804131b97b57534adf5ad96a1f54980b75fd5e71185e2d5376a7df35696c7bcfd593b5d8e34bd2e386 SHA512 1e4d5a6393937e6c7103e6d0e97df76f2d129350854c2f338aa888591091b1508c63e9b52c8e5a176e282ff2f6b72c6a87de54875c412771aff26e8ece2c84e8
diff --git a/media-sound/zynaddsubfx/files/zynaddsubfx-3.0.5-docs.patch b/media-sound/zynaddsubfx/files/zynaddsubfx-3.0.5-docs.patch
new file mode 100644
index 000000000000..44060eaf4824
--- /dev/null
+++ b/media-sound/zynaddsubfx/files/zynaddsubfx-3.0.5-docs.patch
@@ -0,0 +1,12 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -28,9 +28,6 @@ include(CTestConfig.cmake)
+ add_subdirectory(src)
+ add_subdirectory(doc) # Doxygen only
+
+-install(FILES AUTHORS.txt COPYING HISTORY.txt README.adoc
+- DESTINATION share/doc/zynaddsubfx
+- )
+ install(FILES zynaddsubfx-jack-multi.desktop zynaddsubfx-jack.desktop zynaddsubfx-alsa.desktop zynaddsubfx-oss.desktop
+ DESTINATION share/applications)
+ install(FILES zynaddsubfx.svg
diff --git a/media-sound/zynaddsubfx/zynaddsubfx-3.0.5.ebuild b/media-sound/zynaddsubfx/zynaddsubfx-3.0.5.ebuild
new file mode 100644
index 000000000000..e2fb4d3256b9
--- /dev/null
+++ b/media-sound/zynaddsubfx/zynaddsubfx-3.0.5.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="Software synthesizer capable of making a countless number of instruments"
+HOMEPAGE="http://zynaddsubfx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/zynaddsubfx/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa doc dssi +fltk jack lash portaudio"
+
+REQUIRED_USE="|| ( alsa jack portaudio )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+DEPEND="
+ >=dev-libs/mxml-2.2.1
+ media-libs/liblo
+ sci-libs/fftw:3.0
+ sys-libs/zlib
+ alsa? ( media-libs/alsa-lib )
+ dssi? ( media-libs/dssi )
+ fltk? (
+ >=x11-libs/fltk-1.3:1
+ x11-libs/libX11
+ x11-libs/libXpm
+ )
+ jack? ( virtual/jack )
+ lash? ( media-sound/lash )
+ portaudio? ( media-libs/portaudio )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-docs.patch )
+
+DOCS=( ChangeLog HISTORY.txt README.adoc )
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ if ! use dssi; then
+ sed -i -e '/pkg_search_module.*DSSI/s/^/#DONT/' src/CMakeLists.txt || die
+ fi
+ if ! use jack; then
+ sed -e '/pkg_check_modules.*JACK/s/^/#DONT/' -i {rtosc,src}/CMakeLists.txt || die
+ fi
+ if ! use lash; then
+ sed -i -e '/pkg_search_module.*LASH/s/^/#DONT/' src/CMakeLists.txt || die
+ fi
+ if ! use portaudio; then
+ sed -i -e '/pkg_check_modules.*PORTAUDIO/s/^/#DONT/' src/CMakeLists.txt || die
+ fi
+
+ # FIXME upstream: sandbox error
+ sed -i -e '/add_subdirectory(bash-completion)/d' doc/CMakeLists.txt || die
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+
+ local mycmakeargs=(
+ -DPluginLibDir=$(get_libdir)
+ $(cmake-utils_use_find_package alsa Alsa)
+ $(cmake-utils_use_find_package doc Doxygen)
+ $(cmake-utils_use_find_package fltk FLTK)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use doc && cmake-utils_src_compile doc
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
+ cmake-utils_src_install
+ insinto /usr/share/${PN}
+ doins -r instruments/*
+}