summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-09 03:31:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-09 03:31:45 +0100
commit21163a7df007aabbd8936ee04475ad5a150d1923 (patch)
treef860963280da0c4bb835d793f24c87178d3c1131 /media-sound
parentprofiles: Mask media-video/2mandvd for removal (diff)
downloadgentoo-21163a7df007aabbd8936ee04475ad5a150d1923.tar.gz
gentoo-21163a7df007aabbd8936ee04475ad5a150d1923.tar.bz2
gentoo-21163a7df007aabbd8936ee04475ad5a150d1923.zip
media-sound/bempc: Add 0.11_p20160207 Qt5-based snapshot
Closes: https://bugs.gentoo.org/539590 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/bempc/Manifest1
-rw-r--r--media-sound/bempc/bempc-0.11_p20160207.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/media-sound/bempc/Manifest b/media-sound/bempc/Manifest
index 6896f700da29..5deebd330055 100644
--- a/media-sound/bempc/Manifest
+++ b/media-sound/bempc/Manifest
@@ -1 +1,2 @@
DIST bempc-0.11.tar.xz 182588 BLAKE2B 52ce00bca550d1a33df3418fde578ab760b1cb8e9deb881ae0aafea257e90fe630d8fb33513616725d9ca26c30ee27fb053eaf51dc803db98c9584b4b2256b69 SHA512 ec1cd82d7b93b45c16ff54e6e14f0625af0042b863c65f72e06eeaf67933384fd527f6db15725363fc02ca1ce9a6855fbf215da2bef2e8c52e8fec70d742de5c
+DIST bempc-0.11_p20160207.zip 237795 BLAKE2B 80ccfa052fd5c41ff948e99cfef22a767a0788de7addec482804c1d28304c48deaf64ea2d43ead590675169e9f0574793c14e072c58056108df4c5aea964e284 SHA512 8e8d85db3d9c1ec9dce5f4a5f3bfa9981a2ff9b7f80abfcf38958fe36ac843c3c6f7dafa27a018899d4d4376acb910ac779b9a9dd6e1e95cd9cc1f9db0bc4a5e
diff --git a/media-sound/bempc/bempc-0.11_p20160207.ebuild b/media-sound/bempc/bempc-0.11_p20160207.ebuild
new file mode 100644
index 000000000000..d0cee23dcc87
--- /dev/null
+++ b/media-sound/bempc/bempc-0.11_p20160207.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMIT=783ea4e61cbfe54250e809498b1496d6cbd5afa1
+inherit qmake-utils xdg-utils
+
+DESCRIPTION="Qt5 MPD client with experimental UI"
+HOMEPAGE="http://qt-apps.org/content/show.php?content=137091"
+SRC_URI="https://sourceforge.net/code-snapshots/git/b/be/be-mpc/code.git/be-mpc-code-${COMMIT}.zip -> ${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-libs/libmpdclient
+"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ default
+ mv be-mpc-code-"${COMMIT}" "${A%.zip}" || die
+}
+
+src_prepare() {
+ default
+
+ # Install on live fs should be done by portage itself
+ sed -e 's/postinstall/#postinstall/g' \
+ -i be.mpc.pro
+
+ # Fix invalid desktop file
+ sed -e 's/Categories=Application;Qt;Audio;/Categories=Qt;AudioVideo;Audio;/' \
+ -i be.mpc.desktop
+
+ eqmake5 be.mpc.pro
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}