summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-10 17:16:22 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-10 17:41:49 +0100
commit25982b170ac62c28504a6ae9288cca35731776da (patch)
treea2b2fe144fcec0614179c7ca0a91c5b4d6012458 /media-sound
parentmedia-sound/seq24: Fix mutex build ambiguity (diff)
downloadgentoo-25982b170ac62c28504a6ae9288cca35731776da.tar.gz
gentoo-25982b170ac62c28504a6ae9288cca35731776da.tar.bz2
gentoo-25982b170ac62c28504a6ae9288cca35731776da.zip
media-sound/specimen: EAPI-7 bump, drop versionator, missing desktop
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/specimen/specimen-0.5.2_rc3-r2.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/media-sound/specimen/specimen-0.5.2_rc3-r2.ebuild b/media-sound/specimen/specimen-0.5.2_rc3-r2.ebuild
index b664bba525c3..b310ba245343 100644
--- a/media-sound/specimen/specimen-0.5.2_rc3-r2.ebuild
+++ b/media-sound/specimen/specimen-0.5.2_rc3-r2.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools versionator
-
-MY_PV="$(replace_version_separator 3 -)"
+MY_PV="${PV/_/-}"
+inherit autotools desktop
DESCRIPTION="A Midi Controllable Audio Sampler"
HOMEPAGE="http://zhevny.com/specimen"
@@ -16,22 +15,27 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="lash"
-RDEPEND=">=media-sound/jack-audio-connection-kit-0.109.2
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/libxml2:2
+ gnome-base/libgnomecanvas
>=media-libs/alsa-lib-0.9
media-libs/libsamplerate
media-libs/libsndfile
>=media-libs/phat-0.4
- dev-libs/libxml2:2
+ >=media-sound/jack-audio-connection-kit-0.109.2
x11-libs/gtk+:2
- gnome-base/libgnomecanvas
- lash? ( media-sound/lash )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ lash? ( media-sound/lash )
+"
+RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${P}-jackmidi.patch"
"${FILESDIR}/${P}-underlinking.patch"
)
+
S="${WORKDIR}"/${PN}-${MY_PV}
src_prepare() {