summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-31 11:59:14 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-31 11:59:34 +0100
commit290ac49e682b978ebdb7e473364277bf558c9f9c (patch)
tree89f5763b1ff6ba338a54ae7e851e4489eda556b6 /media-sound
parentdev-perl/CPAN-Changes: amd64/x86 stable, (ALLARCHES policy) wrt bug #570306 (diff)
downloadgentoo-290ac49e682b978ebdb7e473364277bf558c9f9c.tar.gz
gentoo-290ac49e682b978ebdb7e473364277bf558c9f9c.tar.bz2
gentoo-290ac49e682b978ebdb7e473364277bf558c9f9c.zip
media-sound/sooperlooper: Fix building with latest glibmm/libsigc++ (#569520)
Package-Manager: portage-2.2.26
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/sooperlooper/files/sooperlooper-1.7.3-libsigc26.patch96
-rw-r--r--media-sound/sooperlooper/sooperlooper-1.7.3-r1.ebuild59
2 files changed, 155 insertions, 0 deletions
diff --git a/media-sound/sooperlooper/files/sooperlooper-1.7.3-libsigc26.patch b/media-sound/sooperlooper/files/sooperlooper-1.7.3-libsigc26.patch
new file mode 100644
index 000000000000..51ac10c33789
--- /dev/null
+++ b/media-sound/sooperlooper/files/sooperlooper-1.7.3-libsigc26.patch
@@ -0,0 +1,96 @@
+diff -ur a/sooperlooper-1.7.3/src/control_osc.hpp b/sooperlooper-1.7.3/src/control_osc.hpp
+--- a/sooperlooper-1.7.3/src/control_osc.hpp 2013-10-18 18:37:39.000000000 +0300
++++ b/sooperlooper-1.7.3/src/control_osc.hpp 2015-12-05 01:40:01.848107565 +0200
+@@ -27,7 +27,7 @@
+ #include <list>
+ #include <utility>
+
+-#include <sigc++/object.h>
++#include <sigc++/trackable.h>
+
+ #include "event.hpp"
+ #include "event_nonrt.hpp"
+diff -ur a/sooperlooper-1.7.3/src/gui/app_frame.hpp b/sooperlooper-1.7.3/src/gui/app_frame.hpp
+--- a/sooperlooper-1.7.3/src/gui/app_frame.hpp 2014-02-03 18:52:15.000000000 +0200
++++ b/sooperlooper-1.7.3/src/gui/app_frame.hpp 2015-12-05 01:40:01.844774250 +0200
+@@ -26,7 +26,7 @@
+ #include <string>
+ #include <vector>
+
+-#include <sigc++/object.h>
++#include <sigc++/trackable.h>
+ #include <sigc++/signal.h>
+ #include <sigc++/connection.h>
+
+diff -ur a/sooperlooper-1.7.3/src/gui/config_panel.hpp b/sooperlooper-1.7.3/src/gui/config_panel.hpp
+--- a/sooperlooper-1.7.3/src/gui/config_panel.hpp 2013-10-18 18:37:39.000000000 +0300
++++ b/sooperlooper-1.7.3/src/gui/config_panel.hpp 2015-12-05 01:40:01.841440935 +0200
+@@ -26,7 +26,7 @@
+
+ #include <string>
+ #include <vector>
+-#include <sigc++/object.h>
++#include <sigc++/trackable.h>
+
+ class wxListCtrl;
+ class wxSpinCtrl;
+diff -ur a/sooperlooper-1.7.3/src/gui/keys_panel.hpp b/sooperlooper-1.7.3/src/gui/keys_panel.hpp
+--- a/sooperlooper-1.7.3/src/gui/keys_panel.hpp 2013-10-18 18:37:39.000000000 +0300
++++ b/sooperlooper-1.7.3/src/gui/keys_panel.hpp 2015-12-05 01:40:01.838107619 +0200
+@@ -26,7 +26,7 @@
+
+ #include <string>
+ #include <vector>
+-#include <sigc++/object.h>
++#include <sigc++/trackable.h>
+
+ class wxListCtrl;
+
+diff -ur a/sooperlooper-1.7.3/src/gui/latency_panel.hpp b/sooperlooper-1.7.3/src/gui/latency_panel.hpp
+--- a/sooperlooper-1.7.3/src/gui/latency_panel.hpp 2013-10-18 18:37:39.000000000 +0300
++++ b/sooperlooper-1.7.3/src/gui/latency_panel.hpp 2015-12-05 01:40:01.834774304 +0200
+@@ -26,7 +26,7 @@
+
+ #include <string>
+ #include <vector>
+-#include <sigc++/object.h>
++#include <sigc++/trackable.h>
+
+ class wxListCtrl;
+
+diff -ur a/sooperlooper-1.7.3/src/gui/main_panel.hpp b/sooperlooper-1.7.3/src/gui/main_panel.hpp
+--- a/sooperlooper-1.7.3/src/gui/main_panel.hpp 2014-02-04 18:39:55.000000000 +0200
++++ b/sooperlooper-1.7.3/src/gui/main_panel.hpp 2015-12-05 01:40:01.831440989 +0200
+@@ -26,7 +26,7 @@
+ #include <string>
+ #include <vector>
+
+-#include <sigc++/object.h>
++#include <sigc++/trackable.h>
+ #include <sigc++/signal.h>
+ #include <sigc++/connection.h>
+
+diff -ur a/sooperlooper-1.7.3/src/gui/midi_bind_panel.hpp b/sooperlooper-1.7.3/src/gui/midi_bind_panel.hpp
+--- a/sooperlooper-1.7.3/src/gui/midi_bind_panel.hpp 2013-10-18 18:37:39.000000000 +0300
++++ b/sooperlooper-1.7.3/src/gui/midi_bind_panel.hpp 2015-12-05 01:40:01.828107674 +0200
+@@ -26,7 +26,7 @@
+
+ #include <string>
+ #include <vector>
+-#include <sigc++/object.h>
++#include <sigc++/trackable.h>
+ #include <list>
+
+ #include <midi_bind.hpp>
+diff -ur a/sooperlooper-1.7.3/src/gui/prefs_dialog.hpp b/sooperlooper-1.7.3/src/gui/prefs_dialog.hpp
+--- a/sooperlooper-1.7.3/src/gui/prefs_dialog.hpp 2013-10-18 18:37:39.000000000 +0300
++++ b/sooperlooper-1.7.3/src/gui/prefs_dialog.hpp 2015-12-05 01:40:01.824774358 +0200
+@@ -26,7 +26,7 @@
+
+ #include <string>
+ #include <vector>
+-#include <sigc++/object.h>
++#include <sigc++/trackable.h>
+
+ class wxListCtrl;
+ class wxSpinCtrl; \ No newline at end of file
diff --git a/media-sound/sooperlooper/sooperlooper-1.7.3-r1.ebuild b/media-sound/sooperlooper/sooperlooper-1.7.3-r1.ebuild
new file mode 100644
index 000000000000..491e493b5b49
--- /dev/null
+++ b/media-sound/sooperlooper/sooperlooper-1.7.3-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WX_GTK_VER=3.0
+
+inherit autotools eutils flag-o-matic wxwidgets toolchain-funcs
+
+DESCRIPTION="Live looping sampler with immediate loop recording"
+HOMEPAGE="http://essej.net/sooperlooper/index.html"
+SRC_URI="http://essej.net/sooperlooper/${P/_p/-}.tar.gz
+ mirror://gentoo/${PN}-1.6.5-m4.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="wxwidgets"
+
+RDEPEND="
+ media-sound/jack-audio-connection-kit
+ >=media-libs/liblo-0.10
+ >=dev-libs/libsigc++-2.2.10:2
+ >=media-libs/libsndfile-1.0.2
+ >=media-libs/libsamplerate-0.0.13
+ dev-libs/libxml2
+ >=media-libs/rubberband-0.0.13
+ sci-libs/fftw:3.0
+ wxwidgets? ( x11-libs/wxGTK:${WX_GTK_VER} )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${P/_p*}
+
+DOCS=( OSC README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libsigc26.patch
+ epatch "${FILESDIR}"/${P}-wx3.0.patch
+
+ cp -rf "${WORKDIR}"/aclocal "${S}" || die "copying aclocal failed"
+
+ AT_M4DIR="${S}"/aclocal eautoreconf
+}
+
+src_configure() {
+ use wxwidgets && need-wxwidgets unicode
+ append-cppflags -std=c++11 # Its ugly build system honors CPPFLAGS instead of CXXFLAGS for this
+ econf \
+ $(use_with wxwidgets gui) \
+ --disable-optimize \
+ --with-wxconfig-path="${WX_CONFIG}"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}