summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-06-21 15:19:38 +0200
committerDavid Seifert <soap@gentoo.org>2020-06-21 15:19:38 +0200
commit2fdd166c935b4d024aea314a6252e33d370dd8cc (patch)
tree74c7c4bc314aead67ffd12879c214d499f60d6a8 /media-sound
parentsys-devel/binutils-config: bump up to 5.3.2 (diff)
downloadgentoo-2fdd166c935b4d024aea314a6252e33d370dd8cc.tar.gz
gentoo-2fdd166c935b4d024aea314a6252e33d370dd8cc.tar.bz2
gentoo-2fdd166c935b4d024aea314a6252e33d370dd8cc.zip
media-sound/streamripper: [QA] Add AM_PROG_AR
Closes: https://bugs.gentoo.org/724760 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/streamripper/files/streamripper-1.64.6-fix-autotools.patch11
-rw-r--r--media-sound/streamripper/streamripper-1.64.6.ebuild23
2 files changed, 29 insertions, 5 deletions
diff --git a/media-sound/streamripper/files/streamripper-1.64.6-fix-autotools.patch b/media-sound/streamripper/files/streamripper-1.64.6-fix-autotools.patch
new file mode 100644
index 000000000000..a0bb6151700a
--- /dev/null
+++ b/media-sound/streamripper/files/streamripper-1.64.6-fix-autotools.patch
@@ -0,0 +1,11 @@
+diff -ur ORIG/configure.ac MOD/configure.ac
+--- ORIG/configure.ac 2020-06-21 13:23:49.051525439 +0200
++++ MOD/configure.ac 2020-06-21 13:24:14.279437637 +0200
+@@ -24,6 +24,7 @@
+
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
++AM_PROG_AR
+
+ dnl test for inline
+ AC_C_INLINE
diff --git a/media-sound/streamripper/streamripper-1.64.6.ebuild b/media-sound/streamripper/streamripper-1.64.6.ebuild
index 4364a4d2493c..23969844b457 100644
--- a/media-sound/streamripper/streamripper-1.64.6.ebuild
+++ b/media-sound/streamripper/streamripper-1.64.6.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit autotools
DESCRIPTION="Extracts and records individual MP3 file tracks from shoutcast streams"
HOMEPAGE="http://streamripper.sourceforge.net"
@@ -12,14 +14,20 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~arm hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="vorbis"
-RDEPEND="media-libs/libmad
+RDEPEND="
+ media-libs/libmad
media-libs/faad2
>=dev-libs/glib-2.16
vorbis? ( media-libs/libvorbis )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-autotools.patch )
-DOCS=( CHANGES parse_rules.txt README THANKS )
+src_prepare() {
+ default
+ eautoreconf
+}
src_configure() {
econf \
@@ -27,3 +35,8 @@ src_configure() {
--without-included-argv \
$(use_with vorbis ogg)
}
+
+src_install() {
+ default
+ dodoc parse_rules.txt
+}