summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-09-04 13:36:24 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-09-04 13:36:37 +0200
commit40133476b7cb91fc70935f3ba50e99ba544926a1 (patch)
treee7d5dfda73f4387e74c63b8a60cbf526babc0657 /media-sound
parentx11-misc/sux: Version 1.0.1 (diff)
downloadgentoo-40133476b7cb91fc70935f3ba50e99ba544926a1.tar.gz
gentoo-40133476b7cb91fc70935f3ba50e99ba544926a1.tar.bz2
gentoo-40133476b7cb91fc70935f3ba50e99ba544926a1.zip
media-sound/ardour: fix compilation in 6.2-r1
Closes: https://bugs.gentoo.org/740312 Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/ardour/ardour-6.2-r1.ebuild1
-rw-r--r--media-sound/ardour/files/ardour-6.2-use-signed-int-for-atomic-operations.patch69
2 files changed, 70 insertions, 0 deletions
diff --git a/media-sound/ardour/ardour-6.2-r1.ebuild b/media-sound/ardour/ardour-6.2-r1.ebuild
index 9935afaf3d5d..97893a719d62 100644
--- a/media-sound/ardour/ardour-6.2-r1.ebuild
+++ b/media-sound/ardour/ardour-6.2-r1.ebuild
@@ -71,6 +71,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/${P}-fix-no-nls.patch"
+ "${FILESDIR}/${P}-use-signed-int-for-atomic-operations.patch"
)
pkg_setup() {
diff --git a/media-sound/ardour/files/ardour-6.2-use-signed-int-for-atomic-operations.patch b/media-sound/ardour/files/ardour-6.2-use-signed-int-for-atomic-operations.patch
new file mode 100644
index 000000000000..90454593b68d
--- /dev/null
+++ b/media-sound/ardour/files/ardour-6.2-use-signed-int-for-atomic-operations.patch
@@ -0,0 +1,69 @@
+From 6d950d15ba5192a86c57d8045d1d26f9ad4be0db Mon Sep 17 00:00:00 2001
+From: Robin Gareus <robin@gareus.org>
+Date: Thu, 16 Jul 2020 16:13:21 +0200
+Subject: [PATCH] Use signed int for atomic operations -- #8314
+
+---
+ libs/pbd/pbd/mpmc_queue.h | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/libs/pbd/pbd/mpmc_queue.h b/libs/pbd/pbd/mpmc_queue.h
+index a7909a901..2c08068e1 100644
+--- a/libs/pbd/pbd/mpmc_queue.h
++++ b/libs/pbd/pbd/mpmc_queue.h
+@@ -82,7 +82,7 @@ public:
+ push_back (T const& data)
+ {
+ cell_t* cell;
+- guint pos = g_atomic_int_get (&_enqueue_pos);
++ gint pos = g_atomic_int_get (&_enqueue_pos);
+ for (;;) {
+ cell = &_buffer[pos & _buffer_mask];
+ guint seq = g_atomic_int_get (&cell->_sequence);
+@@ -108,7 +108,7 @@ public:
+ pop_front (T& data)
+ {
+ cell_t* cell;
+- guint pos = g_atomic_int_get (&_dequeue_pos);
++ gint pos = g_atomic_int_get (&_dequeue_pos);
+ for (;;) {
+ cell = &_buffer[pos & _buffer_mask];
+ guint seq = g_atomic_int_get (&cell->_sequence);
+@@ -138,8 +138,8 @@ private:
+ cell_t* _buffer;
+ size_t _buffer_mask;
+
+- volatile guint _enqueue_pos;
+- volatile guint _dequeue_pos;
++ volatile gint _enqueue_pos;
++ volatile gint _dequeue_pos;
+ };
+
+ } /* end namespace */
+--
+2.28.0
+
+From 9fcb51de2e34f9fee74838e57317ad44d21c40d0 Mon Sep 17 00:00:00 2001
+From: Robin Gareus <robin@gareus.org>
+Date: Thu, 16 Jul 2020 18:07:14 +0200
+Subject: [PATCH] Use signed int for atomic operations part II -- #8314
+
+---
+ libs/ardour/ardour/session.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libs/ardour/ardour/session.h b/libs/ardour/ardour/session.h
+index dcc8c88ed..f491f7f17 100644
+--- a/libs/ardour/ardour/session.h
++++ b/libs/ardour/ardour/session.h
+@@ -1762,7 +1762,7 @@ private:
+ OnlyLoop,
+ };
+
+- volatile guint _punch_or_loop; // enum PunchLoopLock
++ volatile gint _punch_or_loop; // enum PunchLoopLock
+ gint current_usecs_per_track;
+
+ bool punch_active () const;
+--
+2.28.0