summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-10-18 12:08:50 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-10-19 23:59:47 +0200
commit4060bf620b778c696a3b63200cb091ed1b37d2fb (patch)
tree4319d001e27a6001bf01a893a6dcd21f659c4fb1 /media-sound
parentdev-util/meson: 0.48.1 version bump (diff)
downloadgentoo-4060bf620b778c696a3b63200cb091ed1b37d2fb.tar.gz
gentoo-4060bf620b778c696a3b63200cb091ed1b37d2fb.tar.bz2
gentoo-4060bf620b778c696a3b63200cb091ed1b37d2fb.zip
media-sound/teamspeak-client: bump to version 3.2.3
Also bumped to EAPI=7. Closes: https://bugs.gentoo.org/667744 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10165 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/teamspeak-client/Manifest2
-rw-r--r--media-sound/teamspeak-client/teamspeak-client-3.2.3.ebuild95
2 files changed, 97 insertions, 0 deletions
diff --git a/media-sound/teamspeak-client/Manifest b/media-sound/teamspeak-client/Manifest
index bc6c8114a783..8c49a281b907 100644
--- a/media-sound/teamspeak-client/Manifest
+++ b/media-sound/teamspeak-client/Manifest
@@ -1,2 +1,4 @@
DIST TeamSpeak3-Client-linux_amd64-3.2.2.run 76227220 BLAKE2B 86a50064e01a496dd68559a3fa92003bf674cb59e714a45e6d12b2e6c2b33988b6ee7b76f474b35f1c08ae17fe430e8882c271e1751381df74c4dd5f7d552c42 SHA512 3edc003d721494e914fa74ae3d2666c795c5beb7feae7cc3b379d06447acb3e0941d9c5e2495e8bec8c1c1f5e25b5b31767ea214d198b2e320fc6a7925fdc541
+DIST TeamSpeak3-Client-linux_amd64-3.2.3.run 76247769 BLAKE2B 2fc226455bf839811ad82735c30f493ac9800e6f5f2f3af2d34bcbce3abd7478144feff329c3afa31d994a891990ecae5f51aa3fa001fe828d4ae0bba60fc6e9 SHA512 6f2a0e366589a3495be3ecbe3e866e1d05db3578ed1e2bf19195e6d6818acc1ddb44b46915aa88ff64ac6cc150d3b88b3347147bb0cde93e013aa7960c10dfab
DIST TeamSpeak3-Client-linux_x86-3.2.2.run 75976893 BLAKE2B 0d0396f2fdd0d61c5e1fc1daec9978e6f4ebb82511b80c97bbc86d97bcbf3237e17064666212d8ba2650dc173cef8774acc38027241247c233c14e41ed697807 SHA512 3ca1a8602a9df3ee7669d3f226a44354a92ef5b3f52b720ac7a91dbd50331c609a46a1ae83d39c82dea8f6fc0a5f32245525ab601f7fd329521478ef29909027
+DIST TeamSpeak3-Client-linux_x86-3.2.3.run 75997823 BLAKE2B 03403430d6409ceebcbdfcdb48b54142327a003c300a3bcbd63f9fb6e40c259f50ee9346fe54fbbb3a19143bacb782248f5b61d2a950f893e8227568a2df1839 SHA512 ad6ea2d5f8237585859c5deac11e0f0b6af6018b2a92fe0aab2a04cfdeab0bd57166bf4fec273d48fedd20819203cba2fd58c3a76b59ec3224e867fc10172808
diff --git a/media-sound/teamspeak-client/teamspeak-client-3.2.3.ebuild b/media-sound/teamspeak-client/teamspeak-client-3.2.3.ebuild
new file mode 100644
index 000000000000..816b907b9fee
--- /dev/null
+++ b/media-sound/teamspeak-client/teamspeak-client-3.2.3.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit desktop unpacker xdg-utils
+
+MY_PV="${PV/_/-}"
+
+DESCRIPTION="A client software for quality voice communication via the internet"
+HOMEPAGE="https://www.teamspeak.com/"
+SRC_URI="amd64? ( http://ftp.4players.de/pub/hosted/ts3/releases/${PV}/TeamSpeak3-Client-linux_amd64-${MY_PV}.run )
+ x86? ( http://ftp.4players.de/pub/hosted/ts3/releases/${PV}/TeamSpeak3-Client-linux_x86-${MY_PV}.run )"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="teamspeak3"
+SLOT="0"
+IUSE="alsa pulseaudio"
+REQUIRED_USE="|| ( alsa pulseaudio )"
+
+RDEPEND="
+ app-arch/snappy:0/1
+ <dev-libs/openssl-1.1:0
+ dev-libs/quazip
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[accessibility,dbus,xcb]
+ dev-qt/qtnetwork:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtsvg:5
+ dev-qt/qtwebchannel:5
+ dev-qt/qtwebengine:5[geolocation,widgets]
+ dev-qt/qtwidgets:5
+ net-libs/libsrtp:0
+ sys-libs/libcxx[libcxxabi]
+ sys-libs/zlib:0/1
+ virtual/udev
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio )
+"
+
+RESTRICT="mirror"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="
+ opt/teamspeak3-client/error_report
+ opt/teamspeak3-client/package_inst
+ opt/teamspeak3-client/soundbackends/libalsa_linux_*.so
+ opt/teamspeak3-client/soundbackends/libpulseaudio_linux_*.so
+ opt/teamspeak3-client/ts3client
+ opt/teamspeak3-client/update
+"
+
+src_prepare() {
+ default
+
+ if ! use alsa; then
+ rm -f soundbackends/libalsa_linux_*.so || die
+ fi
+ if ! use pulseaudio ; then
+ rm -f soundbackends/libpulseaudio_linux_*.so || die
+ fi
+
+ mv ts3client_linux_* ts3client || die
+}
+
+src_install() {
+ exeinto /opt/teamspeak3-client
+ doexe error_report package_inst ts3client "${FILESDIR}"/ts3client-bin update
+
+ exeinto /opt/teamspeak3-client/soundbackends
+ doexe soundbackends/*.so
+
+ insinto /opt/teamspeak3-client
+ doins -r gfx html resources sound styles translations
+
+ dosym ../../usr/$(get_libdir)/qt5/libexec/QtWebEngineProcess /opt/teamspeak3-client/QtWebEngineProcess
+
+ dodir /opt/bin
+ dosym ../teamspeak3-client/ts3client-bin /opt/bin/ts3client
+
+ make_desktop_entry /opt/bin/ts3client "Teamspeak 3 Client" /opt/teamspeak3-client/styles/default/logo-128x128.png "Audio;AudioVideo;Network"
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}