summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-06-21 15:19:55 +0200
committerDavid Seifert <soap@gentoo.org>2020-06-21 15:19:55 +0200
commit4b909c3fc49f1c65afa83c48657f57361c4b84b6 (patch)
tree27a9673bcbd06fc605e09de10620ffbe86d98df0 /media-sound
parentmedia-sound/fmdrv: [QA] Fix build system (diff)
downloadgentoo-4b909c3fc49f1c65afa83c48657f57361c4b84b6.tar.gz
gentoo-4b909c3fc49f1c65afa83c48657f57361c4b84b6.tar.bz2
gentoo-4b909c3fc49f1c65afa83c48657f57361c4b84b6.zip
media-sound/mp3asm: [QA] Run autoreconf
Closes: https://bugs.gentoo.org/724680 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mp3asm/files/mp3asm-0.1.3-fix-autotools.patch11
-rw-r--r--media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild18
2 files changed, 22 insertions, 7 deletions
diff --git a/media-sound/mp3asm/files/mp3asm-0.1.3-fix-autotools.patch b/media-sound/mp3asm/files/mp3asm-0.1.3-fix-autotools.patch
new file mode 100644
index 000000000000..334050d441a9
--- /dev/null
+++ b/media-sound/mp3asm/files/mp3asm-0.1.3-fix-autotools.patch
@@ -0,0 +1,11 @@
+--- a/configure.in
++++ b/configure.in
+@@ -7,8 +7,6 @@
+ dnl Checks for programs.
+ AC_PROG_LN_S
+
+-CFLAGS="-g -O -Wall"
+-
+ dnl Checks for libraries.
+
+ dnl Checks for header files.
diff --git a/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild b/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
index 467241065e7c..a03af0ddc1db 100644
--- a/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
+++ b/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+inherit autotools
-MY_PV="${PV}-1" # Patchlevel
+MY_PV="${PV}-1" # Patchlevel
DESCRIPTION="A command line tool to clean and edit mp3 files"
HOMEPAGE="https://sourceforge.net/projects/mp3asm/"
@@ -18,11 +18,15 @@ KEYWORDS="amd64 ppc sparc x86"
# the author uses weird numbering...
S="${WORKDIR}/${PN}-0.1"
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+PATCHES=( "${FILESDIR}"/${P}-fix-autotools.patch )
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
}
src_install() {
- dobin src/mp3asm
- dodoc Changelog README
+ default
+ dodoc Changelog
}