summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-05-12 07:56:42 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-05-12 07:56:52 +0200
commit508869f1b33487583cfc57aa66730feec6e770ec (patch)
treeb78201c1b58a4f61675b2699fa274586da5692da /media-sound
parentdev-libs/efl: drop lua-5.3 support (diff)
downloadgentoo-508869f1b33487583cfc57aa66730feec6e770ec.tar.gz
gentoo-508869f1b33487583cfc57aa66730feec6e770ec.tar.bz2
gentoo-508869f1b33487583cfc57aa66730feec6e770ec.zip
media-sound/drumstick: bump to 2.2.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/drumstick/Manifest1
-rw-r--r--media-sound/drumstick/drumstick-2.2.0.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/media-sound/drumstick/Manifest b/media-sound/drumstick/Manifest
index 568a2b26e448..49aa8c656977 100644
--- a/media-sound/drumstick/Manifest
+++ b/media-sound/drumstick/Manifest
@@ -1 +1,2 @@
DIST drumstick-2.1.1.tar.gz 1959938 BLAKE2B 010072faac3819d326659421d7c2c32345f8f5cf3fdcf390b80f57f942e786d569feb19319eca21ca5346ea1f990f54353afc52ecad4fbc6b631065e7b3ed751 SHA512 764b2db79f49f1ab428f472a2f4715c1ab5a9d948af43c77befc2e758b43c604673c7c0c39779a63240a31d6169f648a8c67680c1a42891c6a6cdbd2a481f557
+DIST drumstick-2.2.0.tar.gz 1965327 BLAKE2B 1fbb97c031af319999c7fb707523c3522afff61dfba3c1c0123619ed738a4996b4b835df9f60b3bb3b27b6d13616f11619160f43cf36c8429947f43dee62a840 SHA512 eff261ae0fbb620673eaa4d12e168b8ed0cfffb3e605ad8ebbc10a444d18eb0d6aecad7bad3b0c3a639df1cfee96bece3a870139bb818a278d6f51e13418a0a9
diff --git a/media-sound/drumstick/drumstick-2.2.0.ebuild b/media-sound/drumstick/drumstick-2.2.0.ebuild
new file mode 100644
index 000000000000..1459d1b265ae
--- /dev/null
+++ b/media-sound/drumstick/drumstick-2.2.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg
+
+DESCRIPTION="Qt/C++ wrapper for ALSA sequencer"
+HOMEPAGE="https://drumstick.sourceforge.io/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fluidsynth pulseaudio"
+
+BDEPEND="
+ dev-libs/libxslt
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+ x11-misc/shared-mime-info
+ doc? (
+ app-doc/doxygen[dot]
+ app-text/docbook-xsl-stylesheets
+ )
+"
+DEPEND="
+ dev-qt/designer:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ media-libs/alsa-lib
+ fluidsynth? ( media-sound/fluidsynth )
+ pulseaudio? ( media-sound/pulseaudio )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS readme.md TODO )
+
+RESTRICT="test"
+
+src_prepare() {
+ cmake_src_prepare
+
+ if ! use fluidsynth ; then
+ sed -e "/pkg_check_modules(FLUIDSYNTH/s/^/# disabled by -fluidsynth/" \
+ -i library/rt-backends/CMakeLists.txt || die
+ fi
+
+ if ! use pulseaudio ; then
+ sed -e "/pkg_check_modules(PULSE/s/^/# disabled by -pulseaudio/" \
+ -i CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=OFF
+ -DUSE_DBUS=ON
+ -DBUILD_DOCS=$(usex doc)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_src_compile doxygen
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
+ cmake_src_install
+}