summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-11-26 15:02:51 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-26 15:03:19 +0100
commit5b9df79b606e95d69f1aca29c1cbe2cef7a2d917 (patch)
tree8b63d99d506ddd747a417c0a0191bc46118083f5 /media-sound
parentdev-perl/Time-Moment: Bump to version 0.390.0 (diff)
downloadgentoo-5b9df79b606e95d69f1aca29c1cbe2cef7a2d917.tar.gz
gentoo-5b9df79b606e95d69f1aca29c1cbe2cef7a2d917.tar.bz2
gentoo-5b9df79b606e95d69f1aca29c1cbe2cef7a2d917.zip
media-sound/ams: Disable automagic media-libs/liblo dependency
Gentoo-bug: 600642 Package-Manager: portage-2.3.2
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/ams/ams-2.1.2.ebuild5
-rw-r--r--media-sound/ams/files/ams-2.1.2-fix-build-system.patch49
2 files changed, 52 insertions, 2 deletions
diff --git a/media-sound/ams/ams-2.1.2.ebuild b/media-sound/ams/ams-2.1.2.ebuild
index bb363fbe99cd..0851f37b302d 100644
--- a/media-sound/ams/ams-2.1.2.ebuild
+++ b/media-sound/ams/ams-2.1.2.ebuild
@@ -40,5 +40,8 @@ src_configure() {
# C++11/14 fails:
# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=811645
append-cxxflags -std=gnu++98
- econf --enable-qt5 MOC="$(qt5_get_bindir)/moc"
+ econf \
+ --disable-nsm \
+ --enable-qt5 \
+ MOC="$(qt5_get_bindir)/moc"
}
diff --git a/media-sound/ams/files/ams-2.1.2-fix-build-system.patch b/media-sound/ams/files/ams-2.1.2-fix-build-system.patch
index f18f5e7f1ffa..5120859ef215 100644
--- a/media-sound/ams/files/ams-2.1.2-fix-build-system.patch
+++ b/media-sound/ams/files/ams-2.1.2-fix-build-system.patch
@@ -1,9 +1,23 @@
* Remove extraneous CXXFLAGS
* Missing -ldl for dlsym, dlerror, and dlopen
-See also: https://bugs.gentoo.org/379251
+See also:
+ https://bugs.gentoo.org/show_bug.cgi?id=379251
+ https://bugs.gentoo.org/show_bug.cgi?id=600642
--- a/configure.ac
+++ b/configure.ac
+@@ -3,9 +3,9 @@
+
+ AC_PREREQ(2.61)
+ AC_INIT(ams, [2.1.2], [alsamodular-devel@lists.sourceforge.net])
+-AC_CANONICAL_SYSTEM
++AC_CANONICAL_TARGET
+ AC_CONFIG_SRCDIR([src/box.h])
+-AC_CONFIG_HEADER([src/config.h])
++AC_CONFIG_HEADERS([src/config.h])
+ AM_INIT_AUTOMAKE([dist-bzip2])
+
+ # Checks for programs.
@@ -31,46 +31,7 @@
AC_FUNC_SELECT_ARGTYPES
AC_FUNC_STAT
@@ -67,6 +81,39 @@ See also: https://bugs.gentoo.org/379251
dnl for vocoder module
AC_CHECK_LIB([fftw3], [fftw_execute], ,
[AC_MSG_ERROR(libfftw3 is required)])
+@@ -111,7 +76,7 @@
+ fi
+
+ dnl option to enable Qt5 instead of default Qt4 library
+-AC_ARG_ENABLE(qt5, AC_HELP_STRING([--enable-qt5],
++AC_ARG_ENABLE(qt5, AS_HELP_STRING([--enable-qt5],
+ [enable Qt5 instead of Qt4 library]),,
+ enable_qt4=yes)
+ AS_IF([test x$enable_qt4 = xyes],
+@@ -215,7 +180,7 @@
+
+ # Check for ladspa plugins path
+ AC_ARG_WITH(ladspa-path,
+- [AC_HELP_STRING([--with-ladspa-path=DIR],
++ [AS_HELP_STRING([--with-ladspa-path=DIR],
+ [directory for ladspa plugins])],
+ [ if test "x$withval" != "x" ; then
+ LADSPA_PATH="$withval"
+@@ -250,14 +215,6 @@
+ if test "$have_liblo" = "yes"; then
+ AC_DEFINE(NSM_SUPPORT, 1,
+ [Define to enable NSM support])
+- LIBSsave=$LIBS
+- CFLAGSsave=$CFLAGS
+- CFLAGS=$LIBLO_CFLAGS
+- LIBS=$LIBLO_LIBS
+- AC_SUBST(LIBLO_CFLAGS)
+- AC_SUBST(LIBLO_LIBS)
+- LIBS+=$LIBSsave
+- CFLAGS+=$CFLAGSsave
+ fi
+ fi
+
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -267,7 +267,7 @@