summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-09-02 10:32:47 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-09-02 10:33:04 +0200
commit6128f01f2648d14c91363ddc89f868d8938a4b2e (patch)
tree93fdc0adfc4a92d5071f2abd3f11bb5ac6341a3c /media-sound
parentdev-python/dask: remove distributed references (diff)
downloadgentoo-6128f01f2648d14c91363ddc89f868d8938a4b2e.tar.gz
gentoo-6128f01f2648d14c91363ddc89f868d8938a4b2e.tar.bz2
gentoo-6128f01f2648d14c91363ddc89f868d8938a4b2e.zip
media-sound/audacity: disabled ccache in 2.4.2-r1
Closes: https://bugs.gentoo.org/735642 Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audacity/audacity-2.4.2-r1.ebuild1
-rw-r--r--media-sound/audacity/files/audacity-2.4.2-disable-ccache.patch19
2 files changed, 20 insertions, 0 deletions
diff --git a/media-sound/audacity/audacity-2.4.2-r1.ebuild b/media-sound/audacity/audacity-2.4.2-r1.ebuild
index e6c8898ad225..f7df783a70cd 100644
--- a/media-sound/audacity/audacity-2.4.2-r1.ebuild
+++ b/media-sound/audacity/audacity-2.4.2-r1.ebuild
@@ -65,6 +65,7 @@ PATCHES=(
"${FILESDIR}/${P}-fix-gettimeofday.patch"
"${FILESDIR}/${P}-fix-metainfo.patch"
"${FILESDIR}/${P}-add-missing-include-portaudio.patch"
+ "${FILESDIR}/${P}-disable-ccache.patch"
)
src_prepare() {
diff --git a/media-sound/audacity/files/audacity-2.4.2-disable-ccache.patch b/media-sound/audacity/files/audacity-2.4.2-disable-ccache.patch
new file mode 100644
index 000000000000..03acf6a20586
--- /dev/null
+++ b/media-sound/audacity/files/audacity-2.4.2-disable-ccache.patch
@@ -0,0 +1,19 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4ff5430..9c9dbf6 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -69,14 +69,6 @@ set( CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake-proxies/cmake-modules)
+ set( CMAKE_CXX_STANDARD 14 )
+ set( CMAKE_CXX_STANDARD_REQUIRED ON )
+
+-# Use ccache if available
+-find_program( CCACHE_PROGRAM ccache )
+-mark_as_advanced( FORCE CCACHE_PROGRAM )
+-
+-if( CCACHE_PROGRAM )
+- set_property( GLOBAL PROPERTY RULE_LAUNCH_COMPILE "${CCACHE_PROGRAM}" )
+-endif()
+-
+ # Our very own project
+ project( Audacity )
+