summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-06-21 15:19:46 +0200
committerDavid Seifert <soap@gentoo.org>2020-06-21 15:19:46 +0200
commit618321b34f69fafa76cdc9fa4bb18ce5bf76d73f (patch)
tree30132e58add18a6bc196f4cf45ee931ad590bb78 /media-sound
parentmedia-sound/erec: [QA] Fix build system (diff)
downloadgentoo-618321b34f69fafa76cdc9fa4bb18ce5bf76d73f.tar.gz
gentoo-618321b34f69fafa76cdc9fa4bb18ce5bf76d73f.tar.bz2
gentoo-618321b34f69fafa76cdc9fa4bb18ce5bf76d73f.zip
media-sound/muse: [QA] Add AM_PROG_AR
Closes: https://bugs.gentoo.org/724712 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/muse/files/muse-0.9.2_p20161002-fix-build-system.patch14
-rw-r--r--media-sound/muse/muse-0.9.2_p20161002.ebuild19
2 files changed, 20 insertions, 13 deletions
diff --git a/media-sound/muse/files/muse-0.9.2_p20161002-fix-build-system.patch b/media-sound/muse/files/muse-0.9.2_p20161002-fix-build-system.patch
index 7ca30e6da689..456dca9b9dee 100644
--- a/media-sound/muse/files/muse-0.9.2_p20161002-fix-build-system.patch
+++ b/media-sound/muse/files/muse-0.9.2_p20161002-fix-build-system.patch
@@ -20,7 +20,15 @@ Fix build system to properly install files and prevent underlinking.
dnl ==============================================================
-@@ -178,19 +178,12 @@
+@@ -67,6 +67,7 @@
+ AC_PROG_CPP
+ AC_SEARCH_LIBS([strerror],[cposix])
+ AC_PROG_RANLIB
++AM_PROG_AR
+
+
+ dnl ==============================================================
+@@ -178,19 +179,12 @@
# this is really libcdk's configuration, needs to be reviewed if correct
# see src/ncursesgui/libcdk
if test x$want_ncurses_gui = xyes; then
@@ -46,7 +54,7 @@ Fix build system to properly install files and prevent underlinking.
if test x$have_ncurses_h = xyes; then
AC_DEFINE([GUI_RUBIK], 1, [Have ncurses GUI])
-@@ -326,8 +319,13 @@
+@@ -326,8 +320,13 @@
dnl documentation
@@ -62,7 +70,7 @@ Fix build system to properly install files and prevent underlinking.
dnl ==============================================================
-@@ -402,6 +400,7 @@
+@@ -402,6 +401,7 @@
AC_CONFIG_FILES([
Makefile
diff --git a/media-sound/muse/muse-0.9.2_p20161002.ebuild b/media-sound/muse/muse-0.9.2_p20161002.ebuild
index 89771e227748..e296b01d6582 100644
--- a/media-sound/muse/muse-0.9.2_p20161002.ebuild
+++ b/media-sound/muse/muse-0.9.2_p20161002.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools
@@ -14,24 +14,23 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="doc gtk jack ncurses portaudio"
-RDEPEND="media-sound/lame
+RDEPEND="
+ media-sound/lame
media-libs/libvorbis
- media-libs/libsndfile
+ media-libs/libsndfile:=
media-libs/libogg
media-libs/libshout
media-libs/libsamplerate
gtk? ( x11-libs/gtk+:2 )
jack? ( media-sound/jack-audio-connection-kit )
ncurses? ( sys-libs/ncurses:0= )
- portaudio? ( media-libs/portaudio )
-"
-DEPEND="${RDEPEND}
+ portaudio? ( media-libs/portaudio )"
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
doc? ( app-doc/doxygen )"
-PATCHES=(
- "${FILESDIR}"/${PN}-0.9.2_p20161002-fix-build-system.patch
-)
+PATCHES=( "${FILESDIR}"/${PN}-0.9.2_p20161002-fix-build-system.patch )
src_prepare() {
default