summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-03-04 14:19:52 -0500
committerAaron Bauman <bman@gentoo.org>2019-03-04 14:19:52 -0500
commit80bdcf12e2443fede598ccb6add11575f9edc272 (patch)
tree24fbf966188e6313800db26712532d931927c30e /media-sound
parentmedia-libs/mesa: Add Iris support to mesa-9999 (diff)
downloadgentoo-80bdcf12e2443fede598ccb6add11575f9edc272.tar.gz
gentoo-80bdcf12e2443fede598ccb6add11575f9edc272.tar.bz2
gentoo-80bdcf12e2443fede598ccb6add11575f9edc272.zip
media-sound/peercast: bump EAPI
-Dead upstream links and unable to find new -There is a SF page which has peercast but content -Package still builds fine but may be considered for removal Signed-off-by: Aaron Bauman <bman@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.12
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/peercast/peercast-0.1218-r2.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/media-sound/peercast/peercast-0.1218-r2.ebuild b/media-sound/peercast/peercast-0.1218-r2.ebuild
index 105d18390306..8034fe6aef9d 100644
--- a/media-sound/peercast/peercast-0.1218-r2.ebuild
+++ b/media-sound/peercast/peercast-0.1218-r2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit eutils flag-o-matic toolchain-funcs
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="A client and server for Peercast P2P-radio network"
HOMEPAGE="http://www.peercast.org"
@@ -18,12 +19,12 @@ DEPEND=""
S=${WORKDIR}
-src_prepare() {
- epatch "${FILESDIR}"/${P}-CVE-2008-2040.patch \
- "${FILESDIR}"/${PN}-0.1216-makefile.patch \
- "${FILESDIR}"/${PN}-0.1216-amd64.patch \
- "${FILESDIR}"/${P}-glibc-2.10.patch
-}
+PATCHES=(
+ "${FILESDIR}/${P}-CVE-2008-2040.patch" \
+ "${FILESDIR}/${PN}-0.1216-makefile.patch" \
+ "${FILESDIR}/${PN}-0.1216-amd64.patch" \
+ "${FILESDIR}/${P}-glibc-2.10.patch"
+)
src_compile() {
append-ldflags -pthread