summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-14 23:04:52 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-14 23:12:19 +0200
commit97da098e6537ef198202e2f137cfae44606986b2 (patch)
tree0ce945c8c15e752965825aaf30161eb2271e5f90 /media-sound
parentdev-libs/libgit2: Bump to 0.28.3 (diff)
downloadgentoo-97da098e6537ef198202e2f137cfae44606986b2.tar.gz
gentoo-97da098e6537ef198202e2f137cfae44606986b2.tar.bz2
gentoo-97da098e6537ef198202e2f137cfae44606986b2.zip
media-sound/pragha: Bump to 1.3.99.1 (1.4rc2)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/pragha/Manifest1
-rw-r--r--media-sound/pragha/pragha-1.3.99.1.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/media-sound/pragha/Manifest b/media-sound/pragha/Manifest
index 4670ce21950f..aecba9e47fcd 100644
--- a/media-sound/pragha/Manifest
+++ b/media-sound/pragha/Manifest
@@ -1,2 +1,3 @@
DIST pragha-1.3.4.tar.bz2 691256 BLAKE2B af1455633a4f9d3c40f6b97051692fa301cfb763d0ca5f03c3ae932513556ff7a6fed5c68cdd3f7e86dbca305598cb9495221e1b2c841f7e1cb56905fa742130 SHA512 65aadf68f427f03ea7ca07d2002806eb94019c8091a80320da7d8ff4c2f0cd912e9c346956188b42d2b7a68c56c79ee5af8e8327c69ad69f4a1fa5b9e3b3ca58
+DIST pragha-1.3.99.1.tar.bz2 804701 BLAKE2B ae68c01706d593defc4ee357e1bdd1e832fb6d6720f723149c752c98f16502e1254553b404f53b40a4e126b647e6de478e7929b7715c0f9815d23b2e62e5475b SHA512 1c92bf7b2d1d1d6b3f8616b1980b60c6c688844d0bf9f80bc86185035a05971f3b8f5aa73d230b01fa5d14e54db38b356df41781e4a5da73b0adae82829c8c31
DIST pragha-1.3.99.tar.bz2 781892 BLAKE2B 9d73dd2859db0c7ab7ac66fdafe873bd78b019408682828ddd05aa18a1591576df667e326037a7ca28eaed227fcbce943209fad16c9f55bb38c0c2c808275104 SHA512 df032fe16932ad464417306d8d01373b8e415f5f810a06b1baff647a395b10bdee5c912f36a3f6e3ea6a0e04d399257e202112c1838444d23dfc17b5fd34e12b
diff --git a/media-sound/pragha/pragha-1.3.99.1.ebuild b/media-sound/pragha/pragha-1.3.99.1.ebuild
new file mode 100644
index 000000000000..c60f3ad27eab
--- /dev/null
+++ b/media-sound/pragha/pragha-1.3.99.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A lightweight music player (for Xfce)"
+HOMEPAGE="https://github.com/pragha-music-player/pragha"
+SRC_URI="https://github.com/pragha-music-player/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cdda +glyr grilo +keybinder koel lastfm libnotify mtp +peas +playlist rygel soup +udev"
+
+COMMON_DEPEND=">=dev-db/sqlite-3.4:3=
+ >=dev-libs/glib-2.42
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ >=media-libs/taglib-1.8:=
+ >=x11-libs/gtk+-3.14:3
+ >=xfce-base/libxfce4ui-4.11:=[gtk3(+)]
+ cdda? ( >=dev-libs/libcdio-0.90:=
+ >=dev-libs/libcdio-paranoia-0.90:=
+ >=media-libs/libcddb-1.3.0:= )
+ glyr? ( >=media-libs/glyr-1.0.1:= )
+ grilo? ( media-libs/grilo:0.3[network] )
+ keybinder? ( >=dev-libs/keybinder-0.2.0:3 )
+ koel? ( dev-libs/json-glib )
+ lastfm? ( >=media-libs/libclastfm-0.5:= )
+ libnotify? ( >=x11-libs/libnotify-0.7.5 )
+ mtp? ( >=media-libs/libmtp-1.1.0:= )
+ peas? ( >=dev-libs/libpeas-1.0.0[gtk] )
+ playlist? ( >=dev-libs/totem-pl-parser-2.26:= )
+ rygel? ( >=net-misc/rygel-0.26 )
+ soup? ( >=net-libs/libsoup-2.38:= )
+ udev? ( virtual/libgudev:= )"
+RDEPEND="${COMMON_DEPEND}
+ media-plugins/gst-plugins-meta:1.0"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ >=dev-util/xfce4-dev-tools-4.10
+ sys-devel/gettext
+ virtual/pkgconfig
+ xfce-base/exo"
+REQUIRED_USE="glyr? ( peas )
+ grilo? ( peas )
+ koel? ( soup )
+ libnotify? ( peas )
+ mtp? ( udev )
+ rygel? ( peas )
+ soup? ( peas )
+ udev? ( peas )"
+
+src_configure() {
+ local myconf=(
+ $(use_enable peas libpeas-1.0)
+ $(use_enable glyr libglyr)
+ $(use_enable lastfm libclastfm)
+ $(use_enable cdda libcdio)
+ $(use_enable cdda libcdio_paranoia)
+ $(use_enable cdda libcddb)
+ $(use_enable playlist totem-plparser)
+
+ $(use_enable libnotify)
+ $(use_enable keybinder)
+ $(use_enable udev gudev-1.0)
+ $(use_enable mtp libmtp)
+ $(use_enable koel json-glib-1.0)
+ $(use_enable soup libsoup-2.4)
+ $(use_enable rygel rygel-server-2.6)
+ $(use_enable grilo grilo-0.3)
+ $(use_enable grilo grilo-net-0.3)
+ # avoid trying to use 0.2 & 0.3 simultaneously
+ # https://github.com/pragha-music-player/pragha/issues/124
+ --disable-grilo-0.2
+ --disable-grilo-net-0.2
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}