summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrendan Horan <brendanhoran@basstech.net>2016-08-31 22:17:23 +0800
committerDavid Seifert <soap@gentoo.org>2016-09-04 20:58:11 +0200
commita1c40f3d38a6cbdeee0e7ff9775b0e516e6eb984 (patch)
tree25f3aeed65494be9945a1fbd70cfe89b56ae28c8 /media-sound
parentdev-libs/quazip: remove unused patches (diff)
downloadgentoo-a1c40f3d38a6cbdeee0e7ff9775b0e516e6eb984.tar.gz
gentoo-a1c40f3d38a6cbdeee0e7ff9775b0e516e6eb984.tar.bz2
gentoo-a1c40f3d38a6cbdeee0e7ff9775b0e516e6eb984.zip
media-sound/fmit: Fixed RDEPEND, bump to -r1
* Removed media-libs/freeglut from RDEPEND, upstream no longer need * Added dev-qt/linguist-tools to RDEPEND * Slotted sci-libs/fftw, should rebuild on (sub)-slot changes Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2176 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/fmit/fmit-1.0.15-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/media-sound/fmit/fmit-1.0.15-r1.ebuild b/media-sound/fmit/fmit-1.0.15-r1.ebuild
new file mode 100644
index 000000000000..646c5bde4aba
--- /dev/null
+++ b/media-sound/fmit/fmit-1.0.15-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="Free Music Instrument Tuner"
+HOMEPAGE="https://gillesdegottex.github.io/fmit"
+SRC_URI="https://github.com/gillesdegottex/fmit/archive/v${PV}.tar.gz \
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa jack oss portaudio"
+
+RDEPEND=">=sci-libs/fftw-3.3.4:3.0=
+ dev-qt/qtmultimedia:5
+ dev-qt/qtopengl:5
+ dev-qt/qtsvg:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[-gles2]
+ alsa? ( media-libs/alsa-lib )
+ jack? ( media-sound/jack-audio-connection-kit )
+ portaudio? ( media-libs/portaudio )"
+
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools"
+
+src_prepare() {
+ # Fix the path to readme file to prevent errors on start up
+ sed -i "/QFile readmefile/c\QFile readmefile \
+ (\"/usr/share/doc/${PF}/README.txt\");" \
+ src/main.cpp || die "README sed failed"
+ # Fix the PREFIX location, insert real path.
+ sed -i "/QString fmitprefix/c\QString fmitprefix(STR(/usr));" \
+ src/main.cpp || die "PREFIX fix sed failed"
+ # Fix the PREFIX location, insert real path.
+ sed -i "/QString fmitprefix/c\QString fmitprefix(STR(/usr));" \
+ src/modules/MicrotonalView.cpp || die "PREFIX fix sed failed"
+ default
+}
+
+src_configure() {
+ local config flag
+ for flag in alsa jack portaudio oss; do
+ use ${flag} && config+=" acs_${flag}"
+ done
+
+ "$(qt5_get_bindir)"/lrelease fmit.pro || die "Running lrelease failed"
+
+ eqmake5 CONFIG+="${config}" fmit.pro PREFIX="${D}"/usr \
+ PREFIXSHORTCUT="${D}"/usr DISTDIR=/usr
+}