summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-09-03 13:47:12 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-09-03 13:47:12 -0500
commitada2cd969b6cb40d987b025f9a7fc12a0069abcd (patch)
tree66c27a65d8c9b68e7f68aeb76d4fa90f67c53842 /media-sound
parentapp-crypt/certbot: fixing the deps (diff)
downloadgentoo-ada2cd969b6cb40d987b025f9a7fc12a0069abcd.tar.gz
gentoo-ada2cd969b6cb40d987b025f9a7fc12a0069abcd.tar.bz2
gentoo-ada2cd969b6cb40d987b025f9a7fc12a0069abcd.zip
media-sound/spotify: bup
Package-Manager: portage-2.2.28
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/spotify/Manifest2
-rw-r--r--media-sound/spotify/spotify-1.0.37.ebuild117
2 files changed, 119 insertions, 0 deletions
diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
index 5107e35fdb6b..d4ea77a0c6f4 100644
--- a/media-sound/spotify/Manifest
+++ b/media-sound/spotify/Manifest
@@ -1,2 +1,4 @@
DIST spotify-client_1.0.36.120.g536a862f-20_amd64.deb 79230104 SHA256 c041f58229451d54dac65da98d5d3d2d005cbc38366cddccad7f38d2c987240f SHA512 a8723d49d8dc1a68b033c032873c020732a2e5d52d19527eec74959b1b5aa0e052e40ed021a7d42dcb96718f1c4385aa0ab9f572ce92b9618f347ed7d80393d7 WHIRLPOOL fc475b7c8ffec19ca722d579dc48dff847a0ca1c6afd4f0c3eff319452cc47f8ec9107f9ea01e931e4a76d1ed65ef1129f4893035927aade979823e1ef91528c
DIST spotify-client_1.0.36.120.g536a862f-2_i386.deb 87489612 SHA256 8f8b6b1ba42fa6b610b608f92c0f81ace1b07482ac663ba4381a58bf05dc582c SHA512 d46ccd1d93e69c46f9b581a8f112113dd968593457f5067690e53252470d0979891a7948504280d3e847388dd29c637047fccf44c6784c68b0ca0fdbdc576413 WHIRLPOOL 5a5e5a19d00bcb6e0a7f4ee4adbbff88bfd15400c41636fa6ff1ab1100c66403071bdacdfd0f0d70af70f0d25e6a09e4c767f709c71127f09e68ef29b3fea679
+DIST spotify-client_1.0.37.152.gc83ea995-42_amd64.deb 79521822 SHA256 9da56b2f696159361bcf6eac0a218ef0a669802f8deb3be17dbf25cb062e0d02 SHA512 c148a4bfdaae14b1d87fa09b6d4c9780fd87e594ae310f8fc1d696be6111214f88ddc239e368faab17d327a5c7ec2b745391d4f114bd41ad9ce6e3b731790609 WHIRLPOOL f49cf8f0ead7a4c436b7491e5c8fc3991133b89e623fc323260a0905b67ef25c26cab0fb6866e8a18a5448110a7e7157c8dc796ae6548469670598f654c7eb6b
+DIST spotify-client_1.0.37.152.gc83ea995-42_i386.deb 87737188 SHA256 a5a33f167491455df03f791b818c64e90f4a35b0d83284bb223e15bd4a45f228 SHA512 ef18a4ad61427669c2da00dbd2487882de2cfab191c42cc385f0db230b2bae6b0f03f504c60f5dde67aecc12becb0076727729f6380a7fa88ce01d140965efd1 WHIRLPOOL 64449c68c60c2e46dd16f109a0e3c14f2c844bb9b43ad7cb7d7ab2a3ac603bf34d895637b881341d09f77ef60e82eae513a003b6f494e429899ace42b022bc71
diff --git a/media-sound/spotify/spotify-1.0.37.ebuild b/media-sound/spotify/spotify-1.0.37.ebuild
new file mode 100644
index 000000000000..79731ade8a0d
--- /dev/null
+++ b/media-sound/spotify/spotify-1.0.37.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils fdo-mime gnome2-utils pax-utils unpacker
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
+SRC_BASE="http://repository.spotify.com/pool/non-free/${PN:0:1}/${PN}-client/"
+SRC_URI="amd64? ( ${SRC_BASE}${PN}-client_${PV}.152.gc83ea995-42_amd64.deb )
+ x86? ( ${SRC_BASE}${PN}-client_${PV}.152.gc83ea995-42_i386.deb )"
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome pax_kernel pulseaudio"
+RESTRICT="mirror strip"
+
+DEPEND=""
+# zenety needed for filepicker
+RDEPEND="
+ ${DEPEND}
+ dev-libs/nss
+ gnome-base/gconf
+ gnome-extra/zenity
+ media-libs/alsa-lib
+ media-libs/harfbuzz
+ media-libs/fontconfig
+ media-libs/mesa
+ net-misc/curl[ssl,curl_ssl_openssl]
+ net-print/cups[ssl]
+ x11-libs/gtk+:2
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ dev-python/pygobject:3
+ dev-python/dbus-python
+ pulseaudio? ( media-sound/pulseaudio )
+ gnome? ( gnome-extra/gnome-integration-spotify )"
+ #sys-libs/glibc
+
+S=${WORKDIR}/
+
+QA_PREBUILT="opt/spotify/spotify-client/spotify"
+
+src_prepare() {
+ # Fix desktop entry to launch spotify-dbus.py for GNOME integration
+ if use gnome ; then
+ sed -i \
+ -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+ usr/share/spotify/spotify.desktop || die "sed failed"
+ fi
+ default
+}
+
+src_install() {
+ dodoc usr/share/doc/spotify-client/changelog.gz
+
+ SPOTIFY_PKG_HOME=usr/share/spotify
+ insinto /usr/share/pixmaps
+ doins ${SPOTIFY_PKG_HOME}/icons/*.png
+
+ # install in /opt/spotify
+ SPOTIFY_HOME=/opt/spotify/spotify-client
+ insinto ${SPOTIFY_HOME}
+ doins -r ${SPOTIFY_PKG_HOME}/*
+ fperms +x ${SPOTIFY_HOME}/spotify
+
+ dodir /usr/bin
+ cat <<-EOF >"${D}"/usr/bin/spotify || die
+ #! /bin/sh
+ exec ${SPOTIFY_HOME}/spotify "\$@"
+ EOF
+ fperms +x /usr/bin/spotify
+
+ local size
+ for size in 16 22 24 32 48 64 128 256 512; do
+ newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
+ "spotify-client.png"
+ done
+ domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+ if use pax_kernel; then
+ #create the headers, reset them to default, then paxmark -m them
+ pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+ eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+ eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ eqawarn "you suspect that ${PN} is being broken by this modification,"
+ eqawarn "please open a bug."
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+
+ ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+ ewarn "To remove the cache:"
+ ewarn "rm -rf ~/.cache/spotify"
+ ewarn
+ ewarn "If you use KDE and are upgrading from 0.9 to 1.0, you might still see the old icon."
+ ewarn "Run"
+ ewarn "$ rm /var/tmp/kdecache-\$USER/icon-cache.kcache"
+ ewarn "Then log out and log in back to KDE."
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}