summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-10-24 10:59:55 +0200
committerPacho Ramos <pacho@gentoo.org>2015-10-24 10:59:55 +0200
commitc2708cc297bfff6ea1ef7d76317fdd00443a25b8 (patch)
treef338afddbaa2f318057c4452ff29880fb3852af4 /media-sound
parentthirdpartymirrors: nero is no longer used (#510594) (diff)
downloadgentoo-c2708cc297bfff6ea1ef7d76317fdd00443a25b8.tar.gz
gentoo-c2708cc297bfff6ea1ef7d76317fdd00443a25b8.tar.bz2
gentoo-c2708cc297bfff6ea1ef7d76317fdd00443a25b8.zip
media-sound/spek: Support wxGTK:3.0, use new ffmpeg/libav handling (#563332)
Package-Manager: portage-2.2.23
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/spek/spek-0.8.3-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-sound/spek/spek-0.8.3-r1.ebuild b/media-sound/spek/spek-0.8.3-r1.ebuild
new file mode 100644
index 000000000000..e61810978aa7
--- /dev/null
+++ b/media-sound/spek/spek-0.8.3-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WX_GTK_VER="3.0"
+
+inherit autotools eutils toolchain-funcs wxwidgets
+
+DESCRIPTION="Analyse your audio files by showing their spectrogram"
+HOMEPAGE="http://www.spek-project.org/"
+SRC_URI="https://github.com/alexkay/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libav"
+
+RDEPEND="
+ libav? ( media-video/libav:= )
+ !libav? ( media-video/ffmpeg:0= )
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ >=sys-devel/gcc-4.7
+ sys-devel/gettext
+"
+
+src_prepare() {
+ need-wxwidgets unicode
+
+ if [ $(gcc-major-version) -lt "4" ] ; then
+ die "You need to activate at least gcc:4.7"
+ fi
+ if [ $(gcc-major-version) -eq "4" -a $(gcc-minor-version) -lt "7" ] ; then
+ die "You need to activate at least gcc:4.7"
+ fi
+
+ epatch \
+ "${FILESDIR}"/${PN}-0.8.1-disable-updates.patch \
+ "${FILESDIR}"/${P}-replace-gnu+11-with-c++11.patch \
+ "${FILESDIR}"/${P}-stdlib.patch
+ eautoreconf
+}