summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2016-08-11 19:27:01 +0300
committerMarek Szuba <marecki@gentoo.org>2016-08-11 22:56:27 +0200
commitc6c50d144477c6aad74dbbebb36ef3f1e5410d05 (patch)
tree088778024ec9c1f7d39a48bf3adc732a02fd085a /media-sound
parentx11-misc/xmobar: drop old (diff)
downloadgentoo-c6c50d144477c6aad74dbbebb36ef3f1e5410d05.tar.gz
gentoo-c6c50d144477c6aad74dbbebb36ef3f1e5410d05.tar.bz2
gentoo-c6c50d144477c6aad74dbbebb36ef3f1e5410d05.zip
media-sound/pms: live ebuild overhaul
Updated homepage and repo URIs Bumped EAPI to version 6 Fixed build with ncurses[tinfo] Added dependency on media-libs/libmpdclient Removed obsolete boost dependency Updated USE-flags and upstream metadata Added new maintainer info Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/pms/metadata.xml13
-rw-r--r--media-sound/pms/pms-9999.ebuild34
2 files changed, 25 insertions, 22 deletions
diff --git a/media-sound/pms/metadata.xml b/media-sound/pms/metadata.xml
index 2476d56bc0ec..aa181ca7a9c6 100644
--- a/media-sound/pms/metadata.xml
+++ b/media-sound/pms/metadata.xml
@@ -1,11 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>hilobakho@gmail.com</email>
+ <name>Mykyta Holubakha</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
<use>
- <flag name="regex">Enable regular expression searches
- using <pkg>dev-libs/boost</pkg></flag>
+ <flag name="regex">Enable regular expression searches</flag>
</use>
<upstream>
- <remote-id type="sourceforge">pms</remote-id>
+ <remote-id type="github">ambientsound/pms</remote-id>
</upstream>
</pkgmetadata>
diff --git a/media-sound/pms/pms-9999.ebuild b/media-sound/pms/pms-9999.ebuild
index 7ead914d10b8..96f9c35584b4 100644
--- a/media-sound/pms/pms-9999.ebuild
+++ b/media-sound/pms/pms-9999.ebuild
@@ -1,16 +1,14 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=2
+EAPI=6
-inherit autotools git-2
+inherit autotools flag-o-matic git-r3
DESCRIPTION="Practical Music Search: an open source ncurses client for mpd, written in C++"
-HOMEPAGE="http://pms.sourceforge.net/"
-SRC_URI=""
-
-EGIT_REPO_URI="git://pms.git.sourceforge.net/gitroot/pms/pms"
+HOMEPAGE="https://ambientsound.github.io/pms"
+EGIT_REPO_URI="https://github.com/ambientsound/pms.git"
LICENSE="GPL-3"
SLOT="0"
@@ -18,30 +16,28 @@ KEYWORDS=""
IUSE="regex"
RDEPEND="
- sys-libs/ncurses
+ sys-libs/ncurses[unicode]
dev-libs/glib:2
- regex? ( >=dev-libs/boost-1.36 )
+ media-libs/libmpdclient
"
DEPEND="
virtual/pkgconfig
${RDEPEND}
"
+DOCS=( AUTHORS README TODO )
+
src_prepare() {
- # bug #424717
- sed -i "s:^CXXFLAGS +=:AM_CXXFLAGS =:g" Makefile.am || die "sed failed"
+ eapply_user
eautoreconf
}
src_configure() {
- econf \
- $(use_enable regex) ||
- die "configure failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "installation failed"
+ # Required for ncurses[tinfo]
+ append-cppflags $(pkg-config --cflags ncursesw)
+ append-libs $(pkg-config --libs ncursesw)
- dodoc AUTHORS README TODO
+ econf \
+ $(use_enable regex)
}