summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-05-19 11:45:51 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-05-19 11:46:13 +0200
commitcec80d00caf5ead084760f175d168623e8eef6fb (patch)
tree19afff1520f8290c348db259f1c3e51e1606599d /media-sound
parentdev-python/setuptools: amd64/arm64/arm/hppa/ppc64/ppc/sparc/x86 stable (ALLAR... (diff)
downloadgentoo-cec80d00caf5ead084760f175d168623e8eef6fb.tar.gz
gentoo-cec80d00caf5ead084760f175d168623e8eef6fb.tar.bz2
gentoo-cec80d00caf5ead084760f175d168623e8eef6fb.zip
media-sound/amsynth: fixed compilation of 1.12.2 wrt x11
Closes: https://bugs.gentoo.org/791043 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amsynth/amsynth-1.12.2.ebuild10
-rw-r--r--media-sound/amsynth/files/amsynth-1.12.2-x11.patch22
2 files changed, 31 insertions, 1 deletions
diff --git a/media-sound/amsynth/amsynth-1.12.2.ebuild b/media-sound/amsynth/amsynth-1.12.2.ebuild
index 6afc53191fed..872703207acb 100644
--- a/media-sound/amsynth/amsynth-1.12.2.ebuild
+++ b/media-sound/amsynth/amsynth-1.12.2.ebuild
@@ -28,7 +28,10 @@ RDEPEND="
media-libs/dssi:=
media-libs/liblo:=
)
- gtk? ( x11-libs/gtk+:2 )
+ gtk? (
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ )
jack? ( virtual/jack )
lash? ( media-sound/lash )
lv2? ( media-libs/lv2 )
@@ -41,6 +44,11 @@ PATCHES=(
"${FILESDIR}/${P}-metadata.patch"
)
+src_prepare() {
+ default
+ ! use gtk && eapply "${FILESDIR}/${P}-x11.patch"
+}
+
src_configure() {
econf \
$(use_with alsa) \
diff --git a/media-sound/amsynth/files/amsynth-1.12.2-x11.patch b/media-sound/amsynth/files/amsynth-1.12.2-x11.patch
new file mode 100644
index 000000000000..2222fc1eb355
--- /dev/null
+++ b/media-sound/amsynth/files/amsynth-1.12.2-x11.patch
@@ -0,0 +1,22 @@
+diff --git a/Makefile.in b/Makefile.in
+index e0dd2a6..4449599 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -1297,7 +1297,7 @@ amsynth_SOURCES = $(libcore_sources) $(libdsp_sources) \
+ $(am__append_1) $(am__append_3) $(am__append_4)
+ amsynth_CPPFLAGS = $(AM_CPPFLAGS) @ALSA_CFLAGS@ @JACK_CFLAGS@ @LASH_CFLAGS@ @LIBLO_CFLAGS@ @GTK_CFLAGS@
+ amsynth_LDADD = @ALSA_LIBS@ @JACK_LIBS@ @LASH_LIBS@ @LIBLO_LIBS@ \
+- @LIBS@ -lX11 $(am__append_2)
++ @LIBS@ $(am__append_2)
+ @DARWIN_TRUE@amsynth_LDFLAGS = $(AM_LDFLAGS) -framework CoreFoundation -framework CoreAudio -framework CoreMIDI
+
+ #
+@@ -1317,7 +1317,7 @@ noinst_LTLIBRARIES = $(am__append_5) $(am__append_6) $(am__append_7)
+ @BUILD_DSSI_TRUE@amsynth_dssi_la_LDFLAGS = -rpath $(dssidir) -avoid-version -module -export-symbols-regex "dssi_descriptor" -disable-static
+ @BUILD_DSSI_GUI_TRUE@amsynth_dssi_gtk_SOURCES = src/amsynth_dssi_gtk.cpp $(libcore_sources) $(libgui_sources)
+ @BUILD_DSSI_GUI_TRUE@amsynth_dssi_gtk_CPPFLAGS = $(AM_CPPFLAGS) @DSSI_CFLAGS@ @GTK_CFLAGS@ @LIBLO_CFLAGS@
+-@BUILD_DSSI_GUI_TRUE@amsynth_dssi_gtk_LDADD = @DSSI_LIBS@ @GTK_LIBS@ @LIBLO_LIBS@ -lstdc++ -lX11
++@BUILD_DSSI_GUI_TRUE@amsynth_dssi_gtk_LDADD = @DSSI_LIBS@ @GTK_LIBS@ @LIBLO_LIBS@ -lstdc++
+
+ #
+ # LV2