summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-11-15 16:23:56 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-11-15 18:40:22 +0100
commiteb4f072c1e2f6e1333cb17bf0119a05916f5404a (patch)
treeb0b8210e4e2037d54edd38ef5f76debdd585f233 /media-sound
parentmedia-libs/alsa-lib: Bump to version 1.1.5 (diff)
downloadgentoo-eb4f072c1e2f6e1333cb17bf0119a05916f5404a.tar.gz
gentoo-eb4f072c1e2f6e1333cb17bf0119a05916f5404a.tar.bz2
gentoo-eb4f072c1e2f6e1333cb17bf0119a05916f5404a.zip
media-sound/alsa-utils: Bump to version 1.1.5
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-utils/Manifest1
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.1.5.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/media-sound/alsa-utils/Manifest b/media-sound/alsa-utils/Manifest
index ccdb2cbd061d..072b5d0c2940 100644
--- a/media-sound/alsa-utils/Manifest
+++ b/media-sound/alsa-utils/Manifest
@@ -1,3 +1,4 @@
DIST alsa-utils-1.1.2.tar.bz2 1193140 SHA256 7af603c0877d1251599d65b4fbc372e63a54371b888f5c26c6a86ac1d0519071 SHA512 38dc3331e8410123085738e74ca34c860666027ee2f6aaa21f48e726c84d8e6264043c8c7111ce2b1e158a0f38142a04d72a128ee54e00173dc4e4ba514d2f14 WHIRLPOOL 353d636271fd4354e7a7b986c08a3eabdb91bb8239b3d14a2163dea095dee010cd777276901c11df58a4fcba24680770512df4784e446a63941224f9ee79f632
DIST alsa-utils-1.1.3.tar.bz2 1201424 SHA256 127217a54eea0f9a49700a2f239a2d4f5384aa094d68df04a8eb80132eb6167c SHA512 a0a00578e7f7ed8441628757048412813a0345f0a3f2e085cda7a881ae3c6e22f7cf1e5119f8200e2e4340e42152b91aa5bdc20646b8422adc74ba00e4c59363 WHIRLPOOL 10f1f8f5b7a659dc7ba79c934076eafbbd72f4892b571660a6224fc1061b4e893e2f5a937187a4eb50f2e982c07e097c965a88052451218adcde2e5cd3bfb6f9
DIST alsa-utils-1.1.4.tar.bz2 1202047 SHA256 a7831044de92c5bf33bf3365a3f36e49397f4191e934df460ae1ca15138c9d9d SHA512 96852b3f5b57d7d9078a20881f28311543d446b69c80450179823a225089df7306456991890a7ef37672c1f55e9c386a7731c94e125504dcda2c88a674c8b4c7 WHIRLPOOL f09be2aeb3402b580ba103cfacb854b4fd55c2c19bfcfb7e56d4b924add5eb17d4fcb523cf7d85482728da8d8cfde0033cf205a7f9e53225a9b7a4a59a906f28
+DIST alsa-utils-1.1.5.tar.bz2 1202691 SHA256 320bd285e91db6e7fd7db3c9ec6f55b02f35449ff273c7844780ac6a5a3de2e8 SHA512 102e9ed34b89219dbad243ad5f61ca65fb8101502566c02f40d4e69abb45baa7a60f24440de1417e0f0e7f55b28db53d365d53a59af11f1ca816e2aa5907153d WHIRLPOOL f1afb19d2135500a0552825e89eb115c2cb00812ee1e911c7710246c08cbdb53d267b535fb8775b3e895f9a6550fd447873aaa22a3d698c2cac5080dc7e32efe
diff --git a/media-sound/alsa-utils/alsa-utils-1.1.5.ebuild b/media-sound/alsa-utils/alsa-utils-1.1.5.ebuild
new file mode 100644
index 000000000000..87137657c10e
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.1.5.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils systemd udev
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="bat doc +libsamplerate +ncurses nls selinux"
+
+CDEPEND=">=media-libs/alsa-lib-${PV}
+ libsamplerate? ( media-libs/libsamplerate )
+ ncurses? ( >=sys-libs/ncurses-5.7-r7:0= )
+ bat? ( sci-libs/fftw:= )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? ( app-text/xmlto )"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-alsa )"
+
+src_configure() {
+ local myconf
+ use doc || myconf='--disable-xmlto'
+
+ # --disable-alsaconf because it doesn't work with sys-apps/kmod wrt #456214
+ econf \
+ --disable-maintainer-mode \
+ $(use_enable bat) \
+ $(use_enable libsamplerate alsaloop) \
+ $(use_enable nls) \
+ $(use_enable ncurses alsamixer) \
+ --disable-alsaconf \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ --with-udev-rules-dir="${EPREFIX}/$(get_udevdir)"/rules.d \
+ --with-asound-state-dir="${EPREFIX}"/var/lib/alsa \
+ ${myconf}
+}
+
+src_install() {
+ default
+ dodoc seq/*/README.*
+
+ newinitd "${FILESDIR}"/alsasound.initd-r7 alsasound
+ newconfd "${FILESDIR}"/alsasound.confd-r4 alsasound
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/alsa-modules.conf-rc alsa.conf
+
+ keepdir /var/lib/alsa
+
+ # ALSA lib parser.c:1266:(uc_mgr_scan_master_configs) error: could not
+ # scan directory /usr/share/alsa/ucm: No such file or directory
+ # alsaucm: unable to obtain card list: No such file or directory
+ keepdir /usr/share/alsa/ucm
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "To take advantage of the init script, and automate the process of"
+ elog "saving and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog "# rc-update add alsasound boot"
+ ewarn
+ ewarn "The ALSA core should be built into the kernel or loaded through other"
+ ewarn "means. There is no longer any modular auto(un)loading in alsa-utils."
+ fi
+}