summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-11-01 12:31:46 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-11-01 12:32:10 +0100
commitf1fe704b3aa097b4f533e0cdcf31557782a48c76 (patch)
tree75b51a8ea3b832bf6f5e5b17bdd162e59ea972c3 /media-sound
parentdev-tcltk/expect: arm stable wrt bug #694622 (diff)
downloadgentoo-f1fe704b3aa097b4f533e0cdcf31557782a48c76.tar.gz
gentoo-f1fe704b3aa097b4f533e0cdcf31557782a48c76.tar.bz2
gentoo-f1fe704b3aa097b4f533e0cdcf31557782a48c76.zip
media-sound/jack2-1.9.13: bump
Closes: https://github.com/gentoo/gentoo/pull/13383 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/jack2/Manifest1
-rw-r--r--media-sound/jack2/jack2-1.9.13.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/media-sound/jack2/Manifest b/media-sound/jack2/Manifest
index 1dd71b0983c4..9864c8b207f0 100644
--- a/media-sound/jack2/Manifest
+++ b/media-sound/jack2/Manifest
@@ -1 +1,2 @@
DIST jack2-1.9.12.tar.gz 6487135 BLAKE2B 9140b3892d2321576a7329fbef2f23e340be4b9be967ec173edbbc7a43952c9a3712ead05dbe57f958b88c1e29c8a912a937c0bd34e0122ecc600ac9d48f147d SHA512 f0271dfc8f8e2f2489ca52f431ad4fa420665816d6c67a01a76da1d4b5ae91f6dad8c4e3309ec5e0c159c9d312ed56021ab323d74bce828ace26f1b8d477ddfa
+DIST jack2-1.9.13.tar.gz 6485870 BLAKE2B 7acc0a1389af133dafa7368b4285c2a06607d84015601f2d8afbd63a9a08f40210f8206f2febbd0e5cc651513a59419e1d948a56163d2074c4b77da5edd84a52 SHA512 dd83a6535cf92a3c45b5ed31edda5f1cb4a6c1db2ac683d4ea709e226bc30d55b366ce80ee543dfaa600f871079f3754e9314124093e230dc7deeceb828de8aa
diff --git a/media-sound/jack2/jack2-1.9.13.ebuild b/media-sound/jack2/jack2-1.9.13.ebuild
new file mode 100644
index 000000000000..54bed398c30a
--- /dev/null
+++ b/media-sound/jack2/jack2-1.9.13.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 python3_7 )
+PYTHON_REQ_USE="threads(+)"
+inherit python-single-r1 waf-utils multilib-minimal
+
+DESCRIPTION="Jackdmp jack implemention for multi-processor machine"
+HOMEPAGE="http://jackaudio.org/"
+
+if [[ "${PV}" = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jackaudio/${PN}.git"
+else
+ MY_PV="${PV/_rc/-RC}"
+ MY_P="${PN}-${MY_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/jackaudio/jack2/releases/download/v${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="2"
+IUSE="alsa +classic dbus doc ieee1394 libsamplerate opus pam readline sndfile"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( classic dbus )"
+
+CDEPEND="${PYTHON_DEPS}
+ media-libs/libsamplerate
+ media-libs/libsndfile
+ sys-libs/readline:0=
+ alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
+ dbus? (
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ )
+ ieee1394? ( media-libs/libffado:=[${MULTILIB_USEDEP}] )
+ opus? ( media-libs/opus[custom-modes,${MULTILIB_USEDEP}] )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+RDEPEND="${CDEPEND}
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ pam? ( sys-auth/realtime-base )
+ !media-sound/jack-audio-connection-kit:0"
+
+DOCS=( ChangeLog.rst README.rst README_NETJACK2 )
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local mywafconfargs=(
+ --htmldir=/usr/share/doc/${PF}/html
+ $(usex dbus --dbus "")
+ $(usex classic --classic "")
+ --alsa=$(usex alsa yes no)
+ --celt=no
+ --doxygen=$(multilib_native_usex doc yes no)
+ --firewire=$(usex ieee1394 yes no)
+ --iio=no
+ --opus=$(usex opus yes no)
+ --portaudio=no
+ --readline=$(multilib_native_usex readline yes no)
+ --samplerate=$(multilib_native_usex libsamplerate yes no)
+ --sndfile=$(multilib_native_usex sndfile yes no)
+ --winmme=no
+ )
+
+ waf-utils_src_configure ${mywafconfargs[@]}
+}
+
+multilib_src_compile() {
+ WAF_BINARY="${BUILD_DIR}"/waf waf-utils_src_compile
+}
+
+multilib_src_install() {
+ WAF_BINARY="${BUILD_DIR}"/waf waf-utils_src_install
+}
+
+multilib_src_install_all() {
+ python_fix_shebang "${ED}"
+}