summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-13 15:28:42 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-13 15:31:16 +0100
commitf803187d334a0b771d118f00879f2e4c452372d2 (patch)
tree637b071a8e92566731c9fbe57113704bce1c46f2 /media-sound
parentmedia-sound/lmms: Bump to version 1.2.0_rc8 (diff)
downloadgentoo-f803187d334a0b771d118f00879f2e4c452372d2.tar.gz
gentoo-f803187d334a0b771d118f00879f2e4c452372d2.tar.bz2
gentoo-f803187d334a0b771d118f00879f2e4c452372d2.zip
media-sound/lmms: Synced live ebuild.
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lmms/lmms-9999.ebuild27
1 files changed, 16 insertions, 11 deletions
diff --git a/media-sound/lmms/lmms-9999.ebuild b/media-sound/lmms/lmms-9999.ebuild
index 85c5734ae478..44670637ff58 100644
--- a/media-sound/lmms/lmms-9999.ebuild
+++ b/media-sound/lmms/lmms-9999.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils xdg-utils
+# The order is important here! Both, cmake-utils and xdg define src_prepare.
+# We need the one from cmake-utils
+inherit xdg cmake-utils
DESCRIPTION="Cross-platform music production software"
HOMEPAGE="https://lmms.io"
@@ -11,7 +13,7 @@ if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/LMMS/lmms.git"
inherit git-r3
else
- SRC_URI="https://github.com/LMMS/${PN}/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/LMMS/lmms/releases/download/v${PV/_/-}/${P/_/-}.tar.xz -> ${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${P/_/-}"
fi
@@ -24,6 +26,8 @@ IUSE="alsa debug fluidsynth jack libgig mp3 ogg portaudio pulseaudio sdl soundio
COMMON_DEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
>=media-libs/libsamplerate-0.1.8
>=media-libs/libsndfile-1.0.11
sci-libs/fftw:3.0
@@ -48,9 +52,9 @@ COMMON_DEPEND="
stk? ( media-libs/stk )
vst? ( virtual/wine )
"
-DEPEND="${COMMON_DEPEND}
+DEPEND="${COMMON_DEPEND}"
+BDEPEND="
dev-qt/linguist-tools:5
- >=dev-util/cmake-2.4.5
"
RDEPEND="${COMMON_DEPEND}
media-libs/ladspa-cmt
@@ -72,7 +76,6 @@ src_configure() {
-DWANT_CMT=FALSE
-DWANT_CALF=FALSE
-DWANT_QT5=TRUE
- -DCMAKE_INSTALL_LIBDIR=$(get_libdir)
-DWANT_ALSA=$(usex alsa)
-DWANT_JACK=$(usex jack)
-DWANT_GIG=$(usex libgig)
@@ -89,12 +92,14 @@ src_configure() {
cmake-utils_src_configure
}
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
pkg_postinst() {
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
+ xdg_pkg_postinst
}
pkg_postrm() {
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
+ xdg_pkg_postrm
}