summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-10 15:18:56 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-10 17:41:47 +0100
commitf92198054d0550ae9e2cda436654f9f3ebe33b2d (patch)
treed40a4809e1ae843c3a0f3f970198776c4d09d4a0 /media-sound
parentapp-arch/tar: Security cleanup (diff)
downloadgentoo-f92198054d0550ae9e2cda436654f9f3ebe33b2d.tar.gz
gentoo-f92198054d0550ae9e2cda436654f9f3ebe33b2d.tar.bz2
gentoo-f92198054d0550ae9e2cda436654f9f3ebe33b2d.zip
media-sound/seq24: Drop 0.9.2-r1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/seq24/Manifest1
-rw-r--r--media-sound/seq24/files/seq24-0.9.2-lash-fix.patch248
-rw-r--r--media-sound/seq24/seq24-0.9.2-r1.ebuild40
3 files changed, 0 insertions, 289 deletions
diff --git a/media-sound/seq24/Manifest b/media-sound/seq24/Manifest
index a52e6a93498a..00118c69f51b 100644
--- a/media-sound/seq24/Manifest
+++ b/media-sound/seq24/Manifest
@@ -1,2 +1 @@
-DIST seq24-0.9.2.tar.bz2 213059 BLAKE2B e67a63182f34f7452a8f0550591b5a3d13409782eb42064cff347b333f40ca656477ed601f8b7178f01f35873c992ea8a3d574b43f186b3979f8e09030b8b64c SHA512 31e57c7fafbccf85a69229674d3bcfb86e2fa9b2f095b50fd59a44673896edc5c4f9dd97585923cee9129bc8619ac6eb33274241271cdcc56732c920d4106ec8
DIST seq24-0.9.3.tar.bz2 221014 BLAKE2B 94b771712d53b3a74d9fed249822ce890959b9159ed8ca0d4f30909f186f1c63a4c93b7e11adcbe51219fd4894469af8cb147da1ee8f82dcc1b42e9d16150d96 SHA512 f0fe13ceedbc87899df058918f3bdd57dbb9f1a3491d23503ae48367ba9eebdd2c8b5706b7b041db0959703a941d52d67f57823937ffdc574b01323eda32e3ad
diff --git a/media-sound/seq24/files/seq24-0.9.2-lash-fix.patch b/media-sound/seq24/files/seq24-0.9.2-lash-fix.patch
deleted file mode 100644
index 8b0efadb7b55..000000000000
--- a/media-sound/seq24/files/seq24-0.9.2-lash-fix.patch
+++ /dev/null
@@ -1,248 +0,0 @@
-Upstream fix for segfault when built with lash support.
-https://bugs.launchpad.net/seq24/+bug/696371
-
-=== modified file 'src/lash.cpp'
---- old/src/lash.cpp
-+++ new/src/lash.cpp
-@@ -29,17 +29,9 @@
- lash::lash(int *argc, char ***argv)
- {
- #ifdef LASH_SUPPORT
-- m_lash_args = lash_extract_args(argc, argv);
--#endif // LASH_SUPPORT
--}
--
--
--void lash::init(perform* perform)
--{
--#ifdef LASH_SUPPORT
-- m_perform = perform;
--
-- m_client = lash_init(m_lash_args, PACKAGE_NAME,
-+ m_perform = NULL;
-+
-+ m_client = lash_init(lash_extract_args(argc, argv), PACKAGE_NAME,
- LASH_Config_File, LASH_PROTOCOL(2, 0));
-
- if (m_client == NULL) {
-@@ -65,9 +57,10 @@
-
-
- void
--lash::start()
-+lash::start(perform* perform)
- {
- #ifdef LASH_SUPPORT
-+ m_perform = perform;
- /* Process any LASH events every 250 msec (arbitrarily chosen interval) */
- Glib::signal_timeout().connect(sigc::mem_fun(*this, &lash::process_events), 250);
- #endif // LASH_SUPPORT
-
-=== modified file 'src/lash.h'
---- old/src/lash.h
-+++ new/src/lash.h
-@@ -43,7 +43,6 @@
- #ifdef LASH_SUPPORT
- perform *m_perform;
- lash_client_t *m_client;
-- lash_args_t *m_lash_args;
-
- bool process_events();
- void handle_event(lash_event_t* conf);
-@@ -54,13 +53,12 @@
- public:
- lash(int *argc, char ***argv);
-
-- void init(perform* perform);
- void set_alsa_client_id(int id);
-- void start();
-+ void start(perform* perform);
- };
-
-
--/* global lash driver, defined in seq24.cpp */
-+/* global lash driver, defined in seq24.cpp and used in midibus.cpp*/
- extern lash *lash_driver;
-
-
-
-=== modified file 'src/midibus.cpp'
---- old/src/midibus.cpp
-+++ new/src/midibus.cpp
-@@ -877,11 +877,11 @@
-
- /* set up our clients queue */
- m_queue = snd_seq_alloc_queue( m_alsa_seq );
--#endif
- #ifdef LASH_SUPPORT
- /* notify lash of our client ID so it can restore connections */
- lash_driver->set_alsa_client_id(snd_seq_client_id(m_alsa_seq));
- #endif
-+#endif
- }
-
-
-
-=== modified file 'src/perform.cpp'
---- old/src/perform.cpp
-+++ new/src/perform.cpp
-@@ -1342,6 +1342,7 @@
- stats_last_clock_us= (last.tv_sec * 1000000) + (last.tv_nsec / 1000);
- #else
- /* get start time position */
-+ /* timeGetTime() returns a "DWORD" type (= unsigned long)*/
- last = timeGetTime();
-
- if ( global_stats )
-
-=== modified file 'src/seq24.cpp'
---- old/src/seq24.cpp
-+++ new/src/seq24.cpp
-@@ -108,12 +108,66 @@
- * GTK+. */
- Gtk::Main kit(argc, argv);
-
-- /* Init the lash driver (strips lash specific command line
-- * arguments, but does not connect to daemon) */
-+ /*prepare global MIDI definitions*/
-+ for ( int i=0; i<c_maxBuses; i++ )
-+ {
-+ for ( int j=0; j<16; j++ )
-+ global_user_midi_bus_definitions[i].instrument[j] = -1;
-+ }
-+
-+ for ( int i=0; i<c_max_instruments; i++ )
-+ {
-+ for ( int j=0; j<128; j++ )
-+ global_user_instrument_definitions[i].controllers_active[j] = false;
-+ }
-+
-+
-+ /* Init the lash driver (strip lash specific command line
-+ * arguments and connect to daemon) */
- #ifdef LASH_SUPPORT
- lash_driver = new lash(&argc, &argv);
- #endif
-
-+ /* the main performance object */
-+ /* lash must be initialized here because mastermidibus uses the global
-+ * lash_driver variable*/
-+ perform p;
-+
-+ /* read user preferences files */
-+ if ( getenv( HOME ) != NULL )
-+ {
-+ Glib::ustring home( getenv( HOME ));
-+ last_used_dir = home;
-+ Glib::ustring total_file = home + SLASH + config_filename;
-+
-+ if (Glib::file_test(total_file, Glib::FILE_TEST_EXISTS))
-+ {
-+ printf( "Reading [%s]\n", total_file.c_str());
-+
-+ optionsfile options( total_file );
-+
-+ if ( !options.parse( &p ) ){
-+ printf( "Error Reading [%s]\n", total_file.c_str());
-+ }
-+ }
-+
-+ total_file = home + SLASH + user_filename;
-+ if (Glib::file_test(total_file, Glib::FILE_TEST_EXISTS))
-+ {
-+ printf( "Reading [%s]\n", total_file.c_str());
-+
-+ userfile user( total_file );
-+
-+ if ( !user.parse( &p ) ){
-+ printf( "Error Reading [%s]\n", total_file.c_str());
-+ }
-+ }
-+
-+ }
-+ else
-+ printf( "Error calling getenv( \"%s\" )\n", HOME );
-+
-+
- /* parse parameters */
- int c;
-
-@@ -229,65 +283,14 @@
- } /* end while */
-
-
-- /*prepare global MIDI definitions*/
-- for ( int i=0; i<c_maxBuses; i++ )
-- {
-- for ( int j=0; j<16; j++ )
-- global_user_midi_bus_definitions[i].instrument[j] = -1;
-- }
--
-- for ( int i=0; i<c_max_instruments; i++ )
-- {
-- for ( int j=0; j<128; j++ )
-- global_user_instrument_definitions[i].controllers_active[j] = false;
-- }
--
--
-- /* the main performance object */
-- perform p;
--
-- p_font_renderer = new font();
--
--
-- if ( getenv( HOME ) != NULL )
-- {
-- Glib::ustring home( getenv( HOME ));
-- last_used_dir = home;
-- Glib::ustring total_file = home + SLASH + config_filename;
--
-- if (Glib::file_test(total_file, Glib::FILE_TEST_EXISTS))
-- {
-- printf( "Reading [%s]\n", total_file.c_str());
--
-- optionsfile options( total_file );
--
-- if ( !options.parse( &p ) ){
-- printf( "Error Reading [%s]\n", total_file.c_str());
-- }
-- }
--
-- total_file = home + SLASH + user_filename;
-- if (Glib::file_test(total_file, Glib::FILE_TEST_EXISTS))
-- {
-- printf( "Reading [%s]\n", total_file.c_str());
--
-- userfile user( total_file );
--
-- if ( !user.parse( &p ) ){
-- printf( "Error Reading [%s]\n", total_file.c_str());
-- }
-- }
--
-- }
-- else
-- printf( "Error calling getenv( \"%s\" )\n", HOME );
--
- p.init();
- p.launch_input_thread();
- p.launch_output_thread();
- p.init_jack();
-
-
-+ p_font_renderer = new font();
-+
- mainwnd seq24_window( &p );
- if (optind < argc)
- {
-@@ -299,8 +302,7 @@
-
- /* connect to lash daemon and poll events*/
- #ifdef LASH_SUPPORT
-- lash_driver->init(&p);
-- lash_driver->start();
-+ lash_driver->start(&p);
- #endif
- kit.run(seq24_window);
-
-
diff --git a/media-sound/seq24/seq24-0.9.2-r1.ebuild b/media-sound/seq24/seq24-0.9.2-r1.ebuild
deleted file mode 100644
index a63621d8a8cb..000000000000
--- a/media-sound/seq24/seq24-0.9.2-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit eutils
-
-DESCRIPTION="Seq24 is a loop based MIDI sequencer with focus on live performances"
-HOMEPAGE="https://edge.launchpad.net/seq24/"
-SRC_URI="https://edge.launchpad.net/seq24/trunk/${PV}/+download/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="jack lash"
-
-RDEPEND="media-libs/alsa-lib
- >=dev-cpp/gtkmm-2.4:2.4
- >=dev-libs/libsigc++-2.2:2
- jack? ( >=media-sound/jack-audio-connection-kit-0.90 )
- lash? ( >=media-sound/lash-0.5 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-DOCS=( AUTHORS ChangeLog README RTC SEQ24 )
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-lash-fix.patch
-}
-
-src_configure() {
- econf \
- $(use_enable jack) \
- $(use_enable lash)
-}
-
-src_install() {
- default
- newicon src/pixmaps/seq24_32.xpm seq24.xpm
- make_desktop_entry seq24
-}