summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-11 01:29:54 +0000
committerSam James <sam@gentoo.org>2022-05-11 01:29:54 +0000
commitfa650a14a85055ca24681cc7eae1a2cdf76e7456 (patch)
tree9c9ebc6293557bee080714849148a3b3528f08fe /media-sound
parentdev-libs/spdlog: Stabilize 1.9.2 ppc64, #835774 (diff)
downloadgentoo-fa650a14a85055ca24681cc7eae1a2cdf76e7456.tar.gz
gentoo-fa650a14a85055ca24681cc7eae1a2cdf76e7456.tar.bz2
gentoo-fa650a14a85055ca24681cc7eae1a2cdf76e7456.zip
media-sound/mumble: backport upstream fixes for new Poco, GCC 12
Closes: https://bugs.gentoo.org/842984 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mumble/files/mumble-1.4.230-gcc12-include-memory.patch28
-rw-r--r--media-sound/mumble/files/mumble-1.4.230-poco-link-cmake.patch24
-rw-r--r--media-sound/mumble/mumble-1.4.230.ebuild2
3 files changed, 54 insertions, 0 deletions
diff --git a/media-sound/mumble/files/mumble-1.4.230-gcc12-include-memory.patch b/media-sound/mumble/files/mumble-1.4.230-gcc12-include-memory.patch
new file mode 100644
index 000000000000..624a8594d995
--- /dev/null
+++ b/media-sound/mumble/files/mumble-1.4.230-gcc12-include-memory.patch
@@ -0,0 +1,28 @@
+https://github.com/mumble-voip/mumble/commit/36398fb3b293fc889bbc38df29665359f5c2a0ca
+
+From: Sergei Trofimovich <slyich@gmail.com>
+Date: Sun, 27 Feb 2022 10:59:57 +0000
+Subject: [PATCH] BUILD(positional-audio): Fix missing <memory> include
+
+Without the change the build fails on upcoming gcc-12 as:
+
+ /build/mumble/plugins/gtav/gtav.cpp:13:13:
+ error: 'unique_ptr' in namespace 'std' does not name a template type
+ 13 | static std::unique_ptr< Game > game;
+ | ^~~~~~~~~~
+ /build/mumble/plugins/gtav/gtav.cpp:12:1:
+ note: 'std::unique_ptr' is defined in header '<memory>';
+ did you forget to '#include <memory>'?
+ 11 | #include <cstring>
+ +++ |+#include <memory>
+ 12 |
+--- a/plugins/gtav/gtav.cpp
++++ b/plugins/gtav/gtav.cpp
+@@ -9,6 +9,7 @@
+ #include "mumble_positional_audio_utils.h"
+
+ #include <cstring>
++#include <memory>
+
+ static std::unique_ptr< Game > game;
+
diff --git a/media-sound/mumble/files/mumble-1.4.230-poco-link-cmake.patch b/media-sound/mumble/files/mumble-1.4.230-poco-link-cmake.patch
new file mode 100644
index 000000000000..d1b4dee11d51
--- /dev/null
+++ b/media-sound/mumble/files/mumble-1.4.230-poco-link-cmake.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/842984
+https://github.com/mumble-voip/mumble/commit/fefdd79ebcd53a3035967789d004938ee39e2030
+
+Fix underlinking against Poco.
+--- a/src/mumble/CMakeLists.txt
++++ b/src/mumble/CMakeLists.txt
+@@ -383,11 +383,16 @@ target_include_directories(mumble
+ "${PLUGINS_DIR}"
+ )
+
+-find_pkg(Poco COMPONENTS Zip)
++find_pkg(Poco
++ COMPONENTS
++ XML
++ Zip
++)
+
+ if(TARGET Poco::Zip)
+ target_link_libraries(mumble
+ PRIVATE
++ Poco::XML
+ Poco::Zip
+ )
+ else()
diff --git a/media-sound/mumble/mumble-1.4.230.ebuild b/media-sound/mumble/mumble-1.4.230.ebuild
index 8ddd32995916..c6c38d8a9fd2 100644
--- a/media-sound/mumble/mumble-1.4.230.ebuild
+++ b/media-sound/mumble/mumble-1.4.230.ebuild
@@ -71,6 +71,8 @@ BDEPEND="
PATCHES=(
"${WORKDIR}/${PN}-1.4-openssl3.patch"
+ "${FILESDIR}/${PN}-1.4.230-gcc12-include-memory.patch"
+ "${FILESDIR}/${PN}-1.4.230-poco-link-cmake.patch"
)
src_prepare() {