summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-11-19 15:17:46 -0500
committerCraig Andrews <candrews@gentoo.org>2018-11-19 15:17:46 -0500
commit1ffcc4a4c0d38a33991d53207d4c992d5524d79d (patch)
tree2dfdb1b1677d795a30d88a3e07572ea3b6673232 /media-tv/kodi/kodi-9999.ebuild
parentmedia-libs/vigra: Fix compilation error and add -9999 (diff)
downloadgentoo-1ffcc4a4c0d38a33991d53207d4c992d5524d79d.tar.gz
gentoo-1ffcc4a4c0d38a33991d53207d4c992d5524d79d.tar.bz2
gentoo-1ffcc4a4c0d38a33991d53207d4c992d5524d79d.zip
media-tv/kodi: Fix overzealous Python 3 warning
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-tv/kodi/kodi-9999.ebuild')
-rw-r--r--media-tv/kodi/kodi-9999.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/media-tv/kodi/kodi-9999.ebuild b/media-tv/kodi/kodi-9999.ebuild
index 9994cd976c35..3fc94b17ea84 100644
--- a/media-tv/kodi/kodi-9999.ebuild
+++ b/media-tv/kodi/kodi-9999.ebuild
@@ -175,12 +175,14 @@ pkg_setup() {
}
src_unpack() {
- python_is_python3 && EGIT_BRANCH="feature_python3"
- ewarn "Using the experimental Python 3 branch!"
- ewarn "See https://kodi.wiki/view/Migration_to_Python_3 for more information."
- ewarn "To use the non-experimental Python 2 version:"
- ewarn "echo '~${CATEGORY}/${P} PYTHON_TARGETS: -* python2_7 PYTHON_SINGLE_TARGET: -* python2_7' >> /etc/portage/package.use"
- ewarn "then re-merge using: emerge -a =${CATEGORY}/${P}"
+ if python_is_python3; then
+ EGIT_BRANCH="feature_python3"
+ ewarn "Using the experimental Python 3 branch!"
+ ewarn "See https://kodi.wiki/view/Migration_to_Python_3 for more information."
+ ewarn "To use the non-experimental Python 2 version:"
+ ewarn "echo '~${CATEGORY}/${P} PYTHON_TARGETS: -* python2_7 PYTHON_SINGLE_TARGET: -* python2_7' >> /etc/portage/package.use"
+ ewarn "then re-merge using: emerge -a =${CATEGORY}/${PF}"
+ fi
git-r3_src_unpack
}