summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-02-01 11:05:20 -0500
committerCraig Andrews <candrews@gentoo.org>2021-02-01 11:07:30 -0500
commit29386f5cbe7532838f7ed9e50528c899b36b261c (patch)
tree69c085997b948aae55bc0654b8bfc7bcf4954031 /media-tv/kodi
parentmedia-tv/kodi: make CMake configuration verbose (diff)
downloadgentoo-29386f5cbe7532838f7ed9e50528c899b36b261c.tar.gz
gentoo-29386f5cbe7532838f7ed9e50528c899b36b261c.tar.bz2
gentoo-29386f5cbe7532838f7ed9e50528c899b36b261c.zip
media-tv/kodi: use CPU_FLAGS_* flags
Compile Kodi according to CPU_FLAGS_* USE expand flags instead of compile-time detected host CPU features Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Evgeny Grin <k2k@narod.ru> Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-tv/kodi')
-rw-r--r--media-tv/kodi/kodi-9999.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/media-tv/kodi/kodi-9999.ebuild b/media-tv/kodi/kodi-9999.ebuild
index 5b80fb84d04c..b752b9ffc6e1 100644
--- a/media-tv/kodi/kodi-9999.ebuild
+++ b/media-tv/kodi/kodi-9999.ebuild
@@ -40,6 +40,7 @@ SLOT="0"
# it is _required_ for USB support. Otherwise they'll disable udev and
# that's going to be worse.
IUSE="airplay alsa bluetooth bluray caps cec +css dav1d dbus dvd gbm gles lcms libressl libusb lirc mariadb mysql nfs +opengl power-control pulseaudio raspberry-pi samba systemd +system-ffmpeg test udf udev udisks upnp upower vaapi vdpau wayland webserver +X +xslt zeroconf"
+IUSE="${IUSE} cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_arm_neon"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
|| ( gles opengl )
@@ -224,6 +225,14 @@ src_configure() {
use X && platform+=( x11 )
local core_platform_name="${platform[@]}"
local mycmakeargs=(
+ -DENABLE_SSE=$(usex cpu_flags_x86_sse)
+ -DENABLE_SSE2=$(usex cpu_flags_x86_sse2)
+ -DENABLE_SSE3=$(usex cpu_flags_x86_sse3)
+ -DENABLE_SSE4_1=$(usex cpu_flags_x86_sse4_1)
+ -DENABLE_SSE4_2=$(usex cpu_flags_x86_sse4_2)
+ -DENABLE_AVX=$(usex cpu_flags_x86_avx)
+ -DENABLE_AVX2=$(usex cpu_flags_x86_avx2)
+ -DENABLE_NEON=$(usex cpu_flags_arm_neon)
-Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
-DVERBOSE=ON
-DENABLE_LDGOLD=OFF # https://bugs.gentoo.org/show_bug.cgi?id=606124