summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-tv/shoutcast2vdr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-tv/shoutcast2vdr')
-rw-r--r--media-tv/shoutcast2vdr/Manifest1
-rw-r--r--media-tv/shoutcast2vdr/metadata.xml12
-rw-r--r--media-tv/shoutcast2vdr/shoutcast2vdr-0.0.8-r1.ebuild33
-rw-r--r--media-tv/shoutcast2vdr/shoutcast2vdr-0.0.8.ebuild34
4 files changed, 80 insertions, 0 deletions
diff --git a/media-tv/shoutcast2vdr/Manifest b/media-tv/shoutcast2vdr/Manifest
new file mode 100644
index 000000000000..2a270638a50f
--- /dev/null
+++ b/media-tv/shoutcast2vdr/Manifest
@@ -0,0 +1 @@
+DIST shoutcast2vdr-0.0.8.gz 3538 SHA256 fa63f656ea5a0f25794337e26aac0bedf74f2758bef65bf51ffb750c326bb227 SHA512 ae5ce60c993ff85b3ac9ab3567be55a22ad1929b98a035b323583fa6166b21a96bd7e7017917865d4a339790e7d6c1113820d7230787225d97c68e2174f02c37 WHIRLPOOL 322ea24c91ca63e1629656d0df05400a56296854305aa41274211eabc8a1143bd766d571c4b7922193df23dc8be65830df6970457b18f451f6ede8443c9007b5
diff --git a/media-tv/shoutcast2vdr/metadata.xml b/media-tv/shoutcast2vdr/metadata.xml
new file mode 100644
index 000000000000..d1b88e6872a7
--- /dev/null
+++ b/media-tv/shoutcast2vdr/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-tv/shoutcast2vdr/shoutcast2vdr-0.0.8-r1.ebuild b/media-tv/shoutcast2vdr/shoutcast2vdr-0.0.8-r1.ebuild
new file mode 100644
index 000000000000..3c43bf1f0fb4
--- /dev/null
+++ b/media-tv/shoutcast2vdr/shoutcast2vdr-0.0.8-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="VDR script: generate shoutcast playlists"
+HOMEPAGE="http://www.vdr-portal.de/board/thread.php?threadid=19478"
+SRC_URI="http://www.kost.sh/vdr/${P}.gz"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="media-video/vdr"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+PLAYLIST_DIR="/var/cache/vdr/music/playlists"
+
+src_prepare() {
+ sed -i shoutcast2vdr-0.0.8 -e "s:outputdir=/home/volker/vdr/radio:outputdir=${PLAYLIST_DIR}:"
+
+ # wrt bug 520624
+ sed -i shoutcast2vdr-0.0.8 -e "s:mkdir:mkdir -p:"
+}
+
+src_install() {
+ exeinto /usr/share/vdr/shoutcast2vdr
+ newexe shoutcast2vdr-0.0.8 shoutcast2vdr
+}
diff --git a/media-tv/shoutcast2vdr/shoutcast2vdr-0.0.8.ebuild b/media-tv/shoutcast2vdr/shoutcast2vdr-0.0.8.ebuild
new file mode 100644
index 000000000000..a30c7348cd53
--- /dev/null
+++ b/media-tv/shoutcast2vdr/shoutcast2vdr-0.0.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="VDR script: generate shoutcast playlists"
+HOMEPAGE="http://www.vdr-portal.de/board/thread.php?threadid=19478"
+SRC_URI="http://www.kost.sh/vdr/${P}.gz"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="media-video/vdr"
+
+S="${WORKDIR}"
+
+PLAYLIST_DIR="/var/cache/vdr/music/playlists"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ sed -i shoutcast2vdr-0.0.8 -e "s:outputdir=/home/volker/vdr/radio:outputdir=${PLAYLIST_DIR}:"
+}
+
+src_install() {
+
+ exeinto /usr/share/vdr/shoutcast2vdr
+ newexe shoutcast2vdr-0.0.8 shoutcast2vdr
+
+ keepdir ${PLAYLIST_DIR}
+}