summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-10-24 21:20:30 +0100
committerJames Le Cuirot <chewi@gentoo.org>2021-10-24 21:22:29 +0100
commit066042ef9ddb39008ef658d30602486a95263b3a (patch)
treece205cae0cb70981fc97fac7ecc8ab25487dcdb9 /media-tv
parentmedia-libs/libv4l: Version bump to 1.22.1, EAPI 8 (diff)
downloadgentoo-066042ef9ddb39008ef658d30602486a95263b3a.tar.gz
gentoo-066042ef9ddb39008ef658d30602486a95263b3a.tar.bz2
gentoo-066042ef9ddb39008ef658d30602486a95263b3a.zip
media-tv/v4l-utils: Version bump to 1.22.1, EAPI 8
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/v4l-utils/Manifest1
-rw-r--r--media-tv/v4l-utils/v4l-utils-1.22.1.ebuild110
2 files changed, 111 insertions, 0 deletions
diff --git a/media-tv/v4l-utils/Manifest b/media-tv/v4l-utils/Manifest
index 8ad11332de46..b7cae8ef2396 100644
--- a/media-tv/v4l-utils/Manifest
+++ b/media-tv/v4l-utils/Manifest
@@ -1 +1,2 @@
DIST v4l-utils-1.20.0.tar.bz2 2030419 BLAKE2B 218082b88c42dcb9da3dbdd81b184c0e7402ca7ba35678a2905e16c11db1fe7065a19ec84b5fd57e2ed4718965c3e8097f8e8bdd04a38a485716efe3ec62e42a SHA512 179ca8dbbf7af5fa4870b70f17645d7834fe6ba52670ae6b58473efa257db0cd812ce14f16574cc4491c0bcb218835e4c29f1354882a151687eecec97852fc63
+DIST v4l-utils-1.22.1.tar.bz2 2086238 BLAKE2B a3f01a17ea7c8925c74dd883d30b42f54b7926d253dac79e4cadaba43abc33672804257b3b92e5aa640ead6b5aaaa2458f05e21642044d7dea77e5580a8dbe9a SHA512 8a634d8995d13f453dfaf90ca5d0dfb26f2f4b10a0d200d76a949c46f77040d12fc0a5b35e05d7b1ba68bcfc85a445be5a5ab1d4a7d4eabfe3a254038ccc6170
diff --git a/media-tv/v4l-utils/v4l-utils-1.22.1.ebuild b/media-tv/v4l-utils/v4l-utils-1.22.1.ebuild
new file mode 100644
index 000000000000..65a827a5b6d4
--- /dev/null
+++ b/media-tv/v4l-utils/v4l-utils-1.22.1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs udev xdg
+
+DESCRIPTION="Separate utilities ebuild from upstream v4l-utils package"
+HOMEPAGE="https://git.linuxtv.org/v4l-utils.git"
+SRC_URI="https://linuxtv.org/downloads/v4l-utils/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+bpf dvb opengl qt5 +udev"
+
+RDEPEND="
+ >=media-libs/libv4l-${PV}[dvb?,jpeg]
+ >=virtual/jpeg-0-r2:0=
+ bpf? ( virtual/libelf:= )
+ udev? ( virtual/libudev )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ opengl? ( dev-qt/qtopengl:5[-gles2(-)] virtual/opengl )
+ media-libs/alsa-lib
+ )
+ !media-tv/v4l2-ctl
+ !<media-tv/ivtv-utils-1.4.0-r2
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+ bpf? ( sys-devel/clang:*[llvm_targets_BPF] )
+"
+
+# Not really prebuilt but BPF objects make our QA checks go crazy.
+QA_PREBUILT="*/rc_keymaps/protocols/*.o"
+
+check_llvm() {
+ if [[ ${MERGE_TYPE} != binary ]] && use bpf; then
+ local clang=${ac_cv_prog_CLANG:-${CLANG:-clang}}
+ ${clang} -target bpf -print-supported-cpus &>/dev/null ||
+ die "${clang} does not support the BPF target. Please check LLVM_TARGETS."
+ fi
+}
+
+pkg_pretend() {
+ has_version -b sys-devel/clang && check_llvm
+}
+
+pkg_setup() {
+ check_llvm
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ if use qt5; then
+ local qt5_paths=( \
+ MOC="$($(tc-getPKG_CONFIG) --variable=host_bins Qt5Core)/moc" \
+ UIC="$($(tc-getPKG_CONFIG) --variable=host_bins Qt5Core)/uic" \
+ RCC="$($(tc-getPKG_CONFIG) --variable=host_bins Qt5Core)/rcc" \
+ )
+ if ! use opengl; then
+ sed -e 's/Qt5OpenGL/DiSaBlEd/g' -i configure || die
+ fi
+ fi
+
+ # Hard disable the flags that apply only to the libs.
+ econf \
+ --disable-static \
+ $(use_enable dvb libdvbv5) \
+ $(use_enable qt5 qv4l2) \
+ $(use_enable qt5 qvidcap) \
+ $(use_enable bpf) \
+ --with-jpeg \
+ $(use_with udev libudev) \
+ --with-udevdir="$(get_udevdir)" \
+ "${qt5_paths[@]}"
+}
+
+src_install() {
+ emake -C utils DESTDIR="${D}" install
+ emake -C contrib DESTDIR="${D}" install
+
+ dodoc README
+ newdoc utils/libv4l2util/TODO TODO.libv4l2util
+ newdoc utils/libmedia_dev/README README.libmedia_dev
+ newdoc utils/dvb/README README.dvb
+ newdoc utils/v4l2-compliance/fixme.txt fixme.txt.v4l2-compliance
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if [[ -n ${REPLACING_VERSIONS} ]] && ver_test 1.20.0 -ge ${REPLACING_VERSIONS%% *}; then
+ ewarn "WARNING! ir-keytable has changed significantly from version 1.20.0 so"
+ ewarn "you may need to take action to avoid breakage. See"
+ ewarn "https://bugs.gentoo.org/767175 for more details."
+ fi
+}