summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-06-25 09:34:34 -0400
committerCraig Andrews <candrews@gentoo.org>2021-06-25 09:35:00 -0400
commit0e9e4120aff7a0bc400e9823f0ca24c08c97abd4 (patch)
tree3659e935afdc22fc879b238204ca7ffc199c4c8a /media-tv
parentsci-libs/vtk: drop 8.2.0-r3 (diff)
downloadgentoo-0e9e4120aff7a0bc400e9823f0ca24c08c97abd4.tar.gz
gentoo-0e9e4120aff7a0bc400e9823f0ca24c08c97abd4.tar.bz2
gentoo-0e9e4120aff7a0bc400e9823f0ca24c08c97abd4.zip
media-tv/kodi: support fmt 8
Closes: https://bugs.gentoo.org/797619 See: https://github.com/xbmc/xbmc/pull/19904 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/kodi/files/kodi-19.1-fmt-8.patch28
-rw-r--r--media-tv/kodi/kodi-19.1.ebuild4
2 files changed, 32 insertions, 0 deletions
diff --git a/media-tv/kodi/files/kodi-19.1-fmt-8.patch b/media-tv/kodi/files/kodi-19.1-fmt-8.patch
new file mode 100644
index 000000000000..ea82d007910d
--- /dev/null
+++ b/media-tv/kodi/files/kodi-19.1-fmt-8.patch
@@ -0,0 +1,28 @@
+https://github.com/xbmc/xbmc/pull/19904
+
+From 18ff80a9c169fb969b75e2143d9f1f234b71a730 Mon Sep 17 00:00:00 2001
+From: Craig Andrews <candrews@integralblue.com>
+Date: Thu, 24 Jun 2021 20:41:11 -0400
+Subject: [PATCH] [utils] include fmt/xchar.h
+
+fmt 8 moved wchar/custom char overloads to xchar.h, so for fmt 8 compatibility, xchar.h must be included
+
+See https://github.com/fmtlib/fmt/commit/76ee490468212f8705a1421b4c88f8f814b2d351
+---
+ xbmc/utils/StringUtils.h | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/xbmc/utils/StringUtils.h b/xbmc/utils/StringUtils.h
+index ca6f82953d90a..2dc5c3f03af2f 100644
+--- a/xbmc/utils/StringUtils.h
++++ b/xbmc/utils/StringUtils.h
+@@ -36,6 +36,9 @@
+ #if FMT_VERSION >= 40000
+ #include <fmt/printf.h>
+ #endif
++#if FMT_VERSION >= 80000
++#include <fmt/xchar.h>
++#endif
+
+ #include "XBDateTime.h"
+ #include "utils/params_check_macros.h"
diff --git a/media-tv/kodi/kodi-19.1.ebuild b/media-tv/kodi/kodi-19.1.ebuild
index 11329e6f4706..d8e43ce073b2 100644
--- a/media-tv/kodi/kodi-19.1.ebuild
+++ b/media-tv/kodi/kodi-19.1.ebuild
@@ -30,6 +30,10 @@ else
S=${WORKDIR}/xbmc-${MY_PV}
fi
+PATCHES=(
+ "${FILESDIR}/${P}-fmt-8.patch"
+)
+
inherit autotools cmake desktop linux-info pax-utils python-single-r1 xdg
DESCRIPTION="A free and open source media-player and entertainment hub"